LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   HP Deskjet 3050A in Debian Testing. Scanner not working. (http://www.linuxquestions.org/questions/showthread.php?t=4175445198)

yzT! 01-11-2013 07:01 PM

HP Deskjet 3050A in Debian Testing. Scanner not working.
 
Hi guys!

I'm facing a problem with my All-in-one printer. It prints but it doesn't scan. I've tried SANE and Simple Scan, both detect the scanner but when trying to scan there is an I/O error.

My system is running Debian Testing 64 bits. I have tried in Linux Mint 14 and Windows 7, both virtual machines as guest of the Debian Testing, and the scanner works perfectly there, so the problem must be in some kind of configuration in Debian.

frankbell 01-11-2013 07:40 PM

Have you installed HPLIP? It's in the repos.

If you want the GUI (hp-toolbox), it's a separate package.

HPLIP has worked flawlessly to set up my HP printer on Debian, Slackware, Ubuntu, and Mint.

yzT! 01-12-2013 04:58 AM

yep, I have hplip.

DuskGlow 01-12-2013 05:02 AM

Can you please past output from 'scanimage -L' and 'scanimage -T'? Also 'lsusb' and 'ls -l /dev/bus/usb/number/of/the/printer'?

This may be related to my problem http://www.linuxquestions.org/questi...nt-4175444547/ .

Shadow_7 01-12-2013 06:54 AM

Have you tried copying the configuration from the distros that worked for you. I've never used the scanning option in linux. (stupid windows only printer things)

But I've had a few HP printers. And for hplip you also need the pnm2ppa package which never seemed to be grabbed as a dependency in debian for me. Without it, printing never worked for me, even though everything configuration wise was fine. A simple apt-get of that one package got my printing working all those years ago.

# apt-get install pnm2ppa

I'm not entirely sure if it's that package, it has been a very long time. But I'm 85%-ish sure it is, at least for printing. And oddly still not listed as a dependency in a current debian sid install.

Something to do with interpretation for the language that HP printers speak. Legacied back to the old ghostscript way when HP had two drivers, one for lasers(HPOJ) and one for inkjets. With an infinite amount of frustration with my HP printer at that time. Which in the end came down to the thing not having enough ink left in the cartridge (I had to boot windows to be told that though). The linux drivers at that time gave no such indication, they just failed to do anything useful. But that was five plus years ago to be fair.

yzT! 01-12-2013 09:41 AM

Quote:

Originally Posted by DuskGlow (Post 4868304)
Can you please past output from 'scanimage -L' and 'scanimage -T'? Also 'lsusb' and 'ls -l /dev/bus/usb/number/of/the/printer'?

This may be related to my problem http://www.linuxquestions.org/questi...nt-4175444547/ .

Code:

scanimage -L
device `hpaio:/usb/Deskjet_3050A_J611_series?serial=CN18B4D1JB05PJ' is a Hewlett-Packard Deskjet_3050A_J611_series all-in-one

scanimage -T
scanimage: open of device hpaio:/usb/Deskjet_3050A_J611_series?serial=CN18B4D1JB05PJ failed: Error during device I/O

lsusb
Bus 002 Device 002: ID 03f0:a011 Hewlett-Packard Deskjet 3050A

ls -l /dev/bus/usb/002/002
crw-rw-r-T+ 1 root lp 189, 129 Jan 12 15:36 /dev/bus/usb/002/002

I have tried add my user to lp group and also tried to scan as root, same result.


Shadow_7 I have:
Code:

apt-cache policy printer-driver-pnm2ppa
printer-driver-pnm2ppa:
  Installed: 1.13-4
  Candidate: 1.13-4
  Version table:
 *** 1.13-4 0
        500 http://ftp.es.debian.org/debian/ testing/main amd64 Packages
        100 /var/lib/dpkg/status

Anyway this package seems to be for printing. I can print what I can't is scan.

Which config files? Do you know?

Shadow_7 01-12-2013 12:31 PM

I don't have any linux compatible scanners at the moment. But man sane hints at stuff as does dpkg-deb -c <package.deb> against stuff in /var/cache/apt/archives/.

#dpkg-query --load-avail -l '*sane*hp*'

#apt-get install libsane-hpaio
(that seems to be the driver for the device, for the scanning side)

See if that helps. There was a patch against that package specific to that scanner in January of 2012, so get a recent version if you can. Which might mean using something more recent than stable or testing. Or using another apt source like backports.

Edit: Doh! I should read more of your post before responding. ofc you have that package. But that patch I referenced might be the catch. Also make sure the lp group is active "groups". You have to su or relog to add groups to your current session.

yzT! 01-13-2013 05:08 AM

Seems that I have the latest package.

libsane-hpaio:
Installed: 3.12.6-3
Candidate: 3.12.6-3

It's the same version as in Debian Unstable http://packages.debian.org/sid/libsane-hpaio

yzT! 01-16-2013 08:58 AM

Still I'm struggling with this...

Any tip else?

Shadow_7 01-24-2013 11:06 AM

Just a thought based on the results from this:

$ strings /usr/lib/sane/libsane-hpaio.so.1.0.0 | grep -i "\.so"

libhpip.so.0
libhpmud.so.0
libdbus-1.so.3
libcups.so.2
libdl.so.2
libcrypto.so.1.0.0
libc.so.6
libsane-hpaio.so.1
libhpmud.so
libhpmud.so.0
libm.so
libm.so.6
bb_marvell.so
bb_soapht.so
bb_soap.so

Which implies, if not actually grabbed as dependancies. Stranger things have happened.

# apt-get install libhpmud0 libhpmud-dev libdbus-1-3 libcups2 libssl1.0.0 libc6 libc6-dev

It looks like libhpmud-dev was the only one not grabbed on my system. Which is needed for libhpmud.so without any additional . stuff. Well the only exists but not grabbed on my system. I didn't find any reference for the bb_ libs. Except maybe openhpi for soap, but not an exact match naming wise. And also not installed by default.

Baring that you might be looking at compiling from sources, running another distro, or other tricks like some of the ones for ldconfig. Perhaps a chroot for a distro that works (relative to your scanner) might suit your needs for now. Still just guessing for all intents until you have a solution.

yzT! 02-06-2013 05:02 AM

I ended configuring the printer as network printer.

Using usb:
- Installing by hplips: I/O error in both printer and scanner
- Installing by cups: print works but scanner doesn't.


All times are GMT -5. The time now is 06:38 AM.