LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   HP/Compaq D510 SFF, BIOS, boot from Compact Flash (http://www.linuxquestions.org/questions/showthread.php?t=4175475853)

nedlud 09-04-2013 08:01 AM

HP/Compaq D510 SFF, BIOS, boot from Compact Flash
 
I have bought three HP/Compaq D510 desktop units to use as servers: one at home, the others at friends' places, for remote backup, bittorent, running freenet nodes, etc.

They seem ideal. Available for 30 on ebay. I have flashed the latest BIOS (2.21), added max RAM (2GB), SATA card and large SATA HDs to each of them.

I am (trying to) use a CF card with IDE adaptor for the OS (CentOS minimal).

This works fine with 2 of the 3 boxes. Although they are ostensibly identical, the 2 on which it works are "HP" on the factory barcode label, and the one on which it doesn't work is "Compaq". The baked in asset no's are also of a different format.

On the Compaq I can install the OS to the CF card, but it will not boot. System hangs at "Attempting to boot from hard drive (C:)"

So it seems there are subtle differences between the Compaq and HP models. In addition, I cannot get the Compaq one to boot without a keyboard.

I have checked all the BIOS settings. I have diff'd the output of dmidecode, and they are the same excepting asset numbers.

I have tried to "Save to Diskette" the BIOS settings from a working HP, but every time I get a BIOS message saying "Removable Media is bad or missing". I have tried four floppies, and while they may all be degraded through age, I don't think so.

Does anyone know if there are in fact differences between the HP and Compaq versions, or have any ideas about what else I could try?

jefro 09-06-2013 03:54 PM

A system that can boot to an IDE drive should also be able to boot to a proper CF card and proper adapter. The system should not know the difference between a real hard drive and that.

Issues may be that the CF card isn't fully compliant with ide. The CF to ide adapter isn't fully compliant with bootable standard. Test a known working CF and adapter on this subject system and see what happens. Be sure to swap the ide cable too in this test.

Yes, Compaq and HP could be very much different. Even same make, same model and fru number board and even same revision number could have very different features/oddities.

Some of these adapters may have jumpers for voltages and dma and things.

nedlud 09-14-2013 11:58 AM

I should have made clear that I am using identical CF cards, CF/IDE adaptors and jumper settings. Further, I had tried a card / adaptor combination from one of the working (bootable) boxes, and the result was the same.

I am plugging the adaptor diretly into the IDE conector on the MOBO.

Today I booted the box from a regular IDE HD, successfully, then tried the CF card again, which also worked. So the issue seems to have been chased away. Today as before the BIOS "noticed" the hardware change on boot and I pressed F1 to accept the changes.

I won't mark this as solved just yet, as I don't know what has been going on.

I am surprised (well, disappointed) that there can be significant, or any variation between supposedly identical examples of the same PC. Corporates who buy in large numbers want them to be identical, don't they?

nedlud 09-15-2013 07:56 AM

AAARGH!!

It boots to CF with the SATA drives power disconnected, but not with them powered.

Neither of the SATA disks have bootable partitions.

I have checked (I think) all the relevant BIOS settings. On all three boxes I started with default BIOS settings and only changed the same few. The SATA cards are identical.


All times are GMT -5. The time now is 01:31 AM.