LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 10-01-2012, 05:16 PM   #1
wakatana
Member
 
Registered: Jul 2009
Location: Slovakia
Posts: 133

Rep: Reputation: 16
HP Compaq 6710 - Intel(R) PRO/Wireless 3945ABG/BG


Hi gurus,
I am trying make wireless card working but I am stuck. Tried following:

Hardware button for wifi is enabled (wifi led lights):
Code:
[root@HP-PC ~]# modprobe -r iwl3945
[root@HP-PC ~]# modprobe iwl3945

[root@HP-PC ~]# ifconfig wlan0 up
SIOCSIFFLAGS: No such device

[root@HP-PC ~]# ifup wlan0
/sbin/ifup: configuration for wlan0 not found.
Usage: ifup <device name>

[root@HP-PC network-scripts]# dmesg | tail -n 30
[ 2044.351583] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
[ 2044.351717] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 2044.353597] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 2044.353840] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 2642.444831] cfg80211: Calling CRDA to update world regulatory domain
[ 2642.458065] cfg80211: World regulatory domain updated:
[ 2642.458068] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2642.458072] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2642.458075] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2642.458077] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 2642.458080] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2642.458083] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 2642.458570] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
[ 2642.458572] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 2642.499392] iwl3945 0000:10:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 2642.499395] iwl3945 0000:10:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 2642.499546] iwl3945 0000:10:00.0: irq 46 for MSI/MSI-X
[ 2642.499755] Registered led device: phy0-led
[ 2642.499917] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 2642.514681] cfg80211: Calling CRDA for country: SK
[ 2642.530901] cfg80211: Regulatory domain changed to country: SK
[ 2642.530905] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 2642.530908] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 2642.530911] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 2642.530913] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 2642.530916] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[ 2642.582149] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
[ 2642.582286] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 2642.584171] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 2642.584380] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch



Hardware button for wifi is disabled (wifi led is grey):

Code:
[root@HP-PC ~]# modprobe -r iwl3945
[root@HP-PC ~]# modprobe iwl3945

[root@HP-PC ~]# ifconfig wlan0 up
SIOCSIFFLAGS: Operation not possible due to RF-kill

[root@HP-PC ~]# ifup wlan0
/sbin/ifup: configuration for wlan0 not found.
Usage: ifup <device name>

[root@HP-PC ~]# dmesg | tail -n 30
[ 2990.504120] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 2990.504122] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)
[ 2990.546605] iwl3945 0000:10:00.0: loaded firmware version 15.32.2.9
[ 2990.546734] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 2990.548546] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 2990.548821] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 3125.283057] iwl3945 0000:10:00.0: Radio disabled by HW RF Kill switch
[ 3241.454124] usb 3-1: USB disconnect, device number 4
[ 3250.626608] cfg80211: Calling CRDA to update world regulatory domain
[ 3250.633326] cfg80211: World regulatory domain updated:
[ 3250.633329] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 3250.633332] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3250.633335] cfg80211:   (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 3250.633338] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
[ 3250.633341] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3250.633343] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
[ 3250.639383] iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, in-tree:ds
[ 3250.639386] iwl3945: Copyright(c) 2003-2011 Intel Corporation
[ 3250.680265] iwl3945 0000:10:00.0: Tunable channels: 13 802.11bg, 23 802.11a channels
[ 3250.680270] iwl3945 0000:10:00.0: Detected Intel Wireless WiFi Link 3945ABG
[ 3250.680432] iwl3945 0000:10:00.0: irq 46 for MSI/MSI-X
[ 3250.680639] Registered led device: phy0-led
[ 3250.680788] ieee80211 phy0: Selected rate control algorithm 'iwl-3945-rs'
[ 3250.699498] cfg80211: Calling CRDA for country: SK
[ 3250.705479] cfg80211: Regulatory domain changed to country: SK
[ 3250.705483] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
[ 3250.705486] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 3250.705489] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 3250.705491] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm)
[ 3250.705494] cfg80211:   (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm)

Also in both cases tried:
Code:
[root@HP-PC ~]#  rfkill unblock all


This seems weird because AFAIK "Radio disabled by HW RF Kill switch" means that wifi is disabled by hardware swtich. But this message appers in dmsg when hardware switch was on.

CONFIGURATION:

PC:
HP Compaq 6710b

WLAN Card:
Code:
[root@HP-PC network-scripts]# iwconfig 
p3p1      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11abg  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
Code:
[root@HP-PC network-scripts]# lshw -C network
  *-network DISABLED      
       description: Wireless interface
       product: PRO/Wireless 3945ABG [Golan] Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:10:00.0
       logical name: wlan0
       version: 02
       serial: 00:1c:bf:2f:9d:e1
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwl3945 driverversion=3.4.11-1.fc16.x86_64 firmware=15.32.2.9 latency=0 link=no multicast=yes wireless=IEEE 802.11abg
       resources: irq:46 memory:e4100000-e4100fff
Code:
[root@HP-PC network-scripts]# lspci  | grep Wireless
10:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)


Software:
Code:
[root@HP-PC network-scripts]# uname -a
Linux HP-PC 3.4.11-1.fc16.x86_64 #1 SMP Sun Sep 16 13:50:06 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[root@HP-PC network-scripts]# cat /etc/redhat-release 
Fedora release 16 (Verne)

HP Compaq 6710 - Intel(R) PRO/Wireless 3945ABG/BG
 
Old 10-02-2012, 04:54 AM   #2
padeen
Member
 
Registered: Sep 2009
Location: Perth, W.A.
Distribution: Slackware 14, Debian 7, FreeBSD, OpenBSD
Posts: 158

Rep: Reputation: 32
On my (admittedly different model) Presario C700, I managed to get into this situation and couldn't find an easy solution. I opted for the easy fix by booting to Vista, manually pressing the hardware switch and testing connectivity to make sure it was damned well enabled, then rebooting back to Linux. It worked after that.

From my experiments, it seems as though the hardware switch setting survives over boots (i.e. it is not reset by the BIOS). If you don't have Windows any more, perhaps try playing with the switch so it is on, then rebooting. (I also was not able to rmmod or modprobe the relevant modules, hence the need to reboot every time.)
 
Old 10-02-2012, 09:59 AM   #3
wakatana
Member
 
Registered: Jul 2009
Location: Slovakia
Posts: 133

Original Poster
Rep: Reputation: 16
Hmm this is strange, any idea how to check if wireless NIC is not physically damaged ?
 
Old 10-03-2012, 02:45 PM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,959

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
I have a HP Compaq 6715S - same sort of thing, I imagine, but mine's all AMD/ATI/ with Broadcom nic & wifi. If my experience is anything to go by, leave the <expletive deleted> button on at all times

If you have encryption, there's wpa_passphrase which is the best kept secret for setting up the psk you really need. Otherwise search these forums for commands, and www.linuxwireless.org.

Try This
http://wiki.linuxquestions.org/wiki/...l_area_network
 
Old 10-03-2012, 05:26 PM   #5
wakatana
Member
 
Registered: Jul 2009
Location: Slovakia
Posts: 133

Original Poster
Rep: Reputation: 16
Thanks for reply, I will try it ASAP but as far as I can quickly see links you have posted the command "wlan0 scanning" simply wont working because "ifconfig wlan0 up" is not working also. What do you mean by "leave the <expletive deleted> button on at all times" (sorry for my english). Also seems that problem is also on W7, neither windows nor netstrumbler software simply wont scan netowrks. Netstrumbler also report some error message regarding adapter. In windows seems that everything is installed, I tried also download official drivers from intel on windows, no luck. Regards
 
Old 10-03-2012, 08:56 PM   #6
padeen
Member
 
Registered: Sep 2009
Location: Perth, W.A.
Distribution: Slackware 14, Debian 7, FreeBSD, OpenBSD
Posts: 158

Rep: Reputation: 32
I agree with business_kid: once you have wireless working, leave the button alone! Take wireless offline by using ifconfig, not the button.

If it is not working in W7 either, it isn't a Linux problem. Could be misconfigured, a hardware problem , or even your router's set up (can other computer's connect to the wireless router?).

When in W7, can you check the Event Log (or whatever it is called in W7) to see if any errors happen when you press the button on and off. Does the button light change colour? Does Hardware Manager show an error on the wireless card?
 
Old 10-04-2012, 03:36 AM   #7
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,959

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
leave the button on, that's what I mean.

the 'expletive deleted' thing goes back to Richard Nixon, some American, in the 1970s.
http://en.wikipedia.org/wiki/Expletive_deleted
 
Old 11-06-2012, 05:26 PM   #8
wakatana
Member
 
Registered: Jul 2009
Location: Slovakia
Posts: 133

Original Poster
Rep: Reputation: 16
Problem solved
LAN/WLAN switching have to be turned off in the BIOS settings
http://www.linlap.com/wiki/hp-compaq+6710b
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel Pro Wireless 3945ABG Debian Help jaredhocutt Linux - Newbie 7 01-24-2010 10:22 PM
Intel PRO/Wireless 3945ABG not working!! geek_man Suse/Novell 5 01-20-2008 11:25 AM
Intel PRO Wireless 3945ABG: Help! LDJ Linux - Newbie 13 09-21-2007 05:21 AM
Fedora 7 + intel PRO/Wireless 3945ABG :( adam_blackice Linux - Wireless Networking 9 08-13-2007 11:48 AM
Problem - Intel Intel(R) PRO/Wireless 3945ABG suresheva31 Fedora 2 09-18-2006 07:45 PM


All times are GMT -5. The time now is 02:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration