LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   How to open ports on D-Link router (https://www.linuxquestions.org/questions/linux-hardware-18/how-to-open-ports-on-d-link-router-207446/)

TazG 07-20-2004 11:22 AM

How to open ports on D-Link router
 
Hi I have a D-Link "DI-604" router and I have to open ports 6891 to 6900 so I can send files over MSN... how would I do this?

rjcrews 07-20-2004 11:27 AM

should be here

http://www.dlink.com/products/?pid=62

Bebo 07-20-2004 11:46 AM

I've never used MSN so I don't know how it establishes connections, but I do have a DI-604... Browse away to your router (should be at 192.168.0.1) and log in as admin. Check under Advanced and then Virtual Server. There you can easily translate ports to your heart's content :) However, it might be more useful to configure some stuff under Applications but I haven't done anything there, so I don't really have anything useful to say in that case.

Err, hope this helped...a little :)

TazG 07-20-2004 12:22 PM

Um, now I'm a little confused. Changing things in 192.168.0.1 affects the whole network right? The other computers can use MSN no problem and I can use it on this computer from in Windows.
There must be settings about ports in Linux...?
If it seems like I don't know what I'm talking about it's because I don't - someone in the software forum just told me to "open ports 6891 - 6900"... because when I tried to send a file with aMSN it said "Listening on port 6891" and didn't work.
And that's all I really know.

Bebo 07-20-2004 02:37 PM

Aha, ok, so you have succeeded with the same computer in Windows. Then - if you do know that you can connect to the internet from within Linux (surfing for instance) - it is probably your firewall and/or some tcp wrappers stopping you. To check the settings for the firewall, issue iptables -nvL and see if there are any rules dropping some connections - or maybe just not explicitly allowing them, in case of a DROP policy. The rules for tcp wrappers are in /etc/hosts.allow and /etc/hosts.deny, with hosts.deny having a higher priority than hosts.allow. See what you can find there.

TazG 07-20-2004 03:38 PM

Hi, iptables is not installed and there is no /etc/hosts.allow or /etc/hosts.deny.

Bebo 07-20-2004 03:42 PM

OK... Then you should be completely open to the internet (not good) and should be able to connect to whatever you want... I'm at a loss here, unfortunately.


All times are GMT -5. The time now is 03:59 PM.