-   Linux - Hardware (
-   -   How to know if touchpad supports synaptics driver? (

Mikro 03-04-2009 10:28 AM

How to know if touchpad supports synaptics driver?
Hi, recently bought a netbook, installed Slackware 12.1 and started configuring. Touchpad is being detected as ImExPS/2

I: Bus=0011 Vendor=0002 Product=0006 Version=0000
N: Name="ImExPS/2 Generic Explorer Mouse"
P: Phys=isa0060/serio2/input0
S: Sysfs=/class/input/input4

Tried a lot of things to make Synaptics driver to work, no success. Is there a way to know if this device is supported by Synaptics drivers? Vendor and Product IDs won't lead me anywhere, at least couldn't find any web page to get the manufacturer with those numbers.

When Synaptics probes the device at X start, device is not recognized and module is unloaded, the generic module to be then loaded with more or less good performace (erratic, bad accuracy). I know sometimes Synaptics driver loading can be tricky, but really would like to know if I am loosing my time trying to set up a driver that won't work with this hardware. Is there a way to find this out? Thanks in advance.


int0x80 03-04-2009 11:11 AM

Trying to keep it simple, did you attempt googling for your netbook model and synaptics?

elliott678 03-04-2009 11:27 AM

Some current netbooks have an Elantech touchpad, I think the MSI does, I know the newer EeePCs do. This will work with the Synaptics drivers, but I think it requires a kernel patch for older kernels, I believe 2.6.28 has the proper driver built in.

Mikro 03-05-2009 07:28 AM

The netbook is a MALATA 81005 clon, named by the reseller as Blu::sens FreePC 10P Already searched the web, no specific data on the touchpad. I am using a self compiled kernel, with synaptics and elantech support built in.

Used also lshw and I can't find any clue if synaptics should work.

The vendor doesn't offer any touchpad driver, so I can't even read the windows inf's too look in the original driver.

smalldog 06-20-2009 08:00 AM

I have same problem. However, it works properly as a mouse except without scrolling. Of course, I also googled around the net but without luck:cry:

Dow Franklin Dudley 08-18-2009 01:26 PM

I have a Malata PC-80016 and none of the material that came with the computer lists the touch pad make or manufacturer. The BIOS is "Insyde" and Insyde's site simply refers you to the manufacturer if you are an end-user. The English language version of the Malata site only lists company and product information. The Chinese language site does have a support page that has driver downloads, but they are for Windows XP, Windows Vista, an update to the wireless driver, and an upgrade to the Vista wireless driver. "Crazy L" a blogger in Hong Kong complained about the lack of a proper touch driver as well--I think he may have looked through the drivers as well. The original Linpus OS was based on Fedora 8.0 (and had some very old software) and none of the "updates" addressed the touchpad.

The instructions in the manual tell you to boot into "Legacy" and then boot from a CDROM if you need to refresh your BIOS. But the CD just comes with a bunch of Windows drivers, none of which address the touchpad. I have tried to download the XP and Vista versions of the drivers from the Chinese site in Xiamen, but unsuccessfully. I will see if there is a difference between the CD and the packages. If that doesn't work, I will write the help desk listed on the Chinese site, and see if they will at least tell me the make of the touchpad. I will post the results here.

Dow Franklin Dudley 08-20-2009 05:25 AM

Update: Touchpad and touch pad drivers for Malata
I received a fairly prompt response from the Wanlida (Malata) service department--my apologies for underestimating their willingness to help.

The upshot is this: no synaptics, no ALPS. The Malata pc-80016 (and I suspect the 81005) have a "AVC TPA2 D2EA9" touchpad. A search turns up a few reports of problems with the Fujitsu-Siemens "AVC TPA 1 FINGER-SENSING PAD" on Windows and Debian. There just is not much in the way of drivers for this device beyond what came with your pack. I don't know if the drivers for AVC out there on the web are any better than the existing drivers. Apparently Fujitsu is not doing anything with these drivers either, so I really doubt that a smaller company such as Wanlida Malata would supply much more.

The Wanlida Malata help site is set up for local consumers within Mainland China (you have to choose your province from a drop down menu). So I can't really complain.

Note that the Malata is also the same as the Datacask Jupiter 1014a; the iQon-Quelim AT-2007; NTT Corrino. See footnote 16 on Wikipedia comparison of netbooks. So the same driver issue with AVC Technologies drivers probably applies to them too.

Additionally, the keyboard can be a problem if you don't like the position of the shift and end keys, but you want to use SCIM. You will have to use xen to figure out your key-map and then use xmodmap to switch them. If I manage to do this successfully, I will post the solution.

I hope this saves other people some time if they are in the same boat as I am with this netbook.

smalldog 01-01-2010 12:05 AM

touchpad treated as psmouse
Thanks for you explanation. However, it also breaking my hope to find driver for such touchpad. It means such touchpad can be used as psmouse only. No another software support available such as Synaptic or Alps.

Actually, it works properly except I want to suspend it when I typing. Such functions are available with touch synaptic.

m.pike1 01-04-2010 03:04 PM


I just revived an old thread with the same issue, unfortunately that had no answers either, sorry i only found this one after. I seem to have the same issue but with a different laptop, this is a Zoostorm Freedom. i have tried everything to do with rewriting the xorg.conf and nothing, what you mentioned about the driver not being supported sounds like I may have the same mouse. Mine is totally useless as it jumps too much, please tell me there is a solution?



Dow Franklin Dudley 01-06-2010 08:42 PM

Touchpad on Malata
I can only comment on my particular netbook, but if you have a Wanlida-made netbook, then my best guess is that you are probably out of luck. The manufacturer of the touchpad for the Malata does not even list touchpads on their site. Perhaps there are enough users of your netbook in the UK to encourage someone to come up with a work around. I ended up attaching an external mouse to my netbook. Not an ideal solution.

Sorry for the lack of good news.

m.pike1 01-07-2010 03:30 PM

Cheers for the help. I am yet to find out anything on this particular netbook so have a feeling it will come to the same conclusion however I will try my best to get something working, USB mouse works fine so its usable. I wonder if it would be possible to force linux to use it like a USB mouse, or emulate the way windows handles it..... I can feel my first ever programming project coming on lol.



m.pike1 01-07-2010 03:45 PM

Just a quick discovery, I havn't tested this yet but why not try this its a bunch of SuSE users developing Linux Input Drivers, and they have a lot of support for PS/2 mice, it might just work, just thought I would drop it here incase anyone fancied trying it as i hav other more important issues taht need fixing on my laptop first (My wireless card has started hiding from Linux).

Anyways if anyone tries it let me know how it goes, otherwise i will post back when i have tried but don't know when it will be.

All times are GMT -5. The time now is 07:04 AM.