LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 12-23-2007, 06:04 AM   #1
Pango853
LQ Newbie
 
Registered: Dec 2007
Posts: 19

Rep: Reputation: 0
how to install Ati x1950 driver inFedora 8??


I just installled Fedora 8 .
I want to ask how can i install the driver for my x1950 pro ati.
i hav tried the latest ati-driver-installer-8.43.3-x86.x86_64.run from ati.com. But it dont work at all.
I even cannot start the Catalyst Center!!

And I tried kmod-fglrx too. It dont work too.

So far, I still cannot use Desktop-effects. Is it because the display card hav not yet been installed?

Had anyone succeeded in installing driver for it? Please tell me.
Is it only the problem in Fedora 8? Is it work in fedora 7?
 
Old 12-23-2007, 06:38 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
The newest has just been released a few days ago:

http://ati.amd.com/support/drivers/l...ux-radeon.html

Do not be confused by the version number as AMD/ATI has changed the version numbering scheme, Catalyst 7.12 is newer then the older 8.43.3 installer:

http://wiki.cchtml.com/index.php/Category:Releases
 
Old 12-23-2007, 07:23 AM   #3
Pango853
LQ Newbie
 
Registered: Dec 2007
Posts: 19

Original Poster
Rep: Reputation: 0
I did download the newest one.
But it is not working too.
At the website just hav x1900 series. But my one is x1950.
 
Old 12-23-2007, 08:43 AM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
What do you mean by not working???? How did you install it???

Please post the output from the following typed commands;

fglrxinfo
cat /etc/X11/xorg.conf
 
Old 12-23-2007, 09:37 AM   #5
Pango853
LQ Newbie
 
Registered: Dec 2007
Posts: 19

Original Poster
Rep: Reputation: 0
here my detail.

$ su
# fglrxinfo
display: :0.0 screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: Radeon X1950 Series
OpenGL version string: 2.1.7170 Release

# cat /etc/X11/xorg.conf
# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
Option "AIGLX" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "jp106"
Option "XkbLayout" "jp"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1280x1024"
HorizSync 31.5 - 64.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
Option "UseFastTLS" "0"
Option "BlockSignalsOnLock" "on"
Option "ForceGenericCPU" "off"
Option "KernelModuleParm" "locked-userpages=0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Section "DRI"
Mode 0666
EndSection


in the fglrxinfo, it show ATI driver right. but in the Display settings,
it is still unknown ~=.=
and i still cant run desktop-effects and others compiz..bababa.
 
Old 12-23-2007, 10:00 AM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 57
The ATI driver is installed and working, the Display settings should also show that you are in fact running with this driver. Clicking on the Hardware Tab--> Video card Configure button you should see something like:

fglrx - Vendor-supplied driver for fglrx cards

As for desktop-effects see: http://www.howtoforge.com/compiz-fus...ty-radeon-9200
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation of drivers ATI Radeon X1950 Pro bgast1 SUSE / openSUSE 3 11-27-2007 05:41 PM
SuSe -- need help installing ATI Radeon X1950 pro bgast1 Linux - Newbie 1 11-26-2007 08:55 PM
Ati x1950 fglrx drivers working Steel_J MEPIS 0 05-18-2007 02:18 AM
build and Install the module (ATI driver install) michapma Debian 5 11-13-2005 10:30 AM
ATI Driver prob: Black screen after driver install linuxboynz Linux - Laptop and Netbook 2 10-19-2004 02:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration