-   Linux - Hardware (
-   -   How to get Linux to use my special WIFI button on my acer (

sjampoo 07-16-2010 02:11 PM

How to get Linux to use my special WIFI button on my acer
I have an Acer Aspire 5720z notebook/laptop, and got slackware 13.1 x64 installed. Everything works like a charm ( touchpad, keyboard, screenresolution ), but I a problem with the wireless 'card'.

When I just installed it (as dualboot to the MS Vista it came equipped with) wicd didn't function. Took me ages to find out the standard Atheros AR5001 thing is fully supported under Linux (hence the very few topics on the card )
But still: ifconfig or iwconfig wlan0 up gave me an error 132 message, which through google I learned: hardware switch is set to off.

Anyway: There's this litte button on the first row of 'special' keys, with a blinkenlights (led :) ) that indicates that Wlan is on (or there is wlan activity). Under Vista, it blinks and flashes with Wlan activity, Under Linux: Nothing, Not during Boot, not during never!

Under Vista, when pressing the button, the Wlan is switched off, and on: The internet connections are lost, and when switched on, network activity is restored. Attention please: It's NOT a switch, just a button.

It took me some time to give up getting the Wlan going under linux, rebooted into Vista, noticed the light did flip on,.. and under Vista no problem. I rebooted in to Linux again, and voila: WORKING!
Happy! Succes! Profit!

Nope: the next day: nothing. I didn't press the button. I could press until forever, but under Linux: nothin. Rebooted into windows, had to switch it on, logged out, rebooted into Linux: Working again.

To cut a long story short: the button doesn't work under Linux. Since it's a ' soft ' button, can I switch it on by a command? Since it apparently switches itself off randomly ( maybe sleep, hybernate or any low power state auto switches it off ) and I can only flip it on in Vista.. not the most desireable way to work.

06:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)

uname -a
Linux nutella #3 SMP Wed May 12 23:13:09 CDT 2010 x86_64 Intel(R) Pentium(R) Dual CPU T2330 @ 1.60GHz GenuineIntel GNU/Linux

slackware 13.1 x64

Acer Aspire 5720z

See button:

There are a few ' quick start ' buttons next to it ( which I don't ever use ) to start Internet,Mail,Bluetooth), dummy buttons with leds for hdd activity, caps and scroll lock and some acer only keys with no funtion under linux either )

Drakeo 07-16-2010 03:06 PM

Actually this is a setting that is kept in the /tmp folder most likely. and when you reboot to windows and back to linux linux is doing a cold boot. this then clears out the /tmp file and resets the device to on. this would also happen if the pid in the /var/run is there to.
then it would show that instant it is running and not allow on a soft boot to run.
I am sorry it took so much for you to get the wifi up. but if you would have installed WICD from slackware64/extra/WICD after installation would have your connection running as fast as you could type in the password.
Linux is designed to listen to bios it tries. Do not ask linux to run bios like windows does.
You may want to change this to How to get Linux to use my special buttons on my acer.

sjampoo 07-17-2010 02:33 AM

Title changed.

First thing I did after the fresh 13.1 installation, was install wicd from /extra/ actually. Didn't work.

I'll look into it, since rebooting just to get "wifi" back on isn't the most fun way to do things.

I do not know how it gets triggered to turn itself off. I didn't touch the button in the first place: why would I ever want to turn it off? :)

What should I look for in /tmp? /var/run?

Drakeo 07-17-2010 09:18 PM


I'll look into it, since rebooting just to get "wifi" back on isn't the most fun way to do things.
what if the machine did not have M$ on it? what if the machine Acer was not specifically built for M$ what if you never used the word Windoes ZZZZz. That said I have a beautiful Acer case

I love the blue lights. Then I tore everything out and put in my system.Do not ask why because your catching on. Why because of the M$ motherboard. Now I know you got a lap top so go into the wicd and set the profile for your card to automatically be used at start up.

Other wise you will have to click a icon and and then click connect or type as root dhcpcd wlan0. The acer power setting has been put in the kernel. Yes the card is part of the power settings. The button is a special key I tried to build the 5 year old program but it was not written for my kernel this kernel #3 SMP x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ AuthenticAMD GNU/Linux.
so the next time you reboot and it fails type dmesg and look for the problem.

sobrier 07-17-2010 10:01 PM

i have the same problem...........

Drakeo 07-19-2010 06:36 AM

here is the latest hot key driver. this is the acerhk-0.5.35
are you using the broadcom open source driver or the broadcom driver.

sjampoo 07-20-2010 04:30 AM

Tried to install that driver, but "make" didn't go anywhere. As I am a novice, I do not know where to look for. I then edited the makefile, but all that was there, should be automagically detected ( kernel version etc ).

I am running the 64 bit version off slackware 13.1. I'm using nothing from broadcom. The wifi is a atheros 5000 series, and when functional, 100% functional, no problems at all,.

Drakeo 07-21-2010 09:22 PM

the driver is for 32 bit sorry it is the old acer aspire driver .

All times are GMT -5. The time now is 08:55 AM.