-   Linux - Hardware (
-   -   How to Control Fan Speed on Compaq Proliant ML350 G2 Running Debian (

garryconn 12-21-2012 09:09 AM

How to Control Fan Speed on Compaq Proliant ML350 G2 Running Debian
Hello everyone! This has been a mystery to me for over a year. I have an older Compaq Proliant ML350 G2 running Debian and all the fans inside run full blast constantly. This is a great machine, but I would love to regain control over these fans.

In Windows, the fans immediately slow down after bootup. The RPM's then adjust as they should based on temperatures. However, in Debian the fan speeds all default to high RPM with no control or no regard to temps.

I have tried lm-sensors, fan control, sensors-detect and there are no PWM sensors reporting back. So, I am not sure how the fans can work fine in Windows, but I sure would like it if I could finally have control over the fans running Debian. This machine is used as a very active web server and hosts a handful of sites. I like the machine a lot and do not have any interest in phasing it out.

Ser Olmy 12-21-2012 09:16 AM

I have an original ML350 (G1) running Slackware, and in order to control the fans I had to install the HP system management software.

The daemon you're looking for is "hpasmd".

garryconn 12-21-2012 09:39 AM

Thank you for replying back! And actually, would you mind helping me correctly identifying this machine. I have never been able to fully verify which generation it is. I am pretty sure it is a G2, but how do I know that it's not a G1 or even G3?

It's been months ago, but research did lead me over to HP's website, but from what I remember there wasn't support for the G2. Would you mind providing me with some more direction. I feel like there is some hope now towards shutting this computer up a little bit. hehe

Ser Olmy 12-21-2012 10:29 AM

The later generation servers should all be clearly labeled. Well, clearly labeled once you remove the front cover. Look for a small, square sticker.

Also, dmidecode should be able to tell you the exact make and model.

garryconn 12-21-2012 11:51 PM

Would you mind telling me more about how I can get hpasmd added properly?

Ser Olmy 12-22-2012 10:26 PM

HP typically offers management software packages for RHEL and SLES. As a Slackware user, I had to download and convert the packages manually.

The HP packages all install to /opt/hp and /opt/compaq. At first, hpasmd failed to start as it depended on some slightly antiquated libraries. ldd hpasmd told me what I needed to know, so I downloaded and installed the missing libraries (can't remember the details, sorry).

I then added hpasmd to the startup scripts manually, and everything just worked. I get "Program hpasmd tried to access /dev/mem between fa000->10b000" in the system log whenever hpasmd is started, but it still works. The fan speed is adjusted up and down dynamically, and overheating triggers a shutdown.

All times are GMT -5. The time now is 07:03 AM.