LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-08-2004, 03:02 PM   #1
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Rep: Reputation: 0
How to configure a Lexmark Z 603?


Hello:

Am trying to configure a printer on my brother box, his box is using Lin spire (aka Lindows) distro, everything goes well (except the printer), but i wonder if somebody may help me installing his printer, manufacturer Lexmark model Z603, i do a google, and find some information, but not enough to make the printer work, i also try to install using a 'raw' driver, among other things i try to install the printer w/ the Z600 driver (generic) provided on lexmark.com (the full link was posted here on another tread), and also i've tried to use an older model driver (provided by the Lin spire printer wizard), nothing works, i don't know if it's because the limitations of the distro (i.e. not rpm tool installed by default), maybe if i try w/ CUPS...

Am going to search for more information, verifying if CUPS is installed, etc.

Any help would be appreciated.

Thanks in advance
 
Old 10-08-2004, 05:27 PM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi mofo, welcome to lq. If your distro has the development packages, this may be an option.

http://www.lexmark.com/US/products/i.../download.html

If not I believe linspire is debian based. You could try coverting this package

http://downloads.lexmark.com/cgi-per...e=&fileID=1151

to a debian package with something like alien

good luck.
 
Old 10-13-2004, 02:09 PM   #3
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Original Poster
Rep: Reputation: 0
well many thx PEACEDOG, i actually dl the file CJLZ600LE-CUPS-1.0-1.TAR.gz and do a tar xvzf, so i get many files included some rpms, the i have to use alien tool right, and whats next ?

please

many thx again
 
Old 10-13-2004, 02:39 PM   #4
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
The funny thing is I just downloaded the file, I didn't get any rpm's, just a shell script. In any event, if you've got rpm's, then you'll want to get and install alien, then use it to convert the rpm to a dpkg.
good luck.
 
Old 10-13-2004, 05:41 PM   #5
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Original Poster
Rep: Reputation: 0
hello again PEACEDOG, you are right i dont get any rpm i use another procedure where i get those rpms, but cant remember the procedure.

well i did the tar xzvf to the file CJLX600LE-CUPS-1.0-1.TAR.gz and get 3 files then i did this following the instructions on the README file

# sh z600cups-1.0-1.gz.sh
Verifying archive integrity...OK
Uncompressing Lexmark Printer Driver............
./xlexinstall: error while loading shared libraries: libtcl8.3.so: cannot open shared object file: No such file or directory
The program returned an error code (127)

any suggestion to solve this error?

thx for the help
 
Old 10-13-2004, 05:55 PM   #6
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
The error is most likely due to the fact that the driver is for redhat 9. Several things could be the cause, you may not have that library, or that version of the library installed. You may have the library, but it's static instead of shared. It's hard to say. I believe you can find the rpm file here.

http://www.lexmark.com/US/products/i...wnload_v2.html

Then you could continue with the alien conversion.
good luck.
 
Old 10-13-2004, 06:25 PM   #7
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Original Poster
Rep: Reputation: 0
yes i get the rpm file, but the lisnpire distro does not have rpm tool, where i get it? sourceforge? freshmeat?

thx PEACEDOG
 
Old 10-13-2004, 06:33 PM   #8
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Original Poster
Rep: Reputation: 0
please excuse me RPM tool is on linspire, am going to try the file for the printer, i'll post the result... thx
 
Old 10-13-2004, 06:41 PM   #9
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Original Poster
Rep: Reputation: 0
well i use this command to get the rpm file installed, but iget this errors:

# rpm -i z600llpddk-2.0-1.i386.rpm
error: cannot open Packages index using db3 - No such file or directory (2)
error: cannot open Packages database in /var/lib/rpm

what to do now, any opinion?

thx in advance
 
Old 10-13-2004, 06:46 PM   #10
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
You'll have to use alien to convert the rpm to a dpkg. You can find alien here.

http://www.icewalkers.com/Linux/Soft...020/Alien.html

You can find some instructions here.

http://www.perldoc.com/perl5.6/bin/alien.html

good luck.
 
Old 10-13-2004, 07:20 PM   #11
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Original Poster
Rep: Reputation: 0
so then whats next, i mean what i do w/ the *.deb file (package) ?

something like apt etc...

many thx
 
Old 10-13-2004, 08:33 PM   #12
mofo
LQ Newbie
 
Registered: Feb 2004
Distribution: Debian, Suse
Posts: 17

Original Poster
Rep: Reputation: 0
everything works really fine just use this instructions http://www.linuxprinting.org/piperma...q2/002550.html and the help gived her by PEACEDOG

many, many thx PEACEDOG

now i can print using a lexmark z603

any doubt plese contact me bonovoxmofo at hotmail dot com
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-sourcecode-2.6.8-1.603.noarch.rpm RottenMutt Fedora 5 10-13-2004 10:21 PM
lexmark z 603 arankay Linux - Hardware 3 10-13-2004 06:51 PM
kernel-sourcecode-2.6.8-1.603.noarch.rpm RottenMutt Red Hat 1 10-12-2004 02:42 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 03:52 PM
TCP port 603 open sharpie Linux - Security 6 04-21-2004 09:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration