LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-14-2004, 05:45 AM   #1
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, sometime others
Posts: 119

Rep: Reputation: 16
Lightbulb How to config serial modem to send Fax on a MDK-9.2


I won't succeed in sending faxes with a serial fax modem

My Config is
- MDK 9.2
- Olitec Self Memory 33600 (COM1) configured & supposedly working (*)

Quote:
$ echo "ATZ" > /dev/modem
makes the Olitec 'bip'. ( /dev/ttyS0 is linked to /dev/modem )
But
Quote:
$ echo "ATDT3611" > /dev/modem
(*) first dialed this number, but now does nothing (i RPM-installed efax & kdeprintfax since it worked)
+ CUPs won't recognize my fax modem.

5 days searching Linux Question & the Web, but very few Doc for my configuration.
Also tried to compile Hylafax (heavy one!) but wrote error messages right from the ./configure...

Here's what i get trying to send a PDF with efax :
Quote:
$ efax -t 0231851332 Microtime_model_Fax.pdf
efax: Mon Jun 14 09:47:45 2004 efax v 0.9a-001114 Copyright 1999 Ed Casas
efax: 47:45 compiled Jul 24 2003 15:04:05
efax: 47:45 opened /dev/modem
efax: 47:46 using OLITEC SELF MEMORY 33600 OLITEC AC/V34 in class 2
efax: 47:46 dialing 0231851332
efax: 47:54 Error: dial command failed
HTH can I do to get it works ? try Knoppix-KDE3 ?
 
Old 06-14-2004, 11:42 AM   #2
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, sometime others
Posts: 119

Original Poster
Rep: Reputation: 16
Desperatly in need to fax, i installed Hylafax (& server & client), & configured it.
Quote:
# probemodem
Serial port that modem is connected to []? ttyS0
Now we are going to probe the tty port...

Probing for best speed to talk to modem: 38400 OK.

This looks like a Class 1 and 2 modem.

ATI0 RESULT = "OK" RESPONSE = "33600 V3.254S"
ATI1 RESULT = "OK" RESPONSE = "8FC0"
ATI2 RESULT = "OK" RESPONSE = "OLITEC SELF MEMORY 33600"
[& so on]
I now may start hylafax, but still cannot send anything :
Quote:
# sendfax -n -d 0231851332 faxsent/testfax
request id is 2 (group id 2) for host localhost (1 file)
My modem doesn't even awake
After trying to send 5 faxes from ASCII & PDF files, doing a $ faxstat -s shows :
Quote:
$ HylaFAX scheduler on Blabla: Running

JID Pri S Owner Number Pages Dials TTS Status
2 127 W root 0231851332 0:0 0:12
3 127 W root 0231851332 0:0 0:12
4 127 W root 0871727987 0:0 0:12
5 127 W koz 0871727987 0:0 0:12
6 127 W root 0871727987 0:0 0:12
Well i'll have to do it from Winz, & this makes me quite disapointed
 
Old 06-15-2004, 01:33 AM   #3
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, sometime others
Posts: 119

Original Poster
Rep: Reputation: 16
Unhappy

Allright, one more time

Question : Are Firewall rules able to forbid Computer // FaxModem communication ?
I know Hylafax use port 4559
I use Shorewall.


Last edited by kozaki; 06-15-2004 at 02:11 AM.
 
Old 06-19-2004, 09:06 AM   #4
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, sometime others
Posts: 119

Original Poster
Rep: Reputation: 16
So, actually no one sends fax with Linux and serial modem-fax ?

I've found no more clue on Google as well as on other BBS.
 
Old 06-25-2004, 06:43 AM   #5
kozaki
Member
 
Registered: Jun 2004
Location: France, UE
Distribution: Arch Linux, sometime others
Posts: 119

Original Poster
Rep: Reputation: 16
Well, i now send faxes with Windoze 2k.

This sucks, ain't it ?
 
Old 02-02-2005, 01:30 PM   #6
ka9qlq
Member
 
Registered: Feb 2004
Location: Columbus, IN USA
Distribution: Mepis 3.4 rc1
Posts: 119

Rep: Reputation: 26
Sending faxes

I'm trying myself, let me know if you find Anything.
Alvin
 
Old 06-10-2005, 09:03 AM   #7
spindles
Member
 
Registered: May 2005
Location: New Zealand
Distribution: Now Ubuntu 16.04
Posts: 154

Rep: Reputation: 15
Hello faxers,
Did you ever get your faxing from linux working?
I am having the same problem as kozaki, e.g. "request id is 2 (group id 2)" but no further action.
Using Hylafax, suse 9.1.
The docs I send, using sendfax from command line, are just sitting in var/spool/fax/sendq.
I was hoping that sendfax would then wake up the modem and actually send the docs.
Or at least dial the number.
Have used minicom to successfully dial phone nums -- so I know that, in principle, software can communicate with the modem.
I know, I know, something is not properly configured somewhere.
I wonder where.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem send fax with modem error code 54? jeppe Linux - General 1 06-22-2009 05:38 AM
Can't find fax-modem or serial card cherylchase Linux - Hardware 1 05-11-2005 07:12 PM
mdk 9.1 modem config?? perdesiz Linux - Hardware 5 10-01-2003 04:22 AM
Send fax problem satimis Linux - General 1 06-24-2003 03:59 AM
Us Robotics 56 Fax Modem Usb Config murshed Linux - Hardware 4 04-22-2003 06:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration