LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-30-2005, 12:50 PM   #1
h3llz0r
LQ Newbie
 
Registered: Oct 2005
Posts: 5

Rep: Reputation: 0
how i can make my second HD detectable (plz i need help)


i got a big collection of mp3 and movies in my second harddrive that i would like to share and use with linux and i cant lose plz

the device is there cuz i browse hardware and i saw it.. im a newbie
im using fedora 4 i would like to know how i can see my files on my second hd and make em read and write plz

to - cyberjun or any that would like to help me out plz is in type ntfs
i dont know lot of english i would like to get answered
Mb Type
dev/hdb
hdb1 120gb ntfs

plz i would like to get replyed or emailed
h3llz0r@gmail.com

thx for all your help
 
Old 10-30-2005, 01:04 PM   #2
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
did you try this?:

(as root)
Code:
mkdir /mnt/hdb
mount -t ntfs /dev/hdb /mnt/hdb
if you get a message about 'ntfs' being an unsupported type, then you need to load ntfs support. see http://linux-ntfs.sourceforge.net/.

if this works, then you can add a line to /etc/fstab:

/dev/hdb /mnt/hdb ntfs defaults,umask=000 0 0

that line will cause the drive to be mounted at '/mnt/hdb' every time the system starts.

also, you don't need to use '/mnt/hdb'. if you want the drive to show up as, say, /multimedia or /music or /seconddrive, then you can change '/mnt/hdb' for whatever you want.
 
Old 10-30-2005, 02:33 PM   #3
h3llz0r
LQ Newbie
 
Registered: Oct 2005
Posts: 5

Original Poster
Rep: Reputation: 0
i got the message of unsupported ntfs i downloaded the ntfs kernel module and install it for my correct kernel version and when i type it again i got this message

mount: wrong fs type, bad option, bad superblock on /dev/hdb,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

any thing to do now? plz
 
Old 10-30-2005, 04:05 PM   #4
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
couple of thoughts:

(1) are you sure it is ntfs? if not, try 'vfat' for the type.

Code:
mkdir /mnt/hdb
mount -t vfat /dev/hdb /mnt/hdb
(2) try something other than hdb--e.g., hdb1 (that's a number "1", not a lower-case "L").
or, if you have more than one partition on hdb, try hdbn, where n is an integer greater than 1.

Code:
mkdir /mnt/hdb1
mount -t ntfs /dev/hdb1 /mnt/hdb1

Last edited by mikeh2; 10-30-2005 at 04:06 PM.
 
Old 10-30-2005, 09:46 PM   #5
h3llz0r
LQ Newbie
 
Registered: Oct 2005
Posts: 5

Original Poster
Rep: Reputation: 0
ok it work now i see the hdb1 in my /mnt/ folder but it got a little x on the corner and it say i dont got permission to view the content i think thats easy but im not sure how to access it i think with that u can complete helping me i will wait for ur reply mike and really thx for all the help and ur time
 
Old 10-30-2005, 09:53 PM   #6
Charred
Member
 
Registered: Mar 2005
Location: Utah, USA
Distribution: Slackware 11
Posts: 816
Blog Entries: 2

Rep: Reputation: 30
Edit:
Posted late. I need to change my browsing habits.

Last edited by Charred; 10-31-2005 at 02:46 AM.
 
Old 10-30-2005, 10:45 PM   #7
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
Quote:
Originally posted by h3llz0r
ok it work now i see the hdb1 in my /mnt/ folder but it got a little x on the corner and it say i dont got permission to view the content i think thats easy but im not sure how to access it i think with that u can complete helping me i will wait for ur reply mike and really thx for all the help and ur time
well, if you're mounting it as root and then dropping to a user account, the user might not have access. try adding this line to /etc/fstab (you will need to be root to do it):

/dev/hdb1 /mnt/hdb1 ntfs defaults,umask=000 0 0

then reboot and log in as a user. the user should have access to it. if not, it's beyond my knowledge, which is quite limited.
 
Old 10-31-2005, 01:33 AM   #8
h3llz0r
LQ Newbie
 
Registered: Oct 2005
Posts: 5

Original Poster
Rep: Reputation: 0
it work really thx for your help and time mike
 
Old 11-03-2005, 07:17 AM   #9
dodjie60
LQ Newbie
 
Registered: Aug 2005
Location: Equatorial Guinea
Distribution: OpenSuSE 10.2/Fedora 7/Ubuntu
Posts: 27

Rep: Reputation: 15
Mikeh2,

Same problem here. Your solution is quite great. Before rebooting, I was able to mount sda1 using your command "mount -t ntfs /dev/sda1 /mnt/sda1". As per your instruction, I vi'd /etc/fstab inserting your "/dev/hdb1 /mnt/hdb1 ntfs defaults,umask=000 0 0". When rebooted, I looked in the directory /mnt and found that sda1 was mounted. The problem is the directory is empty. I tried "ls /mnt/sda1" and it only showed me this ". .." in the directory.

What could be the problem?

dodjie60
 
Old 11-03-2005, 08:07 AM   #10
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
Quote:
Originally posted by dodjie60
Mikeh2,

Same problem here. Your solution is quite great. Before rebooting, I was able to mount sda1 using your command "mount -t ntfs /dev/sda1 /mnt/sda1". As per your instruction, I vi'd /etc/fstab inserting your "/dev/hdb1 /mnt/hdb1 ntfs defaults,umask=000 0 0". When rebooted, I looked in the directory /mnt and found that sda1 was mounted. The problem is the directory is empty. I tried "ls /mnt/sda1" and it only showed me this ". .." in the directory.

What could be the problem?

dodjie60
The results of "ls" tell you that the folder is there, but the drive is not mounted. This is because although you correctly modified the mount parameters in my original example--by changing "hdb1" to "sda1"--you did not do so for the fstab entry.

Just change the line you put in fstab. You entered:

Code:
/dev/hdb1 /mnt/hdb1 ntfs defaults,umask=000 0 0
It should be:

Code:
/dev/sda1 /mnt/sda1 ntfs defaults,umask=000 0 0
 
Old 11-03-2005, 08:33 AM   #11
dodjie60
LQ Newbie
 
Registered: Aug 2005
Location: Equatorial Guinea
Distribution: OpenSuSE 10.2/Fedora 7/Ubuntu
Posts: 27

Rep: Reputation: 15
Quote:
Originally posted by mikeh2
The results of "ls" tell you that the folder is there, but the drive is not mounted. This is because although you correctly modified the mount parameters in my original example--by changing "hdb1" to "sda1"--you did not do so for the fstab entry.


Just change the line you put in fstab. You entered:

Code:
/dev/hdb1 /mnt/hdb1 ntfs defaults,umask=000 0 0
It should be:

Code:
/dev/sda1 /mnt/sda1 ntfs defaults,umask=000 0 0
Sorry, typo error. I should have typed "..... I vi'd /etc/fstab inserting your "/dev/sdb1 /mnt/sdb1 ntfs defaults,umask=000 0 0....." . Sill the same result, the directory is empty.

uname -a
Linux dodjie 2.6.11.4-21.9-default #1 Fri Aug 19 11:58:59 UTC 2005 i686 i686 i386 GNU/Linux

dmesg | grep -i ntfs
NTFS driver 2.1.22 [Flags: R/W MODULE].
NTFS-fs error (device sda1): parse_options(): Invalid gid option argument: users
NTFS-fs error (device sda5): parse_options(): Invalid gid option argument: users
NTFS volume version 3.1.
NTFS-fs warning (device sda1): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring.
NTFS volume version 3.1.
NTFS-fs warning (device sda5): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring.

grep -i ntfs /var/log/messages
Nov 3 22:24:03 dodjie kernel: NTFS-fs error (device sda1): parse_options(): Invalid gid option argument: users
Nov 3 12:41:16 dodjie kernel: NTFS volume version 3.1.
Nov 3 12:43:12 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:09:14 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:24:59 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:27:18 dodjie kernel: NTFS-fs warning (device sda1): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring.
Nov 3 13:28:17 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:32:03 dodjie kernel: NTFS-fs warning (device sda5): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring

By the way, I'm using SuSE 9.3 in my IBM Thinkpad T43.
 
Old 11-03-2005, 09:27 AM   #12
mikeh2
Member
 
Registered: Oct 2005
Posts: 32

Rep: Reputation: 15
Quote:
Originally posted by dodjie60
Sorry, typo error. I should have typed "..... I vi'd /etc/fstab inserting your "/dev/sdb1 /mnt/sdb1 ntfs defaults,umask=000 0 0....." . Sill the same result, the directory is empty.

uname -a
Linux dodjie 2.6.11.4-21.9-default #1 Fri Aug 19 11:58:59 UTC 2005 i686 i686 i386 GNU/Linux

dmesg | grep -i ntfs
NTFS driver 2.1.22 [Flags: R/W MODULE].
NTFS-fs error (device sda1): parse_options(): Invalid gid option argument: users
NTFS-fs error (device sda5): parse_options(): Invalid gid option argument: users
NTFS volume version 3.1.
NTFS-fs warning (device sda1): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring.
NTFS volume version 3.1.
NTFS-fs warning (device sda5): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring.

grep -i ntfs /var/log/messages
Nov 3 22:24:03 dodjie kernel: NTFS-fs error (device sda1): parse_options(): Invalid gid option argument: users
Nov 3 12:41:16 dodjie kernel: NTFS volume version 3.1.
Nov 3 12:43:12 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:09:14 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:24:59 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:27:18 dodjie kernel: NTFS-fs warning (device sda1): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring.
Nov 3 13:28:17 dodjie kernel: NTFS volume version 3.1.
Nov 3 13:32:03 dodjie kernel: NTFS-fs warning (device sda5): ntfs_setattr(): Changes in user/group/mode are not supported yet, ignoring

By the way, I'm using SuSE 9.3 in my IBM Thinkpad T43.
What kind of device is it? And is it definitely ntfs? I think this one might be beyond my knowledge.
 
Old 11-03-2005, 09:41 AM   #13
dodjie60
LQ Newbie
 
Registered: Aug 2005
Location: Equatorial Guinea
Distribution: OpenSuSE 10.2/Fedora 7/Ubuntu
Posts: 27

Rep: Reputation: 15
Quote:
Originally posted by mikeh2
What kind of device is it? And is it definitely ntfs? I think this one might be beyond my knowledge.
This thread is getting bigger, but anyway, thank you for your patience.

dodjie:/home/sigeacdws005 # fdisk -l

Disk /dev/sda: 40.0 GB, 40007761920 bytes
240 heads, 63 sectors/track, 5168 cylinders
Units = cylinders of 15120 * 512 = 7741440 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 2229 16851208+ 7 HPFS/NTFS
/dev/sda2 2230 4617 18053280 f W95 Ext'd (LBA)
/dev/sda3 4618 5168 4165560 12 Compaq diagnostics
/dev/sda5 2230 3313 8195008+ 7 HPFS/NTFS
/dev/sda6 3314 3327 105808+ 83 Linux
/dev/sda7 3328 3397 529168+ 82 Linux swap / Solaris
/dev/sda8 3398 4617 9223168+ 83 Linux

To make this story short, I am trying to retreive (dual boot with xp - sda1) my files from win xp to suse 9.3. It is definitely an ntfs file system. Win XP Professional. I don't know what HPFS/NTFS is. But my cat /etc/fstab says that it really is an ntfs.

dodjie:/home/sigeacdws005 # cat /etc/fstab
/dev/sda8 / reiserfs acl,user_xattr 1 1
/dev/sda6 /data1 auto noauto,user 0 0
/dev/sda1 /windows/C ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda5 /windows/D ntfs ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/sda7 swap swap pri=42 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
sysfs /sys sysfs noauto 0 0
/dev/cdrom /media/cdrom subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0

Thanks again for your patience, please help me with this one, everything is functioning fine in my pc except this mounting problem. I can even mount our company server using "mount -t cifs //ip address/foo" but not the one in my laptop.
 
Old 12-10-2005, 02:41 PM   #14
noemeenswat
LQ Newbie
 
Registered: Aug 2004
Location: The Netherlands
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Question

In the past, i'd installed a debian distribution on my system, but it just crashed (HD 80 GB) (by me ).

I just looking around and found an other HD (120 GB).
So, i just installed a newer distribution (Debian) on this HD.

But now, id like to have the data of that other/old HD (80 GB) and copy it to the 120 GB HD.

But the problem: I can't mount this device

I boot now from /dev/hda

and when I use fdisk /dev/hdb, i get the following information:
/dev/hdb1 * 1 1216 9767488+ 83 Linux
/dev/hdb2 1217 1277 489982+ 82 Linux swap / Solaris
/dev/hdb3 1278 3709 19535040 83 Linux
/dev/hdb4 3710 9729 48355650 83 Linux

When i try the following mounts:
mount -t autofs /dev/hdb /mnt/hdb
mount -t autofs /dev/hdb3 /mnt/hdb3
mount -t ext3 /dev/hdb3 /mnt/hdb3

I just get this error:

mount: wrong fs type, bad option, bad superblock on /dev/hdb4,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Please, can anybody help me?

(sorry for my bad english)

Thanks in advance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Non detectable sound card on MSI-RS480 for AMD asheesh1_2000 Linux - Hardware 1 04-07-2006 12:39 PM
ipw2200, error when "make" plz help pz Mike zq Linux - Laptop and Netbook 8 04-11-2005 01:24 PM
WPC11 Ver4 and "Make" errors. plz help JRR Linux - Hardware 4 05-22-2004 06:08 PM
mysql::DBD make problems - help plz pigsy Linux - Software 15 04-17-2004 03:48 PM
help this to make this sed efficient plz doublefailure Programming 1 03-25-2002 07:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration