-   Linux - Hardware (
-   -   How do I reserve an IRQ to ISA? (

peso 02-06-2004 07:33 AM

How do I reserve an IRQ to ISA?

How do I assign/reserve a specific IRQ to the ISA bus under Linux?

The distribution I'm working on is SuSE Linux 9.0, kernel 2.4.21-99 and I have GRUB as a boot loader.

Many thanks

finegan 02-06-2004 09:48 AM

BIOS assigns IRQs, usually its done automatically, but you can usually fiddle with the setting to have an IRQ reserved for a certain slot.

If this is trying to get a module to load right:

cat /proc/interrupts

and assign one that isn't being used with a module argument, usually something like:

modprobe 3c509 irq=7



peso 02-06-2004 09:55 AM

The thing is that I want to assign IRQ 15 for a couple of my serial ports. Any idea how I would do this?

Let's say I wanted to assign serail ports /dev/ttyS2 and /dev/ttyS3 to IRQ 15. How would this be done?


finegan 02-06-2004 10:33 AM

Serial ports... oh:

man setserial

There's an option to hand set the IRQ, you can put a call to it in /etc/rc.d/rc.local so it'll get set at bootup.



peso 02-06-2004 04:01 PM

Hi again,

I've already configured my serial ports in the file:
and the port that I want to reserve the IRQ for is configured as:
setserial /dev/ttyS4 port 0x3E0 uart 16550A irq 15 baud_base 9600
but it still doesn't work.

The thing is that if I boot up in Windows first (I have a dual boot system) and then restart the computer (without shutting it down) and boot up in Linux, then it finds the serial port and I can communicate through it. In my BIOS I've reserved IRQ 15 for ISA devices and in Windows I have bo problem with it. But every time I run Linux (without the above procedure with booting up in Windows first) the serial port isn't recognized. So I guess Linux does something with the BIOS reservation of the IRQ when I boot up the system, but what?

Thankful for any help 'cause this is driving me crazy!

Many thanks

peso 02-07-2004 07:06 AM

Maybe the problem described above has absolutely nothing to do with the IRQ not being reserved correctly. If so, does anybody have any ideas about what could cause the problem?


homey 02-07-2004 11:08 AM


I wonder if it would work better in /etc/rc.d/rc.local

peso 02-07-2004 12:34 PM

There is no such file as /etc/rc.d/rc.local in SuSE Linux 9.0...


finegan 02-07-2004 02:50 PM

In Suse its /etc/rc.d/boot.local

Annoying huh? 4 out of 7 of the big distros have it in the same place, Debian Gentoo and SuSe had to be special.

So the IRQ gets assigned right if you warm reboot it from os to os, but not on a cold boot straight to Linux?



peso 02-07-2004 05:20 PM

Yes that's it, or at least the communication through the serial port works if I warm boot it from os to os. I don't know if that has to do with the reservation of the IRQ or not, but that's the final thing I could think of...

Any ideas about anything that could solve this problem would be very much appreciated!!


All times are GMT -5. The time now is 01:03 AM.