LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-04-2006, 09:17 AM   #61
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,892

Rep: Reputation: 171Reputation: 171

Quote:
Originally Posted by LonelyTraveler
My internal modem is a Broadcom V.92 MDC. That might be what you're seeing.

I am talking about these two devices here.

Code:
0000:02:01.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
0000:02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
Both netcards and by Broadcom your modem is this device.

Code:
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
It says Intel makes it but no matter. Did you try my last suggestion if so what was the result of the networking restart command does the ifconfig -a show the device with an IP.
 
Old 09-04-2006, 10:16 AM   #62
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
I'm going to do that in a few minutes. Just got back from work. Isn't the Ethernet controller my lan card that I'm using now and the Network controller my internal wifi card? I don't know, just wondering.

[QUOTE=HappyTux]
0000:02:01.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
0000:02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
QUOTE]
 
Old 09-04-2006, 10:41 AM   #63
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,892

Rep: Reputation: 171Reputation: 171
[QUOTE=LonelyTraveler]I'm going to do that in a few minutes. Just got back from work. Isn't the Ethernet controller my lan card that I'm using now and the Network controller my internal wifi card? I don't know, just wondering.

Quote:
Originally Posted by HappyTux
0000:02:01.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)
0000:02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
QUOTE]
Yes that is what I am thinking too hardwired netcard and wireless on-board and the second wificard (Belkin) shows up as an Atheros.
Code:
0000:03:00.0 Ethernet controller: Atheros Communications, Inc.: Unknown device 001a (rev 01)
Which is why I am thinking it is already configured and ready to go according to the boot messages. I just need to figure out if the commands put into the interfaces file get you an IP, it will be easy enough to test just unplug the Belkin if it does not show up in the boot mesages then it definitely is the Atheros card..
 
Old 09-04-2006, 11:40 AM   #64
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
I just ran lspci again after unplugging the card and it still picked up the Broadcom devices. So I guess it is the internal card it is picking up. I take it I don't need to do what you told me to do in you last post last night as it is not the external card? I went to my network setting and there it also picks up the internal card a a unknown interface.

Output for iwconfig:

Code:
Conrad:/home/conradtheart# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

sit0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11b  ESSID:""
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Bit Rate:0 kb/s   Tx-Power:0 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/94  Signal level=-95 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Last edited by CrownAmbassador; 09-04-2006 at 11:42 AM. Reason: Added iwconfig output
 
Old 09-04-2006, 12:28 PM   #65
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,892

Rep: Reputation: 171Reputation: 171
Quote:
Originally Posted by LonelyTraveler
I just ran lspci again after unplugging the card and it still picked up the Broadcom devices. So I guess it is the internal card it is picking up. I take it I don't need to do what you told me to do in you last post last night as it is not the external card? I went to my network setting and there it also picks up the internal card a a unknown interface.

Output for iwconfig:

Code:
Conrad:/home/conradtheart# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

sit0      no wireless extensions.

wifi0     no wireless extensions.

ath0      IEEE 802.11b  ESSID:""
          Mode:Managed  Channel:0  Access Point: Not-Associated
          Bit Rate:0 kb/s   Tx-Power:0 dBm   Sensitivity=0/3
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=0/94  Signal level=-95 dBm  Noise level=-95 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Ok that is good it picking the Broadcom means that the Belkin is the Atheros card we need to change the naming for last nights post from wifi0 to the ath0 the output above from the iwconfig shows that the card is active not associated with any access point. Try the iwconfig ath0 essid "name_of_router_ssid" to see if it will associate to it then if there is no encryption on the router try ifup ath0 having changed the /etc/network/interfaces file to add this.

Code:
## Added by me for wireless netcard
#auto ath0
iface ath0 inet dhcp
Look at the Mephis page I posted last night to see the other iwconfig commands you may need to try like the one for the channel and key for encryption if necessary you use these before the ifup command. Post the iwconfig and ifconfig -a commands after this so I can see results.

Edit: If the ifconfig -a shows you that you got an IP from your router try ifdown eth0 and see if you can surf the web, you can always bring the eth0 back up with of course ifup eth0 to use it again.

Last edited by HappyTux; 09-04-2006 at 12:34 PM.
 
Old 09-04-2006, 02:22 PM   #66
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
The channel you're referring too, is that the network name maybe?
 
Old 09-04-2006, 02:43 PM   #67
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,892

Rep: Reputation: 171Reputation: 171
Quote:
Originally Posted by LonelyTraveler
The channel you're referring too, is that the network name maybe?
No when I was looking in my router last night in the wireless configuration there is a drop down menu that has a list of channel numbers you can set which I assume since I have never used it tells the router to use a certain part of the frequency to communicate on. Now I am not sure if the it is necessary to set the channel with the iwconfig but you should be able to get this channel number from your config page in your router (what model is it anyways) along with the essid name and encryption key numbers if needed/turned on, at least they are all there in my config page so I would think yours too. Write these down then you use them if necessary with the iwconfig command to configure/setup the link with the card once this is done use the ifup ath0 to see if you get an IP from the router via the dhcp sever that should be running on your router if you get IP then it should be working to surf the web.
 
Old 09-04-2006, 02:47 PM   #68
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
It is a NetGear CG814WG V2. Doens't seem like there is a proper booklet or something that came with it.
 
Old 09-04-2006, 03:24 PM   #69
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,892

Rep: Reputation: 171Reputation: 171
Quote:
Originally Posted by LonelyTraveler
It is a NetGear CG814WG V2. Doens't seem like there is a proper booklet or something that came with it.
I did not get the settings last night I used from the book I connected to the router using its IP in my case http://192.168.0.1 then entered in the username and password to get into its configuration options it should be similar for your router. According to this page the default username is comcast password 1234 the IP should be http://192.168.0.1 or this page says admin for username and password for password IP should be http://192.168.0.1. Those are the only two results out of three that matter for a google search of "NetGear CG814WG V2 default username and password" so if you have not went out of your way to change the password one of the two should get you into the router to look at the settings. If necessary there is usually a little hole in the back with reset by it that you can stick a needle into to reset the router to its factor default settings.

Edit: And if the password is still at the default then find the spot where you can set it to a different one so someone cannot come by and take over your router.

Last edited by HappyTux; 09-04-2006 at 03:27 PM.
 
Old 09-04-2006, 03:26 PM   #70
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
I just spoke to ComCast as I did change that password sometime, but can't remember what it is. They tried to reset it from their side but it would work. But they also said that the default channel is 6. So I'll try that.
 
Old 09-04-2006, 03:44 PM   #71
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
IT'S WORKING!!!!!!!!!!!! I think I love ya!!! Lol. Just kidding. But seriously, thank you so much! You have been GREAT help and I've learn so much. Can I change the primary network interface in /etc/network/interfaces to my ath0 now? Just to prevent Linux from trying to connect there during startup?

I have two other problems that is not network related. I'm going to do a bit of searching and if I don't get it sorted out, I'm going to put the links to the threads here if you don't mind. I would just really like to sort everything out today.

Thanks again!
 
Old 09-04-2006, 04:47 PM   #72
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
Here is the link to one of the problems I'm having.

http://www.linuxquestions.org/questi...64#post2409264

Thanks.
 
Old 09-04-2006, 04:59 PM   #73
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,892

Rep: Reputation: 171Reputation: 171
Quote:
Originally Posted by LonelyTraveler
IT'S WORKING!!!!!!!!!!!! I think I love ya!!! Lol. Just kidding. But seriously, thank you so much! You have been GREAT help and I've learn so much. Can I change the primary network interface in /etc/network/interfaces to my ath0 now? Just to prevent Linux from trying to connect there during startup?

I have two other problems that is not network related. I'm going to do a bit of searching and if I don't get it sorted out, I'm going to put the links to the threads here if you don't mind. I would just really like to sort everything out today.

Thanks again!
Good to hear its working in your interfaces file just put a # at the start of the auto eth0 line (make sure there is not a lo in the line if so just delete the eth0) and it will not be started (you can always use the ifup eth0 if you need it started) then add the ath0 section I posted a few posts before removing the # in front of the auto ath0 this will bring up the interface on boot. Now for which ever of the iwconfig commands you had to use put them in the pre-up line I showed for the wifi0 post if there was more than one give each their own pre-up line in the order you had to do them.
 
Old 09-04-2006, 05:01 PM   #74
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,892

Rep: Reputation: 171Reputation: 171
Quote:
Originally Posted by LonelyTraveler
Here is the link to one of the problems I'm having.

http://www.linuxquestions.org/questi...64#post2409264

Thanks.
Don't think I can be of much help there it has been so many years since I last used Gnome I wouldn't know where to start.
 
Old 09-04-2006, 05:09 PM   #75
CrownAmbassador
Member
 
Registered: Mar 2005
Location: Cape Town, South Africa
Distribution: Ubuntu 8.10
Posts: 374

Original Poster
Rep: Reputation: 30
Not a problem. I've actually just figured it out. I just reinstalled the GNOME panel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New install - then new hardware matelot Linux - Newbie 5 05-05-2006 05:59 PM
How to install new hardware azazello Linux - Hardware 2 01-21-2006 03:04 PM
how do i install my hardware mandrakelinux Slackware 1 11-22-2005 05:46 PM
How can i install a new hardware? Ronnie85 Slackware 2 04-22-2005 01:46 AM
configure hardware before install OR install elo touchscreen drivers ahnree General 2 06-28-2004 08:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration