-   Linux - Hardware (
-   -   How do I get my USB mouse to work in Gentoo Linux? (

dervxerox 12-27-2011 02:10 PM

How do I get my USB mouse to work in Gentoo Linux?
The device shows up if I type lsusb but doesn't work in the XDM GUI.
Its running on a arm netbook with a bust touchpad that formerly ran Wince.

jefro 12-27-2011 04:43 PM

The X configurator or do it by editing the file.

Try X -configure or xconfig or some such command as the version you have allows.

Ion Silverbolt 12-29-2011 12:17 AM


emerge xf86-input-evdev

dervxerox 12-29-2011 08:42 AM

tried emerge xf86-input-evdev and got an error message: "if you have just changed your profile configuration, you should revert back to the previous configuration. Due to your current profile being invalid, allowed actions are limited to --help, --info, --sync, and --version"
I'm logged in as root.
the machine is ARM.

Ion Silverbolt 12-30-2011 12:55 AM

I don't think you should receive that error message if portage is installed correctly. Is this a fresh install?

dervxerox 12-30-2011 05:06 AM

I got it from here:

Ion Silverbolt 12-31-2011 10:44 PM

Are you able to emerge anything else? Or do you get the same error? First, does your usb mouse get detected? What is the output of lsusb?

If it shows, then you need evdev installed. If it doesn't then you need to enable it in your kernel configuration, or maybe even your usb controller if it isn't compiled. lspci should show the controller info that you can check your kernel config with.

This might help to go over. It's the Gentoo ARM handbook.

That error message you get usually is from a portage install problem. You might be able to work out your problem by following this thread:

All times are GMT -5. The time now is 03:43 PM.