-   Linux - Hardware (
-   -   How do I get my fglrx driver back? (

negafon 05-21-2012 04:20 AM

How do I get my fglrx driver back?
Hey guys, it seems Debian has once again yanked fglrx from the wheezy repositories. I discovered this the hard way by dist-upgrading with apt. It unceremoniously removed fglrx and slapped the radeon driver in its place. I had to fix my xorg.conf just to get back into my DE. The open source driver doesn't work well at all and cooks the processor on my notebook, so I don't want to keep using it. Do I need to reference an older repository snapshot to get my fglrx driver back? I've got the experimental and wheezy repositories in my sources.list right now.

adamk75 05-21-2012 06:20 AM

I haven't used Debian in a while, but from what I'm seeing, Wheezy now uses X server 1.12, correct? That version is incompatible with the current release of fglrx. Hopefully the next fglrx release (12.5) will work with that version X server. You will either need to downgrade X, or you will need to tolerate radeon till fglrx is up-to-speed. Unfortunately, I do not know enough about Debian to tell you the proper way to downgrade. You may want to consider reporting this post to the admins and asking them to move it to the Debian section.


negafon 05-21-2012 11:03 AM

Thanks. Yeah, I'm 90% certain that I need to roll back the X packages, as that's what I primarily saw in the list of upgraded ones. Will that free up the fglrx package for me, though? If they removed it from the repositories I can't get it back just by doing that, right? Perhaps I should download it straight from ATI's website and cross my fingers? If it still doesn't work I could then try to roll back the X packages.

colorpurple21859 05-21-2012 11:25 AM

The use of the radeon driver with hybrid graphics will cause a laptop to get hot if you don't turn one of the graphic cards off. To turn one of the graphics off at prompt as root

echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

cat /sys/kernel/debug/vgaswitcheroo/switch
will display the status of the two video cards. If you get a file/directory not found error the will have to add a mount point for /sys/kernel/debug to your /etc/fstab. These commands can be added to the rc.local file to do it automatically

adamk75 05-21-2012 11:28 AM

If you want to use fglrx, you will need to roll back the X packages no matter what. As I said, X server 1.12 is incompatible with the current release of the fglrx/catalyst driver.

negafon 05-21-2012 11:54 AM

Yeah, you're right, adam. I grabbed version 12.3 (the previous one that I had been using) from AMD's website and tried installing that, but X still didn't like it. colorpurple, thanks for the tip, but I really don't want to use the open source driver because it not only gets hot, but has awful performance. Will your trick fix that as well?

colorpurple21859 05-21-2012 12:55 PM

I Don't know about the performance since all I do is basic stuff, no gaming, but it does help with the heating problem. I have a 6620/6700m hybrid graphics and can only get the 6620 to work with the radeon driver. The screen goes black when I try to switch to the 6700m. I don't know if something isn't configured correctly or just not supported. First chance I get I'm going to try the 3.4 kernel and see if that helps, suppose to be some ati graphic fixes in it.

negafon 05-21-2012 03:29 PM

FYI, I'm using the 3.3 kernel and it's still toasty. I guess I'll give your trick a try. I was able to rollback some of the xorg packages, but it's a mess of broken dependencies. The 12.5 driver is supposed to be compatible with xorg, but they just came out with 12.4, so I don't know WHEN that's going to be released. I am a sad monkey right now. :(

negafon 05-21-2012 04:56 PM

Solved! Okay, here's what I did:

First, you need to add repositories to /etc/apt/sources.list from I used these:

This gives me a snapshot of the wheezy repos on May 15, 2012 at 10:07PM, before the dreaded upgrades were made to the xorg packages. (You can use another date if you like, as long as it's before May 20.) Next, create the file /etc/apt/preferences.d/60xorg_rollback.pref containing this:


Package: xserver-xorg*
Pin: origin ""
Pin-Priority: 1001
This will pin down any apt updates for xorg to this repository only, giving you the version you want. Apt will try to prevent this from happening automatically, so you must create one more file called /etc/apt/apt.conf.d/60ignore_repo_date_check containing:


Check-Valid-Until "false";
Now, get to a command prompt outside your DE if possible and run these commands as root:


apt-get update
apt-get dist-upgrade
You should see something like "Packages to be DOWNGRADED:" with all your xorg packages listed. Hit your 'y' key and you're golden! You should be able to get back into your DE just fine. Now all you have to do is get the 12.4 driver here:

In a terminal, switch to the directory where you downloaded the installer and run these commands as root:


chmod 744
Reboot and you're all set.

Thanks to everyone who replied on the thread and to System Saviour, whose post related to this issue got me pointed in the right direction!

abelloEIS 07-21-2012 02:03 PM

A couple of observations that without them would surely make a lot people go back to Microsoft Windows in a heartbeat:
1. /etc/apt/sources.list won't understand "deb-src". That single line makes the whole apt-get update process to fail miserably.
2. The quoted sources are cropped with "..." that would also break the whole sources.list file.
3. Debian returns that it is IMPOSSIBLE to download from "". Even if the address DOES exists, Debian won't make anything out of it.

In all, the good intentions are in the thread, but they won't do good to people that installed Ddebian and cannot use AMD-sourced ATI drivers. Please re-edit with correct procedure. Thank you!

panosl 08-07-2012 01:02 AM

Post is correct
I just reinstalled fglrx following the above instructions and it went very smoothly.

Just follow the urls above by clicking on them and cut and paste from your browser's address bar into /etc/apt/sources.list.

Many thanks to nagafon for the post.

All times are GMT -5. The time now is 01:56 PM.