Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 11-12-2003, 09:26 PM   #1
Registered: Jul 2003
Location: China
Distribution: Redhat
Posts: 48

Rep: Reputation: 15
How can I make my NIC card working automatically at my os start?

I have just get an ASUS P4C800 Delux, it have a 3Com Gigabit Lan card
but i cant get it up automatic.
I just use it manually.

I use the following command to setup my Lan card
1) copy the driver to the /usr/src/linux-2.4 and uncompress it to 3c2000 folder.
2) use "make load" and " insmod 3c2000.o" to load the driver
3) use "ifconfig eth0 up" to bring the card to work
4) use "ifconfig eth0" to setup ip address.
now the lan card can working perfect
so I return to the graphic interface to config the network's other options
but when i get the networking setting, i have no network device found.
I use ping command to connect to other box to test my connection, i found it's OK.

so i reboot my box
after the OS start i us ifconfig to see my network status
but i couldn't find eth0
so i use #dmesg | grep eth0;
but no item i get.
so i use #insmod /usr/src/linux-2.4/3c2000/3c2000.o
now the driver have load
i use #dmesg to see what happen on my box
i found it add some message on my dmesg output like following:

divert: allocating divert_blk for eth0
3c2000: 3Com Gigabit NIC Driver Version A10
Copyright(c) 2003 3Com Corporation.
Copyright(c) 2003 Marvell
eth0: 3Com Gigabit LOM(3C940)
PrePort: A RlmtMode:Check Link State

I must use ifconfig to wakeup my NIC. and no netwrok device found on the graphic network setting.

I want to know what happen on my nic card
I want nic can work automatically after my box start ,not manually.
How can I add it on the start script to bring it up?

Old 11-12-2003, 09:50 PM   #2
Senior Member
Registered: Oct 2003
Posts: 2,686

Rep: Reputation: 242Reputation: 242Reputation: 242
What distro are you using? The configuration varies from distro to distro. Also post your /etc/modules.conf file. That's what you edit to load your driver. Edit this file by adding the following line:

alias eth0 3c2000.o

If there is an existing line in modules.conf with eth0 in it, comment it out by putting "#" in front of it.

Once the driver is loaded, you can set up the text configuration file for eth0. Most distros use a file called "ifcfg-eth0" for this located in /etc/sysconfig/network-scripts(mandrake and redhat) or in /etc/sysconfig/network (suse). Debian and slackware do it differently and I'm not really familiar with those.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 NIC Card Not Working! 3com 3c501 NIC. Mustard010 Linux - Networking 16 08-15-2007 02:22 AM
how to make named start automatically at startup nazzymac *BSD 3 04-20-2004 10:58 AM
Instructions for getting ANY wireless NIC card working in Redhat 8.0 ksalopek Linux - Wireless Networking 2 01-26-2004 08:14 AM
How to create a tiny script and make it start automatically tchigi Linux - Newbie 2 11-28-2003 03:48 AM
How can i make xfree86 start automatically at boot? KiLLaWaBBiT Linux - Software 1 04-07-2003 10:06 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:39 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration