-   Linux - Hardware (
-   -   How can I get my Adaptec SCSI controller and Quantum SDLT recognized on RH? (

SailorCTO 08-24-2004 01:26 PM

How can I get my Adaptec SCSI controller and Quantum SDLT recognized on RH?

I am trying to get my RH server to recognize a Quantum SDLT and not having much luck. I've searched this board for SDLT posts and have found them to be mostly from RH 7 or earlier (not sure that's the problem), and none of the threads' advice seem to help.

RH Kernel version: 2.4.20-31.9smp
SCSI controller: Adaptec 160
Tape Drive: Quantum SDLT320

'lsmod' shows the follwing:

Module Size Used by Not tainted
soundcore 7044 0 (autoclean)
ide-cd 35808 0 (autoclean)
cdrom 34176 0 (autoclean) [ide-cd]
st 32332 0 (autoclean) (unused)
parport_pc 19204 1 (autoclean)
lp 9188 0 (autoclean)
parport 39072 1 (autoclean) [parport_pc lp]
iptable_filter 2412 0 (autoclean) (unused)
ip_tables 15864 1 [iptable_filter]
autofs 13684 0 (autoclean) (unused)
e1000 60704 2
keybdev 2976 0 (unused)
mousedev 5688 1
hid 22404 0 (unused)
input 6208 0 [keybdev mousedev hid]
usb-uhci 27468 0 (unused)
usbcore 82816 1 [hid usb-uhci]
ext3 73408 6
jbd 56432 6 [ext3]
3w-xxxx 38048 7
sd_mod 13452 14
scsi_mod 110872 3 [st 3w-xxxx sd_mod]

...none of the mt -f /dev/st0 status work.

Any guidance would be greatly appreciated.


michaelk 08-24-2004 02:08 PM

What is the output of the command:
cat /proc/scsi/scsi

Does RH AS have a hardware detection GUI? If so does it show anything for the Adaptec controller or tape drive?

It appears that the the necessary SCSI modules are being loaded. The 3w-xxxx appears to be a SCSI module but I thought the Adaptec 160 uses the aic7xx module.

SailorCTO 08-24-2004 02:40 PM


The 3W-xxx controllers are for the SATA disks (this is a Teramaxx server). I tried loading the aic7xxx but think I may not have done it properly. I entered this: modprobe aic7xxx. Then if I do 'lsmod' it shows up, but as unused. I think I am probably missing a controller driver???


michaelk 08-24-2004 06:49 PM

It does not appear that you are missing anything.
Since you loaded the module have you tried accessing the tape drive?
Does the command show your tape drive?
cat /proc/scsi/scsi

All times are GMT -5. The time now is 02:09 PM.