-   Linux - Hardware (
-   -   High speed memory, linux kernel decompress error (

randyding 09-03-2005 09:35 AM

High speed memory, linux kernel decompress error
My MB is a ABIT-NF7 333/400 bus with Athlon 3000+ 2.1GHz.
Memory is 2 sticks of Mushkin Hi Perf PC-3200 with 2-2-2 timings.
Problem is this computer runs Windows 2000 with no problems
but only takes Linux (Redhat Enterprise) to the point where it
decompresses the kernel and gets a CRC error.

If the memory timings are manually set to 3-3-2.5 it boots
Linux just fine. It also boots just fine with standard
speed memory. I tried a different processor and it
made no difference, same results.

Is the problem the MB is unstable at these memory timings?
I though ABIT was a good board, which other MB can I switch
to that can handler the hi perf memory?

Electro 09-04-2005 06:22 PM

Try setting the motherboard to fail-safe settings in the BIOS. Then decrease the memory timings a little bit which you already did. The difference in non-ECC memory versus ECC memory is data corruption. ECC memory may cost more but it is worth it over the life of the computer.

Comaring Windows to Linux is not smart because Windows only uses 70% to 80% of your system. Linux uses 100%. Computers may have a sufficient heatsink for Windows, but the heatsink may not be sufficient in Linux. Linux is a good OS to really burn a system in.

I do not why you bought Redhat Enterprise because there are many Linux distributions that are free and work equally well.

I have no problems with Abit motherboards in Linux.

randyding 09-04-2005 08:08 PM

Thanks, I'll continue to try decreasing the settings. I was just thinking it was strange to fail so consistently on the kernel decompression. I'll probably not buy the higher cost performance memory anymore after this experience.

I've been using RH Enterprise at home because I quite often take work home with me and all of my development is for customers on RHES. I've become comfortable with it and heck I can afford it so that's just what I've settled with to run my own domains. I also run Fedora now as well. They both work well.

All times are GMT -5. The time now is 12:17 PM.