-   Linux - Hardware (
-   -   Help with Xine & Mplayer video playback (

ssenuta 02-03-2010 12:37 PM

Help with Xine & Mplayer video playback
I just built a new Linux box & cannot get Movies (dvds or files) to play properly.
Xine playback is jittery but audio stays in sync with video.
Xine complains about "Too Many Dropped Frames"
Mplayer playback is ok but audio & video are way out of sync.
Mplayer says my system is "Too Slow"
I think it might be a RADEON driver issue because my Mandriva-2009.1 uses version: 1.6.1
& maybe those drivers ( don't fully support the ATI Radeon HD 4200 GPU. I know
there is a prorietory driver (fglrx) but before trying it I'd like to here what you guys think.

Here is some relevant info about my computer:

Asus M4A785T-M
CPU AMD Athlon II (X2) Soscket AM3
Chipset AMD 785G/SB710
Graphics ATI Radeon HD 4200 GPU (integrated)
Audio VIA VT1708S
Memory 2GB DDR3

lspci -vv
01:05.0 VGA compatible controller: ATI Technologies Inc Device 9710 (prog-if 00 [VGA controller])
Subsystem: ASUSTeK Computer Inc. Device 83a2
01:05.1 Audio device: ATI Technologies Inc Device 970f
Subsystem: ASUSTeK Computer Inc. Device 83a2
Kernel driver in use: HDA Intel
Kernel modules: snd-hda-intel

Note: Radeon module is not listed unless I issue the "modprobe radeon" command.
It seems X uses its "" not the kernel "radeon.ko" If I do
modprobe radeon,..I doesn't help Xine or Mplayer playback. version: 1.6.1

(--) PCI:*(0@1:5:0) ATI Technologies Inc unknown chipset (0x9710) rev 0, Mem @ 0xd0000000/268435456,
0xfeaf0000/65536, 0xfe900000/1048576, I/O @ 0x0000d000/256.
(WW) RADEON(0): Direct rendering disabled
(EE) RADEON(0): Acceleration initialization failed
(II) RADEON(0): Acceleration disabled
(II) Loading /usr/lib/xorg/modules/drivers//
(II) Module radeon: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 6.12.2
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 5.0

xorg.conf (This is not the complete file ..just a snip of some sections of interest)
Section "Module"
Load "dri"
Load "record"
Load "dbe"
Load "vnc"
Load "extmod"
Load "glx"
Load "dri2"

Section "Device"
Identifier "Card0"
Driver "radeon"
VendorName "ATI Technologies Inc"
BoardName "Asus M4A785T-M"
BusID "PCI:1:5:0"
Option "AccelMethod" "EXA"
Option "DRI" "1" ## My attempt to Enable DRI... I also tried "DRI" "on"

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"

Sorry this post is so long. I know it isn't easy to sift thru a long post because that is exactly what I've been doing this past week while try ing to get a solution. Thank you.

adamk75 02-03-2010 01:47 PM

You can only get 2D acceleration with that GPU if you are using kernel 2.6.30 or higher. You will also need a newer version of the Xorg radeon driver. I believe 6.12.4 was the first version with 2D acceleration for your GPU, and you are using 6.12.2.

ssenuta 02-03-2010 11:47 PM

If 2D acceleration allows me to play movies, that is ok by me. I'm not into playing games or other high end video stuff.

However, you also say I need to get the Xorg radeon driver version 6.12.4 or higher. Does that mean I have to install a whole newer version of ?

That will be a problem because Mandriva packages this driver in their x11-server-common- & a higher numbered package is for the new Mandriva-2010.0 distribution. I also believe building X from source is not an easy task.

How can I get a new version of the /usr/lib/xorg/modules/drivers/ ? I am already running Kernel-

adamk75 02-04-2010 05:16 AM

You do not need to install a whole new version of Xorg, just a newer version of that driver, which you can download from here:

You would uncompress that tarball, run:

./configure --prefix=/usr --with-xorg-module-dir=/usr/lib/xorg/modules

Then run 'make' and 'make install' (as root or with sudo).


ssenuta 02-04-2010 08:01 PM

Thank you!!! You solved my Xine & Mplayer playback problem.

I downloaded & installed the xf86-video-ati-6.12.4.tar.bz2 tarball exactly like you said & everything is working fine now.

Here is a snip of the lsmod command output:
radeon 437442 1
ttm 23909 1 radeon
drm_kms_helper 17131 1 radeon
drm 103336 4 radeon,ttm,drm_kms_helper
agpgart 19008 2 ttm,drm
i2c_algo_bit 3579 1 radeon

Note: The above modules were not there before your fix.

Here is a snip of Xorg.0.log after tarball build/install:

(II) LoadModule: "radeon"
(II) Loading /usr/lib/xorg/modules/drivers//
(II) Module radeon: vendor="X.Org Foundation"
compiled for 1.6.1, module version = 6.12.4
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 5.0

(II) RADEON(0): Direct rendering enabled
(II) RADEON(0): Setting EXA maxPitchBytes
(II) EXA(0): Offscreen pixmap area of 117538816 bytes
(II) EXA(0): Driver registered support for the following operations:
(II) Solid
(II) Copy
(II) Composite (RENDER acceleration)
(II) UploadToScreen
(II) DownloadFromScreen
(II) RADEON(0): Acceleration enabled
(**) RADEON(0): DPMS enabled

(EE) AIGLX error: dlopen of /usr/lib/dri/ failed (/usr/lib /dri/ cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Loaded and initialized /usr/lib/dri/
(II) GLX: Initialized DRISWRAST GL provider for screen 0

Thanks again & thanks to everyone that took the time to read my post.

adamk75 02-04-2010 08:08 PM

Cool, glad I could help. The AIGLX messages are simply tell you that you don't have the 3D driver installed. That would require building libdrm and mesa from source (and possibly other components).

All times are GMT -5. The time now is 10:43 PM.