LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-19-2007, 02:43 PM   #1
ssenuta
Member
 
Registered: Mar 2006
Location: NYS
Distribution: Mandriva-2006
Posts: 123

Rep: Reputation: 16
Help with ACPI & APM needed


I just upgraded to kernel-2.6.23.1 from kernel-2.6.22.1 and now my computer power will not turn off at (init 0) shutdown. It just freezes up forcing me to use the reset button, However, if I choose (init 6) reboot, the computer will reboot

To avoid this problem I have to disable (operating system controlled) ACPI in my lilo.conf with the acpi=off option. This allows Linux to substitute the older (bios controlled) APM technology of power management & my computer will then poweroff. I guess there is a bug in the kernel-2.6.23.1 ACPI because the kernel-2.6.22.1 ACPI worked fine on this same
computer.

However, I am a little uncomfortable about switching power managers from ACPI to APM because I just don't understand the benefits of using them on a stand-alone desktop computer that isn't battery powered. Can anyone explain the advantages or disadvantages of using a power manager in simple terms? What would happen if both ACPI & APM were disabled by a user or not even configured into the kernel?
 
Old 10-20-2007, 11:35 AM   #2
pejakm
LQ Newbie
 
Registered: Oct 2007
Posts: 8

Rep: Reputation: 0
Hi ssenuta!

I had the exactly same problem with 2.6.23.1. I solved it by recompiling it with this set of options:

Quote:
#
# Power management options (ACPI, APM)
#
CONFIG_PM=y
# CONFIG_PM_LEGACY is not set
# CONFIG_PM_DEBUG is not set
CONFIG_PM_SLEEP=y
CONFIG_SUSPEND_UP_POSSIBLE=y
CONFIG_SUSPEND=y
CONFIG_HIBERNATION_UP_POSSIBLE=y
# CONFIG_HIBERNATION is not set
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
# CONFIG_ACPI_PROCFS is not set
# CONFIG_ACPI_PROC_EVENT is not set
CONFIG_ACPI_AC=m
# CONFIG_ACPI_BATTERY is not set
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_FAN=m
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_TOSHIBA is not set
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
# CONFIG_ACPI_CONTAINER is not set
# CONFIG_ACPI_SBS is not set
# CONFIG_APM is not set
(Bold text are the changes I've done second time I compiled the kernel.)
 
Old 10-20-2007, 07:39 PM   #3
ssenuta
Member
 
Registered: Mar 2006
Location: NYS
Distribution: Mandriva-2006
Posts: 123

Original Poster
Rep: Reputation: 16
Thanks PEJAKM

I appreciate your reply & will check my kernel-2.6.23.1 Power Management options in the .config file.

Also, I filed a Power-Off Bug report today which was assigned #9194 by the Bugzilla.Kernel.org if anyone is interested. If this is a real kernel bug & not just something specific to my machine, I'd like them to fix it at the factory so everyone can benefit.
 
Old 10-23-2007, 07:01 AM   #4
ssenuta
Member
 
Registered: Mar 2006
Location: NYS
Distribution: Mandriva-2006
Posts: 123

Original Poster
Rep: Reputation: 16
Re- Configuration didn't help ACPI poweroff problem

As suggested, I rebuilt kernel-2.6.23.1 with the following ACPI configuration options disabled but my system still refuses to poweroff:

[ ] Depreciated /proc/acpi files support
[ ] Depreciated /proc/acpi/event support

I did not attempt to disable APM power management though because it is an important FALL-BACK Feature.
 
Old 10-25-2007, 10:31 PM   #5
ssenuta
Member
 
Registered: Mar 2006
Location: NYS
Distribution: Mandriva-2006
Posts: 123

Original Poster
Rep: Reputation: 16
Hi Pejakm

As you suggested I finally disabled APM & my computer will now shutdown when using ACPI. Seems like the new kernel does not like the Config_APM option anymore.

I was under the impression that you could have both ACPI & APM configured because the kernel would use ACPI if your system supported it or automatically fall back to APM.

It now seems a user can configure both but he must also manually disable the one not being used with boot parameters apm=off or acpi=off. Thank again for your reply.
 
Old 10-26-2007, 08:16 AM   #6
pejakm
LQ Newbie
 
Registered: Oct 2007
Posts: 8

Rep: Reputation: 0
Hi!

OK, I'm glad you've solved it finaly!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ACPI vs APM ptawe Debian 1 02-21-2006 01:58 PM
Need help with apm/acpi slinky2004 Linux - Hardware 11 09-09-2005 10:57 PM
ACPI and APM dvrboy Linux - Laptop and Netbook 1 03-08-2005 06:19 AM
ACPI vs. APM perry Linux - Hardware 0 07-21-2004 01:13 PM
apm vs. acpi ? (modprobe: FATAL: Error inserting apm) OneManArmy Linux - Laptop and Netbook 0 05-12-2004 04:39 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration