LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Help with ACPI & APM needed (https://www.linuxquestions.org/questions/linux-hardware-18/help-with-acpi-and-apm-needed-593095/)

ssenuta 10-19-2007 03:43 PM

Help with ACPI & APM needed
 
I just upgraded to kernel-2.6.23.1 from kernel-2.6.22.1 and now my computer power will not turn off at (init 0) shutdown. It just freezes up forcing me to use the reset button, However, if I choose (init 6) reboot, the computer will reboot

To avoid this problem I have to disable (operating system controlled) ACPI in my lilo.conf with the acpi=off option. This allows Linux to substitute the older (bios controlled) APM technology of power management & my computer will then poweroff. I guess there is a bug in the kernel-2.6.23.1 ACPI because the kernel-2.6.22.1 ACPI worked fine on this same
computer.

However, I am a little uncomfortable about switching power managers from ACPI to APM because I just don't understand the benefits of using them on a stand-alone desktop computer that isn't battery powered. Can anyone explain the advantages or disadvantages of using a power manager in simple terms? What would happen if both ACPI & APM were disabled by a user or not even configured into the kernel?

pejakm 10-20-2007 12:35 PM

Hi ssenuta!

I had the exactly same problem with 2.6.23.1. I solved it by recompiling it with this set of options:

Quote:

#
# Power management options (ACPI, APM)
#
CONFIG_PM=y
# CONFIG_PM_LEGACY is not set
# CONFIG_PM_DEBUG is not set
CONFIG_PM_SLEEP=y
CONFIG_SUSPEND_UP_POSSIBLE=y
CONFIG_SUSPEND=y
CONFIG_HIBERNATION_UP_POSSIBLE=y
# CONFIG_HIBERNATION is not set
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
# CONFIG_ACPI_PROCFS is not set
# CONFIG_ACPI_PROC_EVENT is not set
CONFIG_ACPI_AC=m
# CONFIG_ACPI_BATTERY is not set
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_FAN=m
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_THERMAL=m
# CONFIG_ACPI_ASUS is not set
# CONFIG_ACPI_TOSHIBA is not set
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
CONFIG_X86_PM_TIMER=y
# CONFIG_ACPI_CONTAINER is not set
# CONFIG_ACPI_SBS is not set
# CONFIG_APM is not set
(Bold text are the changes I've done second time I compiled the kernel.)

ssenuta 10-20-2007 08:39 PM

Thanks PEJAKM
 
I appreciate your reply & will check my kernel-2.6.23.1 Power Management options in the .config file.

Also, I filed a Power-Off Bug report today which was assigned #9194 by the Bugzilla.Kernel.org if anyone is interested. If this is a real kernel bug & not just something specific to my machine, I'd like them to fix it at the factory so everyone can benefit.

ssenuta 10-23-2007 08:01 AM

Re- Configuration didn't help ACPI poweroff problem
 
As suggested, I rebuilt kernel-2.6.23.1 with the following ACPI configuration options disabled but my system still refuses to poweroff:

[ ] Depreciated /proc/acpi files support
[ ] Depreciated /proc/acpi/event support

I did not attempt to disable APM power management though because it is an important FALL-BACK Feature.

ssenuta 10-25-2007 11:31 PM

Hi Pejakm
 
As you suggested I finally disabled APM & my computer will now shutdown when using ACPI. Seems like the new kernel does not like the Config_APM option anymore.

I was under the impression that you could have both ACPI & APM configured because the kernel would use ACPI if your system supported it or automatically fall back to APM.

It now seems a user can configure both but he must also manually disable the one not being used with boot parameters apm=off or acpi=off. Thank again for your reply.

pejakm 10-26-2007 09:16 AM

Hi!

OK, I'm glad you've solved it finaly!


All times are GMT -5. The time now is 10:30 AM.