LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 11-04-2002, 02:48 PM   #1
vdorta
LQ Newbie
 
Registered: Aug 2002
Posts: 11

Rep: Reputation: 0
Help on activating Cisco Aironet 350 PCMCIA wireless card in RH8


The Cisco 350 card is recognized but I cannot activate it. I read somewhere that this has to be done manually, whatever that means. Any help would be appreciated.

Val
 
Old 11-04-2002, 03:56 PM   #2
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 65
I think the old module package from cisco around the 2.2.x kernels required some hinkiness to get the card running. If the modules airo and airo_cs (I think that's the right pair), show up under the command:

/sbin/lsmod

Then it should just be a matter of ifconfig'ing the card up and giving it the "iwconfig" commands for your network... What happens with those?

Cheers,

Finegan
 
Old 11-04-2002, 05:07 PM   #3
vdorta
LQ Newbie
 
Registered: Aug 2002
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks finegan, but I am a Linux newbie and don't know how to do what you suggest. I am on XP now and will not be able to follow instructions, but I will certainly write them down.
 
Old 11-04-2002, 06:41 PM   #4
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 65
Oh, no problem... here's a little more step by step:

/sbin/lsmod will list all of the currently loaded modules. A module is driver support for some hardware/filesystem/doodad that wasn't compiled directly into the kernel.

One of the cute things about pcmcia is that you know the driver loaded and bound to the card when you hear two identically pitched beeps during startup.

ifconfig eth0 up

Will bring up the device if its the only ethernet device onboard. For instance if you have a normal 10/100 based whatever built-in, then the wireless card will most likely get assigned eth1.

iwconfig eth0 essid blahblahblah

Will configure the card to talk to the wireless network blahblahblah. You might want to check the man page on iwconfig, its actually well written unlike many others. Mostly you'll be worried about the arguments: "essid" and "enc".

Then manually invoking the dhcp client will probably grab a lease:

dhcpcd eth0

Then you should be connected, there's a hundred ways to automate all of that goop, post back if it works or where things get hung up, something might be different about your aironet card, but I doubt it.

Cheers,

Finegan
 
Old 11-05-2002, 07:15 AM   #5
vdorta
LQ Newbie
 
Registered: Aug 2002
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks again finegan. The laptop is an IBM with built in ethernet plus a PCMCIA wireless card. RH8 recognizes both. I will do what you suggest and post back.
 
Old 11-05-2002, 06:42 PM   #6
vdorta
LQ Newbie
 
Registered: Aug 2002
Posts: 11

Original Poster
Rep: Reputation: 0
finegan,

1. /sbin/lsmod gives the following (among more data):

airo_cs 0 unused
airo 0 [airo_cs]
ds 1 [airo_cs]
yenta_socket 1
pcmcia_core 0 [airo_cs ds yenta_socket]
eepro 100 0

2. The two beeps are there, so the card is recognized at startup.

3. lconfig eth0, lconfig eth1, iwconfig eth0, iwconfig eth1 all give "command not found" message.

4. /etc/init.d/pcmcia restart is OK

5. When leaving network configuration, this message appears:
"eht1 has an alias to module airo_cs in modules.config, instead of currently loaded module airo!"

Val
 
Old 11-05-2002, 07:29 PM   #7
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 65
1. cool, all there.
2. cool, working.

3. You have to be root, and if you used su to become root, you're going to need to type out the full path to the command, i.e.:

/sbin/iwconfig

or possibly (different by distro and I don't know RH's hijynx):

/usr/sbin/iwconfig

ifconfig should always be: /sbin/ifconfig

Or, better, use "su -" This will re-log in you entirely as root and all of those commands should work fine without the full path. /sbin means system binaries, stuff not normally usuable by a user, so they're not in a normal user's path. When you use 'su' to become root, you normally keep the old user's path. (this is a recent annoyance added to the bash shell)

Also "ifconfig", not "lconfig".

4. good.

5. Dunno what that'll mean in the long run, probably RH building stupid aliases for devices and not remembering that pcmcia handles stuff differently.

Cheers,

Finegan
 
Old 11-05-2002, 09:19 PM   #8
vdorta
LQ Newbie
 
Registered: Aug 2002
Posts: 11

Original Poster
Rep: Reputation: 0
Super thanks, finegan and sorry for my "lconfig" mistake. Yes, I have been doing all this in a terminal as root.

Number 5: I forgot to say that the message first appeared when rebooting after I had removed eth1 by mistake.

I will do ifconfig and iwconfig again with full paths.

Val
 
Old 02-02-2003, 07:14 PM   #9
michoffm
LQ Newbie
 
Registered: Jan 2003
Location: Amsterdam
Distribution: RedHat 8.0
Posts: 8

Rep: Reputation: 0
The procedure described by finegan actually worked for me, thanks !

The only thing is that it seems to be only working when using no encryption.

As soon as I enable 128 bit encryption on the Access Point I can still associate with it, but I don't get an IP address anymore via dhclient eth1.

It seems that the encryption mechanism used by the RH8 driver is different or not understood by the AP.

Any comments and hints welcome.
 
Old 02-02-2003, 07:24 PM   #10
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 65
If iwconfig can't set the encryption right for you, you might want to try the actual utility from cisco. I've only ever gotten to play with an aironet once, and that was on a borrowed machine where iwconfig worked... so I dunno:

iwconfig eth0 enc 21321321321

Then check iwconfig again to see if you have a signal, or are getting a ton of invalid crypt frames that the laptop can't decrypt as its key doesn't truly match.

Cheers,

Finegan
 
Old 02-03-2003, 04:16 AM   #11
michoffm
LQ Newbie
 
Registered: Jan 2003
Location: Amsterdam
Distribution: RedHat 8.0
Posts: 8

Rep: Reputation: 0
Thanks again Finegan,

that's exactly what I see, a lot of crypt frames ....

Any thoughts where to go from here ?

Cheers,
Michael
 
Old 02-03-2003, 01:07 PM   #12
michoffm
LQ Newbie
 
Registered: Jan 2003
Location: Amsterdam
Distribution: RedHat 8.0
Posts: 8

Rep: Reputation: 0
It seems that I am making progress.... the critical part was setting the rate to auto ....
I am using a Cisco 350 card, Fw: 4.25.30!
Access-Point is also Cisco 1200 AP, Fw: 11.50

The following works, order of commands is critical:

after boot, logged in as root:
1. iwconfig eth1 rate auto
2. iwconfig eth1 essid [your SSID ]
3. iwconfig eth1 enc [26 hex characters ]

After this, you should see something like....

[root@localhost root]# iwconfig eth1

eth1 IEEE 802.11-DS ESSID:"natuschka"
Mode:Managed Frequency:2.412GHz Access Point: 00:02:8A:0E:365
Bit Rate:11Mb/s Tx-Power=17 dBm Sensitivity=0/65535
Retry limit:16 RTS thrff Fragment thrff
Encryption key:****-****-****-****-****-****-** Encryption modepen Power Managementff
Link Quality:14/10 Signal level:-43 dBm Noise level:-256 dBm
Rx invalid nwid:17412 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:3465 Missed beacon:0

the most important info here is the Access Point MAC address, because anything other than FF:FF:FF:FF:FF:FF:FF:FF means : YES you are associated!

ANd now, final step is :
dhclient eth1

and you're on air !
 
Old 02-16-2003, 11:47 AM   #13
sslewis
LQ Newbie
 
Registered: Feb 2003
Location: London
Distribution: Redhat
Posts: 3

Rep: Reputation: 0
The above post is spot on. Thanks.

Now, how do I make redhat use that config on boot (or ifup) ?

Right now, ifup eth0 causes redhat to trample all over that config and I have to go through the iwconfig and dhclient steps above by hand...
 
Old 02-16-2003, 11:52 AM   #14
finegan
LQ Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 65
Edit:

/etc/sysconfig/network-scripts/ifcg-eth0

with all of the specific iwconfig info.

Cheers,

Finegan
 
Old 02-16-2003, 01:09 PM   #15
sslewis
LQ Newbie
 
Registered: Feb 2003
Location: London
Distribution: Redhat
Posts: 3

Rep: Reputation: 0
Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cisco Aironet 350 Wireless Card teo_jason81 Linux - Wireless Networking 2 11-14-2005 10:43 AM
Cisco aironet 350 wireless card error edberskine Linux - Wireless Networking 0 10-23-2005 08:00 PM
Cisco Aironet 350 PCMCIA on Mandrake 10.0 gbrethen Linux - Wireless Networking 5 07-01-2004 08:18 AM
Slackware 9.1 / 2.4.22, Cisco Aironet 350 PCMCIA card error message!? Don_Quixote Linux - Networking 1 04-13-2004 06:23 PM
pcmcia cisco aironet 350 net travels Linux - Newbie 5 07-15-2002 02:28 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration