LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Help! New GeForce 4 causing problems (https://www.linuxquestions.org/questions/linux-hardware-18/help-new-geforce-4-causing-problems-50464/)

Shaka999 03-18-2003 11:18 AM

Help! New GeForce 4 causing problems
 
Hey all,

I'm a Linux newbie....so be gentle.

I'm running RH8 on a dual boot system with XP. I recently had some pretty bad system issues which I tracked down to a failing GeForce3 card. After replacing the card things are running pretty well.....at least in XP.

After having tons of problems just getting X11 to come up I've finally got a screen. The problem is the performance is TERRIBLE. When I drage a window it is slow to respond and then jumps all over. I never had this before with the geforce3.

The system is also choosing 60Hz as the refresh rate even though I've specified a faster refresh.

Can anyone give me some clues to check? When I try and use the RH annoconda (or whatever its called) installer it doesn't even recognize this as an nvidia card but tries to use a vesa default.


Thanks for any help. So far I haven't had much luck googling for an answer.

Brad

----------------
Here is my XF86Config
----------------
# File generated by anaconda.

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
# The location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
# Option "AutoRepeat" "500 5"
# when using XQUEUE, comment out the above line, and uncomment the
# following line
# Option "Protocol" "Xqueue"
# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
#Option "XkbOptions" ""
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us" #Option "XkbVariant" ""
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Korea Data Systems Avitron AV-7T"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 120.0
Option "dpms"
EndSection

Section "Device"
# no known options
#BusID
Identifier "NVIDIA GeForce 4 (generic)"
Driver "nvidia"
VendorName "NVIDIA GeForce 4 (generic)"
BoardName "NVIDIA GeForce 4 (generic)"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 4 (generic)"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection

Shaka999 03-18-2003 11:37 AM

I forgot to mention a few things

System
Athlon 1800+
GeForce4 4200
MSI KT133A MB

I'm seeing the problems with running gnome. I yet to try KDE.

Shaka999 03-18-2003 01:00 PM

Ok, the monitor refresh was because of bad setting in the config and I've fixed that.

I am now running KDE and it is responding MUCH faster than gnome. This is with the same config file. Guess I'll be using KDE.


All times are GMT -5. The time now is 03:46 AM.