LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 08-17-2003, 01:31 PM   #1
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Help needed with Smart and Friendly CD-RW drive


Hi! I have a Smart and Friendly SCSI external CD-RW burner and it used to work consistently and reliably. Recently (like the past month or so), I've been having problems with "check condition" errors when burning data CD-Rs.

I'm using a Slackware 8 Linux system with 2.4.20 kernel (I was running with 2.4.21-ac4 but I never got my IDE CD-ROM working correctly under 2.4.21-ac4 so I went back to 2.4.20), glibc-2.3.2, and XFree86 4.3.0.

Here is the /proc/scsi/scsi output for the burner:

root@c71414-a:/proc/scsi# cat scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 06 Lun: 00
Vendor: SAF Model: CD-RW6424S Rev: 1.50
Type: CD-ROM ANSI SCSI revision: 02
root@c71414-a:/proc/scsi#

I use SimpleCDR-X 1.3.1 as my burning app and it uses cdrecord 2.0.0:


root@c71414-a:/proc/scsi# cdrecord --version
Cdrecord 2.00.3 (i686-pc-linux-gnu) Copyright (C) 1995-2002 Jörg Schilling
root@c71414-a:/proc/scsi#

Here is the command issued by SimpleCDR-X to burn the data CD:

exec_cmd #cd /tmp; mkdir .temp; cd .temp; mkisofs -allow-lowercase -allow-multidot -J -jcharset iso8859-1 -iso-level 3 -v -v -R -relaxed-filenames -graft-points -path-list=/tmp/simplecdrxDgTElY -m .temp -m '/tmp/*' -o /tmp/.temp/simplecdrxPFOrEp.iso /tmp#
[DEBUG] Progressbar 135417952 has been switched to activity mode
Create Image finished!
Burning CD...
cd /tmp/.temp; rm *.bin; cdrecord fs=8192k -v speed=0 dev=0,6,0 -data /tmp/.temp/simplecdrxPFOrEp.iso
[DEBUG] gtk_idle return tag 0
[DEBUG] exec_cmd #cd /tmp/.temp; rm *.bin; cdrecord fs=8192k -v speed=0 dev=0,6,0 -data /tmp/.temp/simplecdrxPFOrEp.iso#
[DEBUG] Progressbar 135417952 has been switched to activity mode
Finished!

Here is the result of the burn:

Track 01: 233 of 677 MB written (fifo 100%) [buf 100%] 1.0x.
Track 01: 234 of 677 MB written (fifo 100%) [buf 100%] 1.0x.
Track 01: 235 of 677 MB written (fifo 100%) [buf 100%] 1.0x.
Track 01: 236 of 677 MB written (fifo 100%) [buf 100%] 1.0x.
cdrecord: Input/output error. write_g1: scsi sendcmd: no error
CDB: 2A 00 00 01 D9 3C 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: F0 00 03 00 01 D6 B1 0C 00 00 00 00 0C 00 00 00
Sense Key: 0x3 Medium Error, Segment 0
Sense Code: 0x0C Qual 0x00 (write error) Fru 0x0
Sense flags: Blk 120497 (valid)
resid: 63488
cmd finished after 2.262s timeout 40s
Sense Bytes: 70 00 00 00 00 00 00 0C 00 00 00 00 00 00 00 00 00 00

cdrecord: Input/output error. flush cache: scsi sendcmd: no error
write track data: error after 248111104 bytes
CDB: 35 00 00 00 00 00 00 00 00 00
Trouble flushing the cache
status: 0x2 (CHECK CONDITION)
Writing time: 1624.013s
Sense Bytes: 70 00 03 00 00 00 00 0C 00 00 00 00 0C 00 00 00
Average write speed 2.9x.
Sense Key: 0x3 Medium Error, Segment 0
Min drive buffer fill was 100%
Sense Code: 0x0C Qual 0x00 (write error) Fru 0x0
Fixating...
Sense flags: Blk 0 (not valid)
cmd finished after 3.440s timeout 120s
Fixating time: 241.873s
cdrecord: fifo had 4036 puts and 3909 gets.
cdrecord: fifo was 0 times empty and 3889 times full, min fill was 85%.

I'm using Memorex 700MB/80 min/48x CD-Rs as my media and I'm doing a great job of making "coasters" out of the CD-Rs with the above behavior.

Any ideas on what's going on? Can anyone recommend a replacement CD-RW burner?

Thanks in advance!

Peace...

Last edited by tomdkat; 08-17-2003 at 01:32 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
DVD on RH9 hogs CPU (100%) reading, chatty 'smart' NMI to blame? (combo drive) Saigua Linux - Hardware 0 08-07-2003 04:48 PM
TREK (smart) USB flash drive pkdk657 Slackware 2 03-06-2003 10:16 AM
USB Smart Drive compatible with lin? wldkos Linux - General 10 01-23-2003 04:35 PM
LS-120 Smart Drive 3.5" dohicks@cyberpo Linux - Software 8 10-08-2001 09:21 PM
Suggestions needed for a new CD-ROM drive Rimmer Linux - General 2 04-22-2001 05:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration