-   Linux - Hardware (
-   -   HELP me !! sound configuration (

meka 11-22-2004 10:32 AM

HELP me !! sound configuration
i can't make my sound to work on slackware 10
i've an intel integrated sound

when i run alsaconf it's ok
but when i'm running alsamixer i can't change my volumes (except capture )
and even more upper left corner at card it mentioned:
Card: Brooketree Bt878
chip: bt87

also i have a tuner whit this chip

this is my lsmod

Module Size Used by Tainted: P
snd-ac97-codec 49500 0 (unused)
gameport 1420 0 (unused)
snd-mpu401-uart 3200 0 (unused)
snd-rawmidi 12740 0 [snd-mpu401-uart]
snd-seq-device 3888 0 [snd-rawmidi]
snd-pcm-oss 37736 0
snd-mixer-oss 12504 0 [snd-pcm-oss]
keybdev 2052 0 (unused)
mousedev 4212 1
hid 21220 0 (unused)
input 3200 0 [keybdev mousedev hid]
i810_rng 2528 0 (unused)
uhci 24444 0 (unused)
usbcore 59308 1 [hid uhci]
nvidia 3205624 6
eepro100 19252 1
mii 2272 0 [eepro100]
tuner 10184 1 (autoclean)
tda9887 3072 1 (autoclean)
tvaudio 13480 0 (autoclean) (unused)
bttv 94656 0
i2c-algo-bit 7144 1 [bttv]
i2c-core 12804 0 [tuner tda9887 tvaudio bttv i2c-algo-bit]
videodev 5952 2 [bttv]
snd-bt87x 5192 0
snd-pcm 56072 0 [snd-pcm-oss snd-bt87x]
snd-timer 13604 0 [snd-pcm]
snd-page-alloc 6328 0 [snd-bt87x snd-pcm]
snd 30852 0 [snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device snd-pcm-oss snd-mixer-oss snd-bt87x snd-pcm snd-timer]
soundcore 3396 4 [bttv snd]
pcmcia_core 39972 0
ntfs 51424 4 (autoclean)
ide-scsi 9328 0
agpgart 43940 3

also my /etc/modprobe.conf is empy

so what should i do to make my soundcard to work

mritch 11-22-2004 12:11 PM

> Card: Brooketree Bt878

if you have such a card besides your (onbaord?) i8x0 (? CHx/model), the later will get another resource/device. so the mixer of the second card will be the second alsamixer. same with pcm - alsa's second pcm, ...

sl mritch.

meka 11-22-2004 01:48 PM

finaly I've solved the problem
sound card war properly installed but ....

but sound card 0 was the tv tuner
and the real sound card war installed as second
stupid isn't it
so when i was running alsamixer (default card 0) i could't change my volumes

the answer :
alsamixer -c 1
or in x mode rightclick on taskbar , add applet ,sound mixer

meka 11-22-2004 04:10 PM

where should i apend line :
"modprobe snd-intel8x0"
this will install my sound card

ps offtopic
what about line
rmmod usbmouse


mritch 11-22-2004 04:54 PM

to make it permanent? /etc/modules (on debian)

sl mritch.

meka 11-24-2004 07:25 AM

i solved this problem but not permanently
after every loghin my alsamixer si reset ( sound off all)
so i've to raise my volumes every time

so.. what shoul i do to make my volumes sets penmanently

also when i give alsamixer and give ctrl+/ in window
-----( / from right on numLock)
apears listed /proc/asound/cards/ like
card 0- tv tuner
card 1- real soundcard
i suppose i have to switch this 2
or probably to modify a config file to load alsamixer for my sound card at startup

any advice will be welcomed

if i'm right your

mritch 11-24-2004 10:02 AM

try changing order first. this can be done with your alsa configuration.

there should be a mixer program with alsa, saving your current mixer settings into a file at shutdown and reload it on bootup. if there is none such - consider using setmixer and other programs that can do this or simple put a line to set the mixer in a suitable bootupscript.
example "/usr/bin/rexima vol 100 -d /dev/mixer1"

sl mritch.

All times are GMT -5. The time now is 07:57 PM.