LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Help finding Driver... (https://www.linuxquestions.org/questions/linux-hardware-18/help-finding-driver-166550/)

sdpeelejr 04-05-2004 04:04 PM

Help finding Driver...
 
I need help finding a Linux Video Card Driver for a Cirrus Logic GD544x. I've searched, but I can't seem to find it. Anyone care to help?

Thanks to all.

- Stevie

tricky_linux 04-05-2004 04:55 PM

take a look at
http://www.linuxforum.com/linux-hardware/video.html

sdpeelejr 04-05-2004 05:16 PM

Thanks for the reply.

My video card is listed on there. What does that mean? What now?

Thanks so much.

sdpeelejr 04-05-2004 06:51 PM

bump

Chris H 04-05-2004 07:54 PM

It means to edit your /etc/XF86Config file and change the graphics card driver to "cirrus".

I've an nvidia chipset so mine looks like this

Section "Device"
Identifier "VESA Framebuffer"
Driver "nvidia"
#VideoRam 65536
# Insert Clocks lines here if appropriate
EndSection

So change whatever you have to cirrus.

HTH

sdpeelejr 04-05-2004 08:03 PM

Thanks so much. My driver was already set to cirrus so
Code:

Section "Device"
Indentifier "Videocard0" /* could this be a prob? */
Driver "cirrus"
VendorName "Videocard vendor" /* could this be a prob? */
BoardName "Cirrus Logic GD544x"
EndSection

Could those commented sections be causing a problem?

Chris H 04-05-2004 08:22 PM

Unlikely to be a prob. Just make sure that Videocard0 is set as device in Section Screen.

BTW, how do you know that it's not working?

sdpeelejr 04-05-2004 08:54 PM

I've been having problems. My monitor is capable of > 640x480 and it is not going any higher than that. 640x480 is killing me :cry:

flyfishin 04-05-2004 09:00 PM

You list your distro as Fedora Core. I am assuming you are using that. So when you run redhat-config-xfree86, I think that is the command, doesn't it setup your card properly?

sdpeelejr 04-05-2004 09:08 PM

I believe it did. My card is onboard, so I can't really tell if it is correct. I am assuming it is.

I would love it if I could Iron out this problem, i've been wrestling with it for 2 weeks now. Thanks.

flyfishin 04-05-2004 09:15 PM

So when you run redhat-config-xfree86 doesn't it give you the option to select your resolution?

sdpeelejr 04-06-2004 06:52 AM

Yes, it does, but when I restart like it says, the resolution is still on 640x480. :(

When it says "restart the X server." What is the X Server, lol.

Thanks

Chris H 04-06-2004 07:02 AM

Can you post or link your /etc/XF86Config file? (or is it -4?)

sdpeelejr 04-06-2004 07:27 AM

/etc/X11/XF86Config:
Code:

# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "MAG InnoVision DX17F"
HorizSync 30.0 - 64.0
VertRefresh 50.0 - 90.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "cirrus"
VendorName "Videocard vendor"
BoardName "Cirrus Logic GD544x"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


flyfishin 04-06-2004 08:46 AM

Is that really your monitor? The MAG InnoVision DX17F? If so then redhat-config-xfree86 did an interesting job of setting it up. According to this page:

http://www.monitoronsale.com/product...ductID=900201A

Your horizontal sync and vertical sync are:

HSCAN: 30-70Khz
VSCAN: 48-160Hz

So try these things:

1. Change

HorizSync 30.0 - 64.0
VertRefresh 50.0 - 90.0

to

HorizSync 30-70
VertRefresh 48-160

2. Change

DefaultDepth 24

to

DefaultDepth 16

You might want to double check those Horiz and Vert values just to be sure. If you set those up wrong you can burn out your monitor, I've never done it myself. Maybe the config was being a little too conservative.


All times are GMT -5. The time now is 10:28 PM.