-   Linux - Hardware (
-   -   HELP: C-Media audio under slackware 9.0 (

fysx 04-05-2003 12:42 PM

HELP: C-Media audio under slackware 9.0
I have a K7S5A motherboard and it comes with a build in C-Media audio device. The driver CD that comes with the motherboard has a driver for a C-Media 9738 that works under windows, so I'm assuming that I have a C-Media 9738. This device has worked under SuSE linux 8.1, but I don't recall what driver module was installed. I installed Slackware 9.0 and after the system boots up, an lsmod command reveals that it loaded a driver for i810_audio and ac97_codec. I checked all the initialization scripts in /etc/rc.d and couldn't find anywhere where it specifies to load those devices. So my first question is where are those devices being loaded from? After a tonne of mucking around, I found that I can add the line
alias i810_audio off
to my /etc/modules.conf file and it represses the loading of the i810_audio device and the ac97_codec. I am assuming that the device I was is cmpci, so i added the line
/sbin/modprobe cmpci
to my /etc/rc.d/rc.modules file
now an lsmod shows that that is the sound module loaded (as well as soundcore). unfortunately, i still don't get any audio. the command
play somewave.wav
gives the error
sox: Unable to set audio speed to 22050 (set to 32000)
and when i start kde i get a similar error saying that a request to set the audio to 44100 failed, using 32000 instead. but still no audio.

I am at a total loss what to do next. I even tried downloading, compiling and installing the driver from the c-media web site, still nothing. i've been at this for two days solid. can someone please help? sorry for the long e-mail :)...

could you e-mail me at, tnx.


finegan 04-08-2003 12:53 PM

There's a big difference between slack 8.1 and 9.0, like a year's work on the kernel.... cmpci is made for an entirely different rev of the same chip that got beefed hardcore, so it makes sense that it loaded, are you using 2.4.20 or 2.4.18? Also, I know the new version of this kid works well with the alsa modules... for what that's worth, which makes sense as to why SuSe liked it. You could raw compile alsa...

Where did you get the source for this kid, got a link?



fysx 04-09-2003 02:00 PM

I'm using a 2.4.20 kernel. The cmpci module came with the Slackware 9.0 distribution. I did find the source for the C-Media 9738/S device at

This compiled into a module called cmaudio, but this module didn't work either. However using this module I got the error 'could not sync with DSP' rather than the error 'sox: Unable to set audio speed to 22050 (set to 32000)' . Any ideas there?

Also, after some searching, I'm not convinced the driver I want is C-Media 9738. This is the device windows uses (and this is the device on the mainboard CD). But upon first installation, slackware loads i810_audio and ac97_codec. It recognizes my device as an SiS7012, which is also what the mainboard manual says is installed on the mainboard. Furthermore, the command lspci lists my audio device as an SiS7012. I think starting with kernel 2.4.18, the i810_audio driver supports the SiS7012 and is shipped with the kernel. So if slackware thinks it should load the i810_audio driver it might be correct, but that still doesn't explain why it doesn't work.

Thanks for the help though. Have any more suggestions? I'll try the alsa drivers and let you know.

finegan 04-09-2003 04:49 PM

Do you get this from /sbin/lspci:

00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] SiS7012 PCI Audio Accelerator (rev a0)

If so, yeah, its an SIS7012 covered by the i810_audio, I've got the same card on board in my work machine, I can't get software volume adjustment, and stuff sounds scratchy, but I only wear headphones every once in a while at work. I know for certain the sis7012 works much better under alsa, I've just been too lazy to compile it... that's probably the best shot.



fysx 04-11-2003 11:24 AM

that is exactly the lin /sbin/lspci gives. it's good to know you have the same card and have it working somewhat. this still doesn't explain why this driver doesn't produce any sound on my computer though. did you do any setup in particular, or just install slack and it worked?

i do have a bttv card as well and the soundcore module makes use of the bttv module and the btaudio module, but i don't think there are any conflicts, because things don't start magically working when i remove those modules.

thanks for the replies, btw

finegan 04-11-2003 12:44 PM

Nothing special, installed Slack 8.1, downloaded and compiled 2.4.20 after applying the xfs patch, nothing exciting at all. I never tried the 2.4.18 kernel module if that helps, didn't even bother to configure the sound until I had the machine at work.



fysx 04-11-2003 12:53 PM

i solved it!!

the problem seems to be that the btaudio module is mapping onto /dev/dsp and not the i810_audio module. unloading the btaudio module didn't fix the problem because the i810_audio module still wasn't mapped onto /dev/dsp. unloading both the btaudio module and the i810_audio module and then reloading the i810_audio module makes everything work magically.

so... any ideas how i can cause the btaudio module to load after the i810_audio module, or how i can force the i810_audio module to map to /dev/dsp? and the btaudio module to map to something else?


Aussie 04-11-2003 04:56 PM

Add the btaudio module to /etc/hotplug/blacklist to stop hotplug from loading it, and load it after all the other modules by adding '/sbin/modprobe btaudio' to /etc/rc.d/rc.local.

Another way would be to add the following to your /etc/modules.conf,
alias sound-slot-0 i810_audio
alias sound-slot-1 btaudio

steved123 04-30-2003 09:52 PM

c-media 9738
I'm running redhat 8.0. I just installed a board with the c-media 9738 onboard sound. I enabled ac_97, the intel 810 driver and the c-media 8738 sound in the kernel. it works good. the board is a ecs l7s7a2. the linux was already on the drive and configured for a ecs k7s5a board previously.

All times are GMT -5. The time now is 12:41 PM.