LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-06-2005, 10:48 PM   #1
tkienzle
Member
 
Registered: Feb 2005
Location: Kansas City MO
Distribution: openSUSE 11.4
Posts: 90

Rep: Reputation: 15
Hello mnt Problem SATA 120 gb win drive..


Hello i have a problem well not a problem i just want to use this drive its on my main screen here and it keeps giving me err "mount: wrong fs type, bad option, bad superblock on /dev/sdb1,
or too many mounted file systems
Please check that the disk is entered correctly."

any one got any help it has win XP on it and it is on a Iwill IS150 sATA pci card
thanks any help is great P.S. Very new to this just started running linux about 3 week
ago
 
Old 02-07-2005, 05:31 AM   #2
tkienzle
Member
 
Registered: Feb 2005
Location: Kansas City MO
Distribution: openSUSE 11.4
Posts: 90

Original Poster
Rep: Reputation: 15
Can i not move stuff off of this drive because it is ntfs? i wanted to copy some stuff off of it...then format for linux..
 
Old 02-07-2005, 07:35 PM   #3
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
You should be able to read the drive. Best practice is to treat NTFS partitions as "read only".

We will need to see the line in your /etc/fstab file that deals with the drive (or the command that you are using to try to mount it).

It should look something like:

/dev/sdb1 /mnt/sdb1 ntfs auto,ro 0 0

Or you could try (as root user):
mount -t ntfs -o ro /dev/sdb1 /mnt/sdb1

Note that he mount point (/mnt/sdb1 in my examples) must be a directory that exist.
 
Old 02-07-2005, 10:30 PM   #4
tkienzle
Member
 
Registered: Feb 2005
Location: Kansas City MO
Distribution: openSUSE 11.4
Posts: 90

Original Poster
Rep: Reputation: 15
thanks for the help i will have to try it out and see.. if i'm in config the cpu-->mandrak control center--->hardware--->then goto the harddrive thing "Disk drak"--->sda1 Tab --->mount point it need to be /dev/sdb1 or /mnt/sdb1 or both...but you all so said try root # comandline i would asume and just put "mount -t ntfs -o ro /dev/sdb1 /mnt/sdb1" ok i have to turn the cpu off to hook it back up and i will re post if i need more help thanks
 
Old 02-08-2005, 12:26 AM   #5
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
The mount point is where the data shows up at. /dev/sdb1 is the actual device where the data is stored. It is not where you go to access the data though. To access the data you mount the device to a folder in the system (called the mount point, /mnt/sdb1 for example). Then, anything that is in the drive will show up in the mount point.

/mnt/sdb1 is an older style of mount point. Some systems will use a different directory by default. You will need to know that the mount point exists before it will work.
 
Old 02-08-2005, 08:36 PM   #6
tkienzle
Member
 
Registered: Feb 2005
Location: Kansas City MO
Distribution: openSUSE 11.4
Posts: 90

Original Poster
Rep: Reputation: 15
Ok it lets me access it in the konsole but it gives me this error "Could not enter folder /mnt/sdb1" why is that..if i found the dir i want in the konsole whats the command to copy a dir over to a diffrent dir say i wanted to copy /mnt/sdb1/pic's to /mnt/removable/pic's....how would i do that...or is their something i can do to access it maybe i need to grant access to the user's...not sure how to do that because i am a "NEWBIE" hee hee sorry ...
 
Old 02-09-2005, 01:25 AM   #7
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
Hmmm. I'm going to go out on a limb here, and guess at what happened. I'll guess that you edited your fstab, mounted the drive (perhaps with "auto" as in my example), and tried to access it as a normal user.

Since NTFS doesn't track Unix style permissions, Linux has to guess at what to use. Try adding the following to the options list:

umask=0222

I'm not sure of the "2"s. I think this is right. For example:

/dev/sdb1 /mnt/sdb1 ntfs auto,ro,umask=0222 0 0

And the command to copy something is 'cp'. You will need to use the "-r" flag to copy a directory (the 'r' is for recursive). for example:

cp -r /mnt/sdb1/pic\'s /mnt/removable/pic\'s

(the backslashes are necessary as an escape character because ' has special meaning in bash.)
 
Old 02-09-2005, 10:00 AM   #8
tkienzle
Member
 
Registered: Feb 2005
Location: Kansas City MO
Distribution: openSUSE 11.4
Posts: 90

Original Poster
Rep: Reputation: 15
Thanks for all the help i could not get it to work in kde so i used the "mount -t ntfs -o ro /dev/sdb1 /mnt/sdb1"line you gave me and then i entered Midnight commander and did all my copying with that very easy i could not make heads or tails of the "/dev/sdb1 /mnt/sdb1 ntfs auto,ro 0 0" or "/dev/sdb1 /mnt/sdb1 ntfs auto,ro,umask=0222 0 0" not sure we are talking about the same thing. and if we are then i'm to newbiefied to understand... but thats ok i'll get it one day... the command console is very cool it is so universal in the sense that linux all runs on unix...if you are willing to explain more on the other stuff i am willing to read it and try more....
 
Old 02-16-2005, 10:03 PM   #9
tkienzle
Member
 
Registered: Feb 2005
Location: Kansas City MO
Distribution: openSUSE 11.4
Posts: 90

Original Poster
Rep: Reputation: 15
ok gd2shoes i have figured it out but it still is giving me problems

i found /etc/fstab but it don't have the line we spoke about it has this line
/dev/sdc1 /mnt/sdb1 auto umask=0,user ,iocharset=iso8859-1, sodepage=850, suid, exec, kudzu, users 0 0

i'm going to go out on a limb to and guess i can't access a ntfs drive in my GUI because every time i try
it don't work

i can access it in console...

well any way when i decide to make the move to the bigger hard drive is their any way to move the operating system to it or will i just have to reinstall it?
 
Old 02-17-2005, 12:52 PM   #10
gd2shoe
Member
 
Registered: Jun 2004
Location: Northern CA
Distribution: Debian
Posts: 835

Rep: Reputation: 49
"/dev/sdc1"

Here's your problem, or at least one of them. When you try to mount your /dev/sdb1 it is trying to mount /dev/sdc1 instead. That line should either start with:

/dev/sdb1 /mnt/sdb1

or

/dev/sdc1 /mnt/sdc1

Check with "cat /proc/partitions". This will tell you every drive and partition on the system. Unless you have an sdc1, I would just change it to say /dev/sdb1. If you do have an sdc1, you may want to copy the line and modify it.

I'm noticing a few errors on the line. I'll assume that you did not copy/paste. There should be no spaces in the comma-separated list. That should be "codepage" (change the 's'). I don't have a clue what the "kudzu" option is.

After you have an apropriate line in the fstab, you should be able to simply say "mount /mnt/hdb1" or "mount /dev/hdb1" and linux will go to the fstab file to look for the details. Further, I would expect the gui to work (though it may play by a few of it's own rules, not sure).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Current Suse9.1, new SATA drive for Win Share jch0rd SUSE / openSUSE 3 10-03-2005 03:06 AM
how do i mnt my win partition lil_ak Linux - Software 11 06-21-2004 08:09 AM
Can't format 120 gig sata HD to ext3 jackstoage Mandriva 3 06-15-2004 12:10 PM
/mnt/win? redhat 8.0 bullwinkel Linux - Newbie 10 12-17-2002 07:56 PM
one more question about /mnt/win from Linux ..sorry purpleburple Linux - General 3 07-06-2002 07:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration