-   Linux - Hardware (
-   -   hdparm -tT not working for my cd drives (

LavaDevil94 04-30-2004 09:23 PM

hdparm -tT not working for my cd drives
i can hdparm -tT the /dev/hda (my harddrive) fine, but when i do hdc or hdd (my cdwriter and dvdrom):

hdparm -tT /dev/hdd

read() hit EOF - device too small
Timing buffered disk reads: 0MB in 0.00 seconds = nan MB/sec
Hmm... suspicious results: probably not enough memory for a proper test

thats the end of the output. i had around 400mb of ram free at the time of testing, so i think the hdparm assumption is wrong. does anyone have any ideas?

RolledOat 04-30-2004 09:38 PM

Do you have a data CD in it and is it mounted?


LavaDevil94 04-30-2004 10:18 PM

i didnt think you were supposed to... nevertheless, i tried it, and i got the same result. any other suggestions?

RolledOat 05-01-2004 12:37 AM

Well, I found two things on google. The first, I don't know what it means,

AFAICT hdparm says "suspicious results" when the disk speed is greater
than one-half the buffer speed. I just got 51.20 and 26.34 on the PPro
with my patches and the message came out again.

The second, make sure that you are root when you are doing the test. I saw several
posts where the suspicious came out when running hdparm -t as non root. Beyond that,
I don't know.

I was unsure about the mounted thing, but figured it couldn't hurt.


whansard 05-01-2004 01:10 AM

that's what you get when the drive is scsi emulated.

LavaDevil94 05-01-2004 09:18 AM

oh, well i do have both drives scsi emulated, although the scsi devices are:
/dev/scd0 (/dev/hdc)
/dev/scd1 (/dev/hdd)
i dont like using scsi emulation (i have an ide-only system), but i have to, otherwise i cant use my cdrom drives at all.

whansard 05-01-2004 02:28 PM

you could turn it off just to test the drives speed if you wanted.
i read my statement above, and it sounds like a chastisement. i just meant thats what we all get when the drive is scsi-emulated. i have one drive like that and one drive not. hdc is scsi emulated.

/# hdparm -tT /dev/hdc
read() hit EOF - device too small
Timing buffered disk reads: read() hit EOF - device too small

/# hdparm -tT /dev/hdd
Timing buffer-cache reads: 128 MB in 0.90 seconds =142.38 MB/sec
Timing buffered disk reads: 64 MB in 22.77 seconds = 2.81 MB/sec

LavaDevil94 05-01-2004 02:51 PM

if i remove ide_scsi (i have it as a module, doesnt work otherwise), and i do hdparm -tT /dev/hdd:
/dev/hdd: no such device or address
despite the fact that i can do ls -l /dev/hdd and it pops right up.

whansard 05-01-2004 04:56 PM

i meant to remove the "hdd=ide-scsi" from your boot loader, reboot and test it, then
put it back like it was.

Electro 05-01-2004 05:54 PM

Just to note, hdparm will not give you real speed. You can use dd and time. Then calculate the kilobytes per second. Benchmarking CDs is a little tedious. You have to split up the CD into thirds then tell dd to start at a certain sector and to skip a certain amount of sectors. You can use bonnie or other benchmark program to get a more accurate result.

LavaDevil94 05-01-2004 07:38 PM

ok, ill try both of those suggestions. thanks :D.

Inhibit 05-01-2004 07:53 PM

Just a note. What you might want to do is make sure your enabling UDMA support on the IDE bus and channels as part of the "append" line in your bootloader. Something like


or if you've got a newer/supported drive


of course replacing "hdx" with your drive letter in /dev, such as "hdc". If you're interested in finding out more, refer to the doc's in Documentation/ide.txt from the linux kernel source.

All times are GMT -5. The time now is 09:31 PM.