-   Linux - Hardware (
-   -   HDD password required on boot, don't even get grub.... (

phazon 02-25-2014 07:43 PM

HDD password required on boot, don't even get grub....
I was given a hard drive that is bigger than the one I currently use. I was hoping to put it in and boot from a live USB stick or live CD and re-format it and install Linux on it and have a bigger hard drive. Weird thing though; Even though I have either a USB stick, or a live CD in the drive, the computer won't boot from them, it simply shows a DOS looking box on the screen that says "HDD password" with a place to enter a password. This hard drive was taken out of another computer which got an upgrade and was more-or-less dis-guarded; probably because of this required password.

How can I get around this password, and re-format the drive?

Thanks in advance.

Isaac Velando 02-25-2014 07:57 PM

Are you certain you set the boot order to look for CD/USB before the HDD in question? I can't imagine that they're being checked but the HDD is somehow superseding the boot order and forcing it to be decrypted or otherwise unlocked before anything else happens. In the worst case you could try unplugging the HDD, boot from the live media, and hotplug in the HDD, but I'd definitely double check the boot order before trying anything else. Usually a BIOS has a hotkey like F2, F9, F10, F12, or Del to either enter a boot order menu or the setup before it tries to boot from a device, and usually this hotkey is displayed on the BIOS POST screen.

Alternatively if the boot order is set correctly but it's going for the HDD first anyway, it's likely that your live media wasn't set up correctly.

Emerson 02-25-2014 08:31 PM

Is this a laptop drive.

michaelk 02-25-2014 08:47 PM

Please post the make/model of computer if known and the hard drive manufacture. A search should lead to some information if it is possible to remove the password. I would guess that it isn't possible unless your willing to pay lots of money...

Please be aware that hacking is beyond the scope of this forum.

descendant_command 02-25-2014 10:40 PM

If the HDD password feature provided by the drives firmware could be easily bypassed, it wouldn't be much use would it?

On the plus side, you now have a novelty paperweight to impress your friends with... :)

phazon 02-26-2014 06:46 AM

Isaac Velando - boot order is USB, CD/DVD, HDD. It is indeed puzzling why it would put that up before booting form the USB

Emerson - Laptop drive

michaelk - after spending about 2 hours reading blogs, posts, how-to, etc. It seems that the make and model of either has no baring on the password.

descendant_command - not much help, but painfully close to the truth.

From what I have been able to gather, the password is part of the firmware on the HDD. Wiping the drive would not obliterate the password since it is not resident on the memory of the platter.

There do seem to be some forensic software and hardware choices to brute your way through it, but those cost more than a new drive, so unless I had a stack of these, that would not be an option for me at this time. I might spend another hour at the most trying to get lucky on this, but I do believe that there is no free lunch after all.

phazon 02-26-2014 02:12 PM

Ok, interesting development. I got this hard drive from a neighborhood computer repair place. I told them that maybe I could get past the password. Thye did not think that I could. In fact, so far, that is true. I can not.

This is a 160 GB drive. When I took it back to them, they told me that it was locked up when they tried putting it into one of the laptops they have there. Apparently, if they put anything larger than a 80 GB drive into that computer, it creates this ned for a password and locks up the drive. I have never heard of this.

They pulled out a 500 GB drive for me to fool around with. I watch they tech put it on a tether and format it, no problem.

I put it in my laptop, and BOOM, it wants a password.... hmmm, The dirve tht I use in this laptop is a 60 GB drive, no problems with it. I am wondering if this is some kind of protection mechanism that laptops have if you try to install a drive that is "too big" for that machine.

What then would be too big?


John VV 02-26-2014 02:18 PM

a question
is a very old copy old windows xp running now on that computer ?
something that is missing say the last 5 years of security updates

if so
wipe the drive and flash the firmware and disinfect it

metaschima 02-26-2014 03:10 PM

Laptops, especially old ones are prone to BIOS bugs. For example, when I tried to replace an old HDD for a new one (expensive one), it refused to see it. It also refused to boot with new RAM unless an old RAM was also present. I scrapped it because there were no BIOS updates available and no way to revive it.

phazon 02-27-2014 06:30 PM

John VV - how do I "flash the firmware"?

metaschima - I suspected something like what you are saying. I am glad I trie this hard drive before buying a nice new one because if this is going to happen on all of them it would be a bummer; however, I put a 320 GB hdd (used) into it and I was able to get it partitioned, and put three distros on it, and left a 200 GB partition on it for storage. So far I am able to use it although it seems like my machine runs slower on it. Also, I get an error when I boot that it is going to fail, and pushing f1 allows me to contiure. I think the problem is on a tiny (1 gb) ntfs partition I left on it. Also, I don't have permission to save anything to teh large partition...

I got this machine as a learning tool, so it is all good, but still would like to know that I can get a nice new HDD some day and use it.

metaschima 02-27-2014 06:33 PM

With laptops/netbooks you shouldn't order parts online, because you never know if they are actually gonna work. Some thing happened with RAM for my netbook, I went to the store and we tried RAM sticks of the exact same specifications, but from different companies, only one set worked. If I would have ordered them online, it would have been a nightmare to keep sending them back.

phazon 02-28-2014 08:25 PM

so, how does one "flash the firmware"?

metaschima 02-28-2014 09:55 PM

If there is a BIOS update that has fixes mention this, then you download it and flash it, but if the power goes out or something unforeseen happens, it may brick your computer. Certainly, you should never flash from Windoze, only from the BIOS menu (EZ-flash etc.) or a DOS boot disk.

This is not guaranteed to improve anything. It didn't for my netbook, even tho there were BIOS updates for it.

phazon 03-08-2014 01:23 PM

So after getting some advice on another forum, then trying severl scenarios, this is what works.

The storage partition is roughly 200 gig and is at location sda12, so

Edit est/fstab by adding the following line

/dev/sda12 /media/ralph/storage ext4 defaults 0 0

to make sure sda12 is mounted

sudo mount -a
to grant permissions to sda12, at the terminal enter

sudo chmod 777 /media/ralph/storage
This "sticks" after shutdown and reboot. I don't have to do this evenry session. I have permissions to the storage drive every time I boot up.

Still don't have an answer as to why I did not have to do this with a 60 gig drive I was using.

All times are GMT -5. The time now is 04:55 PM.