LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   "hdc: lost interrupt" - hard drive hangs (https://www.linuxquestions.org/questions/linux-hardware-18/hdc-lost-interrupt-hard-drive-hangs-320441/)

philetus 05-05-2005 12:54 PM

"hdc: lost interrupt" - hard drive hangs [solved]
 
hi,

I recently installed gentoo with kernel 2.6.11-gentoo, and the hard drive frequently hangs on reads for several seconds, and afterwards there is the following message in the log:

Code:

irq 13: nobody cared!
 [<c0136e2a>] __report_bad_irq+0x2a/0x90
 [<c0136760>] handle_IRQ_event+0x30/0x70
 [<c0136f1c>] note_interrupt+0x6c/0xd0
 [<c01368e6>] __do_IRQ+0x146/0x160
 [<c0104e03>] do_IRQ+0x23/0x40
 [<c01033ca>] common_interrupt+0x1a/0x20
 [<c0136750>] handle_IRQ_event+0x20/0x70
 [<c01087dd>] mask_and_ack_8259A+0x5d/0x100
 [<c013687e>] __do_IRQ+0xde/0x160
 [<c0104e03>] do_IRQ+0x23/0x40
 [<c01033ca>] common_interrupt+0x1a/0x20
 [<c0251aae>] acpi_processor_idle+0x123/0x260
 [<c01010d8>] cpu_idle+0x48/0x60
 [<c050a73b>] start_kernel+0x14b/0x170
 [<c050a330>] unknown_bootoption+0x0/0x1b0
handlers:
[<c029ccf0>] (ide_intr+0x0/0x1b0)
Disabling IRQ #13
hdc: lost interrupt

any suggestions? here is the contents of /proc/interrupts and /proc/io:

Code:

l33tb0x root # cat /proc/interrupts
          CPU0
  0:    1212042          XT-PIC  timer
  1:      1333          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  7:      28278          XT-PIC  yenta, eth0
  9:      1164          XT-PIC  acpi
 11:      34771          XT-PIC  ehci_hcd, ohci_hcd, ohci_hcd, SiS SI7012
 12:      70940          XT-PIC  i8042
 13:    700008          XT-PIC  ide0
NMI:          0
ERR:          0

l33tb0x root # cat /proc/ioports
0000-001f : dma1
0020-0021 : pic1
0040-0043 : timer0
0050-0053 : timer1
0060-006f : keyboard
0080-008f : dma page reg
00a0-00a1 : pic2
00c0-00df : dma2
00f0-00ff : fpu
0170-0177 : ide1
01f0-01f7 : ide0
0300-0301 : pnp 00:04
0310-031f : pnp 00:04
0376-0376 : ide1
03c0-03df : vga+
03f6-03f6 : ide0
0480-048f : pnp 00:04
04d0-04d1 : pnp 00:04
0cf8-0cff : PCI conf1
1000-107f : motherboard
  1000-1003 : PM1a_EVT_BLK
  1004-1005 : PM1a_CNT_BLK
  1008-100b : PM_TMR
  1010-1015 : ACPI CPU throttle
  1016-1016 : PM2_CNT_BLK
  1020-1023 : GPE0_BLK
  1030-1033 : GPE1_BLK
1080-10ff : motherboard
  1080-10ff : pnp 00:04
1100-110f : 0000:00:02.5
1400-141f : 0000:00:02.1
4000-40ff : PCI CardBus #02
4400-44ff : PCI CardBus #02
c000-dfff : PCI Bus #01
  c000-c07f : 0000:01:00.0
e000-e0ff : 0000:00:02.6
e100-e17f : 0000:00:02.6
e200-e2ff : 0000:00:02.7
  e200-e2ff : SiS SI7012
e300-e37f : 0000:00:02.7
  e300-e37f : SiS SI7012
e400-e4ff : 0000:00:04.0
  e400-e4ff : sis900


Matir 05-05-2005 12:56 PM

This is certainly not a good thing. It appears as though your hard drive controller is dropping interrupts: is your IDE controller on-motherboard?

philetus 05-05-2005 01:03 PM

I think the ide controller *is* on the motherboard. here is the output of lspci:

Code:

l33tb0x root # lspci
0000:00:00.0 Host bridge: Silicon Integrated Systems [SiS] 741/741GX/M741 Host (rev 03)
0000:00:01.0 PCI bridge: Silicon Integrated Systems [SiS]: Unknown device 0003
0000:00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
0000:00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
0000:00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
0000:00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
0000:00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
0000:00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
0000:00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
0000:00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
0000:00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 91)
0000:00:07.0 Network controller: RaLink Ralink RT2500 802.11 Cardbus Reference Card (rev 01)
0000:00:0c.0 CardBus bridge: ENE Technology Inc CB1410 Cardbus Controller (rev 01)
0000:01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP VGA Display Adapter

I am pretty sure all of the SiS stuff is on the motherboard. do you think that is relevant to the problem?

Matir 05-05-2005 01:41 PM

It could be hardware, but you may want to look into this: http://www.greenend.org.uk/rjk/2002/...interrupt.html

eantoranz 05-05-2005 02:13 PM

In my experience, the HD is fried.

philetus 05-05-2005 02:21 PM

I already looked at the greenend link, I don't seem to have an entry in /proc/interrupts for ide1?

the drive works fine in windows, so I am fairly confident that it is not a hardware problem.

eantoranz 05-05-2005 02:30 PM

mmmmmmmmmmm......... Sure it's not the HD?.... I had that same feeling with a WD HD (Just remembering it, I get sick).

I could use windows.... but linux?.. a nightmare! I tried mounting with sync... and that kept it from getting trashy... but It was a total pain in the @$$. Once in a while, I got a HD problem. I even blamed the motherboard (it was a cheap PCChips motherboard). Then I got a MCI motherboard... and the truth hit me like a brick wall. Once I got a new HD... it all became "the past".

Matir 05-05-2005 02:31 PM

Well, ide1 would be a secondary controller: ide0 is the primary. Similar deal.

eantoranz 05-05-2005 03:17 PM

Matir.... you following me? :D

Matir 05-05-2005 03:45 PM

Nope, just trying to help in those rare situations where i know something

eantoranz 05-05-2005 03:46 PM

Don't say that, Oh, guru of SCSI!

Matir 05-05-2005 03:58 PM

LOL. I wish I were quite a guru. :)

philetus 05-05-2005 06:34 PM

I figured out what was wrong, I just had generic ide support enabled, when I turned off generic ide support and turned on support for my SiS ide controller and recompiled my kernel everything got better.

Matir 05-05-2005 08:33 PM

Glad that you were able to take care of it! :)

LarryS 09-06-2005 12:48 PM

philetus wrote: I figured out what was wrong, I just had generic ide support enabled, when I turned off generic ide support and turned on support for my SiS ide controller and recompiled my kernel everything got better.

Can someone give me some details about how to switch the controller. I am having similar problems with SiS motherboard components.

Thanks,


All times are GMT -5. The time now is 11:05 AM.