LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-17-2010, 08:52 PM   #1
mrb53
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Rep: Reputation: 0
hdb/cdrom1 mounted? debian lenny VLC player


Brand new to linux, just installed debian lenny (first ever install), vlc for my media player (1.0.5). Insert a dvd into dvd rom and system sees the dvd but i cannot play/access it on/from VLC
when i insert the dvd, "Totem (def player) errors - cannot read source -(I dont use totem) I open VLC and can see the file but cant open
I tried to manually mount dev/hdb/media/cdrom1 but it fails and says "does not exist"
I have a cd player on dev/hda and it is recognized but not my dvd
tried "mount -t iso9660/dec/hdb/media/cdrom1"
also mkdir hdb (sucessfully created)
confusing that the system sees the drive and reads that there is media in the drive but i cannot get vlc to play the dvd
ps - is a Sony dvd
I favor VLC and would like help getting it to play
Also - i do not know commands to see hardware and if/which drives are mounted (1 hard drive, 1 cd and 1 dvd)
the fstab contains line
/dev/hdb/media/cdrom1, udf, iso9660 user, auto 0 0
Is not the VLC software becuase i can load music in cd drive and play from VLC so assuming it is hardware or possible software configuration of the hardware device
Thanks
 
Old 02-18-2010, 02:26 AM   #2
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,837

Rep: Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983
vlc has separate device settings for cd and dvd. Chances are it's default settings are set to something like /dev/cdrom and /dev/dvd, respectively, which means dvds would fail if you don't have a /dev/dvd symlink. You can alter them in the preferences by switching to the advanced settings mode, then going to the input/codecs tab.

BTW, disc playback in programs like this usually accesses the device directly, so their mounted status has no bearing on it.
 
Old 02-18-2010, 02:38 AM   #3
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
To play a commercial movie DVD, you also need the tools to decrypt it. This is most likely what is happening to you. Read:
http://www.debuntu.org/how-to-play-d...r-ubuntu-linux

However, there are anomalies in what you have reported which may also contribute (or be typos):

Quote:
I tried to manually mount dev/hdb/media/cdrom1 but it fails and says "does not exist"
tried "mount -t iso9660/dec/hdb/media/cdrom1"
you seem to be leaving out spaces.

dev/hdb/media/cdrom1 is actually /home/$USER/dev/hdb/media/cdrom1 ... which does not exist, as you discovered. That mount command should run like:

mount -t iso9660 /dev/hdb /media/cdrom1

... which is for a data CD - not a DVD. A DVD could be more like:

mount -t udf /dev/hdb /media/cdrom1

... unless it was burned from an iso.

Quote:
also mkdir hdb (sucessfully created)
... and not needed - /dev/hdb is a special file created for the optical device by linux. You normally need to create the mountpoint (/media/cdrom1) - but still not needed as there is a system called udev whose job is to do this.

Quote:
the fstab contains line
/dev/hdb/media/cdrom1, udf, iso9660 user, auto 0 0
Which it shouldn't do. Gaps and commas are in the wrong place.

/dev/hdb /media/cdrom1 udf,iso9660 user,auto 0 0

But anyway, it should say "noauto" instead of "auto" unless there is always a disk in the drive at boot. - perhaps more like:

/dev/hdb /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

Considering the "cdrom1", this is the second optical drive?

After all that - you do not mount audio or video disks to play them. What is expected to happen is that you insert the disk and the player starts. If this is a drive added since install, then it is unlikely that the players are looking at the right one.

Last edited by Simon Bridge; 02-18-2010 at 02:40 AM.
 
Old 02-18-2010, 11:14 AM   #4
mrb53
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by David the H. View Post
vlc has separate device settings for cd and dvd. Chances are it's default settings are set to something like /dev/cdrom and /dev/dvd, respectively, which means dvds would fail if you don't have a /dev/dvd symlink. You can alter them in the preferences by switching to the advanced settings mode, then going to the input/codecs tab.

BTW, disc playback in programs like this usually accesses the device directly, so their mounted status has no bearing on it.
Thanks for insights on mounting status
I am still confused. I went to preferences, and the only place i found "advanced" was under "show all". After enterening advanced I found no where to adjust input/codecs tab. In the input/codecs tab, i could not find where to adjust / add the /dev/dvd symlink
 
Old 02-18-2010, 11:23 AM   #5
mrb53
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Original Poster
Rep: Reputation: 0
typo

Quote:
Originally Posted by Simon Bridge View Post
To play a commercial movie DVD, you also need the tools to decrypt it. This is most likely what is happening to you. Read:
http://www.debuntu.org/how-to-play-d...r-ubuntu-linux

However, there are anomalies in what you have reported which may also contribute (or be typos):



you seem to be leaving out spaces.

dev/hdb/media/cdrom1 is actually /home/$USER/dev/hdb/media/cdrom1 ... which does not exist, as you discovered. That mount command should run like:

mount -t iso9660 /dev/hdb /media/cdrom1

... which is for a data CD - not a DVD. A DVD could be more like:

mount -t udf /dev/hdb /media/cdrom1

... unless it was burned from an iso.


... and not needed - /dev/hdb is a special file created for the optical device by linux. You normally need to create the mountpoint (/media/cdrom1) - but still not needed as there is a system called udev whose job is to do this.


Which it shouldn't do. Gaps and commas are in the wrong place.

/dev/hdb /media/cdrom1 udf,iso9660 user,auto 0 0

But anyway, it should say "noauto" instead of "auto" unless there is always a disk in the drive at boot. - perhaps more like:

/dev/hdb /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

Considering the "cdrom1", this is the second optical drive?

After all that - you do not mount audio or video disks to play them. What is expected to happen is that you insert the disk and the player starts. If this is a drive added since install, then it is unlikely that the players are looking at the right one.
Sorry for the typos as i only placed the data here to show what i did, where /what i found
mount -t udf /dev/hdb /media/cdrom1 - you mention that this should exist in my fstab yet it doesnt
i have 2 lines for cd players
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdb /media/cdrom1 udf,iso9660 user,noauto 0 0
One is my cd/rw
I assumed the other is my dvd (hdb)
cdrom1 is 2nd optical drive
I think that alternate advie from David the H is closer to the problem but your comment on having the proper data in my fstab seems logical. I am unsure as i am so new to this but will try all to resolve
The VLC program works if I place a music disk in the cd drive but i cannot get the dvd to play so your advice is appreciated. How would I add the proper data to my file and what should it be
Thanks
 
Old 02-18-2010, 11:51 AM   #6
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian + kde 4 / 5
Posts: 6,837

Rep: Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983Reputation: 1983
Quote:
Originally Posted by mrb53 View Post
Thanks for insights on mounting status
I am still confused. I went to preferences, and the only place i found "advanced" was under "show all". After enterening advanced I found no where to adjust input/codecs tab. In the input/codecs tab, i could not find where to adjust / add the /dev/dvd symlink
Well, you're looking in the right place. You do have to scroll down a bit though.
Attached Thumbnails
Click image for larger version

Name:	vlc_prefs.png
Views:	7
Size:	81.2 KB
ID:	2782  
 
Old 02-18-2010, 11:56 AM   #7
mrb53
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Original Poster
Rep: Reputation: 0
ok, now what

Quote:
Originally Posted by David the H. View Post
Well, you're looking in the right place. You do have to scroll down a bit though.
I scrolled down (duh!) and found and it is just as pictured
DVD device = dev/hdb
vca & cd = dev/hba

dev/dvd symlink?

please provide details on how/what to do
 
Old 02-18-2010, 09:37 PM   #8
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
Sorry for the typos as i only placed the data here to show what i did, where /what i found
mount -t udf /dev/hdb /media/cdrom1 - you mention that this should exist in my fstab yet it doesnt
Um ... no I didn't.
Quote:
i have 2 lines for cd players
/dev/hda /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/hdb /media/cdrom1 udf,iso9660 user,noauto 0 0
Which is correct.

I take it you have optical drives as primary master and slave on IDE (pata), and you are using the secondary IDE or sata for your HDD?

It is important to report these things accurately since an inability to play DVDs could have been due to typos in fstab and other files.
Quote:
One is my cd/rw
I assumed the other is my dvd (hdb)
cdrom1 is 2nd optical drive
You don't know?

Code:
$ dmesg | grep dvd
[    1.400575] sr0: scsi3-mmc drive: 48x/48x writer dvd-ram cd/rw xa/form2 cdda tray
... in my case it is /dev/sr0

Quote:
I think that alternate advice from David the H is closer to the problem but your comment on having the proper data in my fstab seems logical. I am unsure as i am so new to this but will try all to resolve
The VLC program works if I place a music disk in the cd drive but i cannot get the dvd to play
Yep - David had the right idea.

Note: many systems use generic-named symlinks as a quick way to let programs access the actual device file. So you'll find a /dev/modem is a link that points to whatever the modem device file may be. eg. /dev/ttySL0 or /dev/ttyS3 or something non-obvious. Similarly, there may have been a /dev/dvd which needs to point at your dvd drive, which we presume is /dev/hdb

ls /dev/dvd*

but your report of the configuration options in VLC seem to be telling us that VLC is pointed at /dev/hdb directly.

Can you read data dvds from this drive?
 
Old 02-18-2010, 10:11 PM   #9
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 462Reputation: 462Reputation: 462Reputation: 462Reputation: 462
cat /proc/sys/dev/cdrom/info will show cd/dvd drive info.

Code:
cat /proc/sys/dev/cdrom/info
CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name:		sr1	sr0
drive speed:		48	48
drive # of slots:	1	1
Can close tray:		1	1
Can open tray:		1	1
Can lock tray:		1	1
Can change speed:	1	1
Can select disk:	0	0
Can read multisession:	1	1
Can read MCN:		1	1
Reports media changed:	1	1
Can play audio:		1	1
Can write CD-R:		1	0
Can write CD-RW:	1	0
Can read DVD:		1	1
Can write DVD-R:	1	0
Can write DVD-RAM:	0	0
Can read MRW:		1	1
Can write MRW:		1	1
Can write RAM:		1	1
 
Old 02-19-2010, 03:59 PM   #10
mrb53
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Original Poster
Rep: Reputation: 0
cd rom info

CD-ROM information, Id: cdrom.c 3.20 2003/12/17

drive name: hdb hda
drive speed: 48 48
drive # of slots: 1 1
Can close tray: 1 1
Can open tray: 1 1
Can lock tray: 1 1
Can change speed: 1 1
Can select disk: 0 0
Can read multisession: 1 1
Can read MCN: 1 1
Reports media changed: 1 1
Can play audio: 1 1
Can write CD-R: 1 1
Can write CD-RW: 1 1
Can read DVD: 1 0
Can write DVD-R: 1 0
Can write DVD-RAM: 0 0
Can read MRW: 1 0
Can write MRW: 1 0
Can write RAM: 1 0

new news
opened a web page and downloaded vlc 1.0.5 (debian download)
default with system was earlier version I uninstalled didnt work either which is why i went for newer version--
checked advanced input / codec in VLC
dvd = dev/hdb
cd = dev/hda

totem -now plays the dvd but quality / volume is very low, hard to hear even at top volume, prefer VLC
soundjuicer plays the audio with sound nicely (loud)

this leads me to think that i missed something in the download for 1.0.5
i thought i caught all the recommends and performed them but maybe i am missing something
 
Old 02-20-2010, 12:21 AM   #11
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
this leads me to think that i missed something in the download for 1.0.5
"download"???
Isn't this for Lenny? Surely VLC is in the repos?
 
Old 02-20-2010, 04:02 AM   #12
mrb53
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Original Poster
Rep: Reputation: 0
yes, as i wrote

Quote:
Originally Posted by Simon Bridge View Post
"download"???
Isn't this for Lenny? Surely VLC is in the repos?
the vlc in rpos was and 8.06 version that also didnt work, It came with the Lenny install. I went out and sourced the VLC 1.0.5 and downloaded / installed it after uninstalling the earlier version

none of this helps me get it working
 
Old 02-22-2010, 09:16 PM   #13
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
totem -now plays the dvd but quality / volume is very low, hard to hear even at top volume, prefer VLC
Where are you adjusting the volume? Have you adjusted the sound mixer settings?

Problems with DVD volume are usually solved by adjusting the global sound mixer settings.

In gnome, rt-clicking the volume control applet allows you to change the preferences.

It also helps to know what sort of output you are using. You can usually figure out what has happened when adjusting your global sound preferences - sliders for some outputs may be very low for eg. DVD may be using surround sound but the extra channels are mute... stuff like that.

VLC is still usually preferred due to having pretty complete support for menus, where totem tends to play the first title.

Quote:
new news
opened a web page and downloaded vlc 1.0.5 (debian download)
default with system was earlier version I uninstalled didnt work either which is why i went for newer version--
This way, as you have noted, it is not clear if you have left out some important packages. If you had reinstalled from synaptic, at east that would have been assured.

All you can do is check the recommends lines against the deb packages (check the versions) you have, then try updating them to make sure they are all installed and in the right order. A possible gotcha is if a recommend specifies a lib version much lower than the one you have installed: the lib may have obsoleted part of its syntax in the meantime.

Quote:
none of this helps me get it working
But it does help provide us with a better picture of what you have installed - that helps me to help you. For instance: what else have you installed off a web site? Which web sites have you been using for this? There is a possibility that something is missing or that you have obtained a broken package.

Choosing to install a third-party package opens the range of possibilities to consider in troubleshooting. Thus, when considering how to advise you, your reasons for choosing to do this is quite important.

You installed the latest because the default did not work for you, but you have not said how you had reason to believe the latest would do any better. It follows that removing the new package and reinstalling from synaptic would help restore confidence.

This may help:
http://www.howtoforge.com/forums/showthread.php?t=40958
... or someone who browses to here in future. Look at the perfect debian lenny desktop setup. That + libdvdcss allows dvd playback.

I notice you have yet to describe the symptoms of the failure of VLC to play DVDs. David and I have just been working on common practise which tells us the most likely culprits are encryption and settings.

How are you trying to play the DVD in VLC?
What did you expect to happen?
What happened? (Start from when you insert a DVD.)
Did you got any messages or errors?

Can you access data DVDs?
Have you tried video dvds which are not encrypted?
Have you tried playing from the commandline?
 
Old 02-23-2010, 12:19 PM   #14
mrb53
LQ Newbie
 
Registered: Feb 2010
Posts: 14

Original Poster
Rep: Reputation: 0
I guess its harder than i thought. Having ovr 20yrs ms experiece didnt help. I even tried re-installing deb linux fresh since i had corrupted rpos and went with vlc imbedded in lenny, same issue. checked global audio and access to dvd and they worked. got totem to work except totems volume isnt that good, soundjuic plays audio cd's. gave up and went bak and installed xp home and vlc and got it wrking in about 1 hr
I will try a ubuntu install as i have heard it is an easier o/s to deal with for 1st timers
thanks for all the help, all of you
 
Old 02-24-2010, 01:37 AM   #15
Simon Bridge
LQ Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 198Reputation: 198
Quote:
checked global audio and access to dvd and they worked.
You don't say how you checked this and what you mean by "they worked". This statement is meaningless for troubleshooting.
Quote:
got totem to work
You don't say how
Quote:
except totems volume isnt that good,
again - you have to adjust the channels that are being used for output when you are playing DVDs. You have not answered any of the questions put in the last post. Nobody can help you if you don't do this. Remember: I cannot see your computer so I don't know what is happening unless you tell me. Troubleshooting by text takes longer than sitting in front of the computer.
Quote:
soundjuicer plays audio cd's. gave up and went back and installed xp home and vlc and got it wrking in about 1 hr
That is longer than I'd have expected, unless you include the XP install - what went wrong?
Quote:
I will try a ubuntu install as i have heard it is an easier o/s to deal with for 1st timers thanks for all the help, all of you
After 20 years in windows you should know how to write a fault report for ease of troubleshooting. Other than that, it is unlikely that your windows experience will help you - your intuitions and habits are irrelevant to a software freedom paradigm. To help you get the most of free support forums like LQ, I recommend that you follow the advice link in my sig. It will help you understand how free software geeks think and so understand the replies you've been getting.

The Ubuntu install will have different defaults to the Debian, so it may not need the fiddle to get the sound balance right. An interesting thing to try is to reverse the order of the optical drives on the ide - explicitly selecting the dvd as master. While you are in there - does the dvd have an audio cable like the CD has?

To configure Karmic for your needs, please see:
http://ubuntuguide.org/wiki/Ubuntu:Karmic

Get back to us with your results.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Newer VLC in Debian Lenny matiasar Linux - Software 7 11-12-2009 07:28 AM
VLC not showing video. Debian Lenny 64. glore2002 Debian 8 10-08-2009 01:51 AM
LXer: How-To: Compile and Install Latest VLC in Debian Lenny LXer Syndicated Linux News 0 08-12-2009 06:41 AM
How to change default player from totem to vlc in Epiphany (Debian Lenny, P6) mike11 Linux - Desktop 2 05-07-2009 09:22 PM
LXer: How-To: Compile and Install VLC 0.9.8 in Debian Lenny LXer Syndicated Linux News 0 03-24-2009 06:00 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration