-   Linux - Hardware (
-   -   HDA Nvidia, Realtek ALC1200 (

Amdx2_x64 02-17-2010 02:31 PM

HDA Nvidia, Realtek ALC1200
Card=HDA Nvidia
Chip=Realtek ALC1200
Xubuntu 9.10 64
VLC (also use other video/audio players but this one is my main one.)

I have the speakers plugged into the headphone jack of the audio card.

The problem is that I am stuck in either 6ch or 8ch mode, even with the headphone box checked and all relevant settings where they are suppose to be in alsamixer. I am missing sounds plus the volume is lower then it should be over all. Music, for example, does play but it is not the whole song. For example if I listen to one song, it stops all instruments and is suppose to play and guitar solo. But I don't hear it at all.

What I want to do is get it to work in 2ch. I am using Alsa but I have no idea what to edit, or if there is anything I can edit to get to 2ch.

I do not want to use pulseaudio at all. One of the main reasons why I won't use Gnome (Ubuntu) right now. I have more headaches with that then I am with this problem.

Any ideas or ways I can fix this?

Amdx2_x64 02-19-2010 04:26 AM


Amdx2_x64 02-21-2010 06:30 PM

Bump Bump

GlennsPref 02-21-2010 06:44 PM

Sorry, I'm watching, But have no advice,

try the intel module. (X86-intel)or something

Amdx2_x64 02-22-2010 01:39 AM

Thanks. This is a strange problem. I am hoping that someone has some idea or maybe they will run across a solution by accident, lol.

I will give what you said a try though, can't hurt at this point.

GlennsPref 02-22-2010 03:39 AM

Hi, check the alsawiki to see if your chip is supported.

also check the pci-id's for the chipset.
A few places to look,

lspci lists pci devices installed.
lsmod lists kernel modules installed/loaded. you can add a -v for verbose to both of these commands.
You can also pipe the output through grep, to show only specific info.

lspci | grep 'HDA Nvidia' (more than one string requires quotes)
lsmod | grep 'Realtek ALC1200' (try different combinations, and single strings)

cheers, and good luck!

Amdx2_x64 02-23-2010 10:55 AM

Thanks for the info.

thorkelljarl 02-23-2010 11:56 AM

Maybe a little more information...

What is the make and model of the card, or is this audio integrated on a motherboard, and which? Why are you using the headphone jack, is there an output jack(green) and have you tried to see if there is a signal?

What result does that "lsmod" command tell you about the sound(snd...codec) module that is loaded? What is the result for audio when you run the command"lshw"?

What do you see for results when you run the command "alsamixer" and use the keyboard commands? See man alsamixer.

Alsamixer may or may not allow you to set the output as a stereo signal and to choose where the output is directed.

I have my stereo output through the motherboard's output jack and the designation is Front, that is as if the jack were on the front of the cabinet. These settings are reflected in alsamixer.

However, the audio, which is on the mother board, is produced by the Southbridge controller, as is usual with motherboard audio, and sound production depends on my openSUSE 11.2 installation to configure my MPC65 Southbridge(nForce560 chip) with the correct codec and sound module.

I can enter and modify the configuration settings with the KDE GUI in openSUSE 11.2. Doesn't Xubuntu give you a similar ability and what results or error messages do you get if you try?

If I am mentioning things you already know, it is because you have posted too little of the details.

thorkelljarl 02-23-2010 05:30 PM

I looked...

I booted a copy of the Xubuntu live-cd out of curiosity. On first glance, there appear to be some configuration variables present in the Mixer settings, that Mixer found under Applications at the top-left of the desktop. Was there nothing there that could help you?

The configuration choices there would allow me to duplicate the settings I have in openSUSE 11.2, that is stereo, using the output jack, as Front,

This information may not be of much help to you since the Xubuntu live-cd found and configured my system hardware at boot without trouble, but having done so, thereafter did not supply much more in the way of re-configuration or fault finding.

Amdx2_x64 02-26-2010 12:36 PM

Well I am not sure what I did but I now have no sound, lol. No big deal. I have a hard drive that I use to back up all data so I am just going to reinstall Xubuntu, that will be the quickest way to do this I think. Then I will tackle the problem again and see. I think this sound card is just crap.

GlennsPref 02-26-2010 05:14 PM

Hi, If it's a current soundcard, you may just need to wait a while.

Here is a script you can run that should reveal your sound hardware.

when you use it, check the options with --help.

cd to dir where script was saved. --help


glenn@GamesBox:~$ --help (27-02 09:05) version 0.4.59

Available options:
--with-aplay (includes the output of aplay -l)
--with-amixer (includes the output of amixer)
--with-alsactl (includes the output of alsactl)
--with-configs (includes the output of ~/.asoundrc and
/etc/asound.conf if they exist)
--with-devices (shows the device nodes in /dev/snd/)
--with-dmesg (shows the ALSA/HDA kernel messages)

--output FILE (specify the file to output for no-upload mode)
--update (check server for script updates)
--upload (upload contents to remote server)
--no-upload (do not upload contents to remote server)
--pastebin (use as remote server
--stdout (print alsa information to standard output
instead of a file)
--about (show some information about the script)
--debug (will run the script as normal, but will not
delete /home/glenn/tmp/alsa-info.ya9ID0bHLx/alsa-info.txt)
see if that reveals any more details.

Regards Glenn

Amdx2_x64 02-26-2010 09:21 PM


Originally Posted by GlennsPref (Post 3878241)
Hi, If it's a current soundcard, you may just need to wait a while.

Here is a script you can run that should reveal your sound hardware.

when you use it, check the options with --help.

cd to dir where script was saved. --help

see if that reveals any more details.

Regards Glenn

Thanks. I will give that a try shortly. I am working on three computers right now. I did a clean install of Xubuntu, Absolute and (cry) Vista on my computer.

Soon, after this long, long Vista update, I need to work on the old computer (Gateway/Firewall/etc) and switching that from SME to ClearOS. Then jumping back on mine and getting the basics set up in Xubuntu and Absolute (plus all updates.)

Then I have to update and clean up my daughters computer (xp) and update Xubuntu, which she loves more then windows. If Wine worked better with WoW she wouldn't even use XP at all.

So sometime tonight or tomorrow I will finally be able to get to the Xubuntu sound issue, lol.

Edit: I have the whole place to myself for a day or so. Best time to catch up on all of this.

Amdx2_x64 05-01-2010 02:51 PM

Well I was never able to work on that sound issue. But... With the newer Linux (and BSD) releases it is now working perfectly. That best advice was just to sit back and wait a bit, lol. (Also, how is this for a late reply :D )

Thanks everyone for the help. Sorry it took so long to mark this thread as solved, been very busy.

All times are GMT -5. The time now is 08:52 AM.