LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Having trouble writing to CD (https://www.linuxquestions.org/questions/linux-hardware-18/having-trouble-writing-to-cd-391683/)

cillm527 12-11-2005 06:37 PM

Having trouble writing to CD
 
Several months ago, I got a new computer, but didn't click the option for "cd burner". I thought that was ok, because I already had a CD Drive that I could burn CDs with.

Well, I replaced the CD drive that came with the computer with my other one which I used to write CD's with.

I can read from it just fine, but I don't know how to write to my CD-RW, or even if I can. On my mom's computer (she uses XP), I can "drag and drop" files onto the CD, but I can't seem to be able to do it here. Is there any special software I need, or simply need to utilize? The computer I'm using is mine, so I have root access if I need it.

Here is some of my hardware info:

Code:

0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8378 [KM400] Chipset Host Bri dge
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI Bridge
0000:00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Co ntroller (rev 80)
0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT82 3x/A/C PIPC Bus Master IDE (rev 06)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Contr oller (rev 81)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Contr oller (rev 81)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Contr oller (rev 81)
0000:00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Contr oller (rev 81)
0000:00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South]
0000:00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8 237 AC97 Audio Controller (rev 60)
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 78)
0000:01:00.0 VGA compatible controller: VIA Technologies, Inc. VT8378 [S3 UniChr ome] Integrated Video (rev 01)

Code:

Linux 2.6.8-2-386 i686
I'm not sure how much of that is useful. Oh, and I'm using Debian 3.1.


Thanks for the help,
Cillman.

odevans 12-12-2005 11:58 AM

Cillman,

try k3b. If you're not using KDE, you may need to install Qt. I'm not a debian user, I presume apt would cover the dependancy checking(?).

O

cillm527 12-12-2005 05:52 PM

Ok. The message that I get is that it "cannot find a suitable writer". I'm 104% certain I wrote CDs with this same drive before.

odevans 12-12-2005 07:04 PM

When you ran k3b for the first time, did it run the k3bsetup program (Settings menu -> k3b Setup)?

Also, does your user have write access to the CD drive? You may have to add your user to an additional group (or change permissions on the drive). As I said, I'm not a Debian user - perhaps there are one or two hanging around that could chime in here?

Try it as root - if that works, it's most likely a permissions error.

O

cillm527 12-12-2005 09:33 PM

I ran it as root, I even went through all the setups and configures, and still no go.

I did, however, find out something that might be useful. It's detecting my CD-Drive and everything, but when it's listing the drive's specifications, under "writes CDs" it says "no".

Well, as I wrote earlier, I've written CDs with it before way back when I was using XP. Is it possible I connected the drive incorrectly?

I also remember seeing an error message when I was using cdrecord suggesting Linux2.5 and up had problems with this kind of stuff.

cillm527 12-26-2005 08:30 PM

Sorry to bump this thread, but...still no go.

I've even been able to use my USB Flash Drive, but still having no luck writing CDs...

Here's some more info

fstab
Code:

# /etc/fstab: static file system information.
#
# <file system> <mount point>  <type>  <options>      <dump>  <pass>
proc            /proc          proc    defaults        0      0
/dev/hda1      /              ext3    defaults,errors=remount-ro 0      1
/dev/hda5      none            swap    sw              0      0
/dev/hdc        /media/cdrom    iso9660 rw,user,sync    0      0
/dev/sda1      /media/usb      vfat    rw,user,sync    0      0
/dev/cdrom      /media/cdrom    iso9660 rw,user,noauto  0      0

Oh, and when I put a CDR in my CD drive, #fdisk -l shows no evidence of it recognizing my CD...

And also, k3b says, "unable to find suitable burning device", or something like that.

Like I said before, I know my cd drive can write CDs, because I used to do it way back when I used Windows.

EDIT:

Ok, I think you guys should also see this:
Code:

cdrecord: Warning: Running on Linux-2.6.8-2-386
cdrecord: There are unsettled issues with Linux-2.5 and newer.
cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
cdrecord: Warning: Linux-2.6.8 introduced incompatible interface changes.
cdrecord: Warning: SCSI transport does no longer work for suid root programs.
cdrecord: Warning: if cdrecord fails, try to run it from a root account.
scsidev: '1,5,0'
scsibus: 1 target: 5 lun: 0
cdrecord: No such file or directory. Cannot open '/dev/sg*'. Cannot open SCSI driver.
cdrecord: For possible targets try 'cdrecord -scanbus'.
cdrecord: For possible transport specifiers try 'cdrecord dev=help'.
cdrecord:
cdrecord: For more information, install the cdrtools-doc
cdrecord: package and read /usr/share/doc/cdrecord/README.ATAPI.setup .

Am I supposed to downgrade my kernel just so I can burn CDs? And if so, how exactly do I do that?

Notwerk 12-27-2005 02:12 AM

I think you're problem is that the first CD-Drive that was on the machine was a normal IDE drive. While the new CD-RW drive is actually a SCSI drive using and IDE interface. Try to install the cdrdao package which contains the SCSI commands that control the drive for writing CDs.

PS: I'm using K3b with Debian (2.6.x) and i got the same warning mentioned in your last post, however I..... ehem..... ignored it and things are working fine for me.

Hope this helps.

tormented_one 12-27-2005 02:30 AM

You may need to pass "ide-scsi" to the kernel at boot on the drive. Do a search for ide-scsi on the site I'm sure you'll find out how to do it.

cillm527 12-27-2005 12:23 PM

I did a search, and they all say to edit lilo.conf or grub.conf...well, the closest thing I found on my machine to those files was /usr/share/kernel-package/kpkg_grub.conf

Could you be more specific or point me to a specific thread?

Nylex 12-27-2005 12:32 PM

If you're using GRUB as your bootloader, you may have a file called menu.lst instead of grub.conf. It's probably located in /boot.

cillm527 12-27-2005 08:49 PM

Ok, I found it, and according to other posts I've read on the forum, I'm supposed to add ide-scsi somewhere in the file. But, where? I haven't been able to find it by simply doing a search on "ide-scsi", or "menu.lst ide-scsi", or anything similar.

Notwerk 12-28-2005 02:57 AM

Append it to the end of the line which start with "Kernel".

It's a good idea to keep a copy of the original file before you edit it:
Code:

#cp /boot/grub/menu.lst /boot/grub/menu.lst.original

cillm527 12-28-2005 08:41 AM

section before
Code:


title          Debian GNU/Linux, kernel 2.4.27-2-386
root            (hd0,0)
kernel          /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro
initrd          /boot/initrd.img-2.4.27-2-386
savedefault
boot

title          Debian GNU/Linux, kernel 2.4.27-2-386 (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro single
initrd          /boot/initrd.img-2.4.27-2-386
savedefault
boot

section after
Code:


title          Debian GNU/Linux, kernel 2.4.27-2-386
root            (hd0,0)
kernel          /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro ide-scsi
initrd          /boot/initrd.img-2.4.27-2-386
savedefault
boot

title          Debian GNU/Linux, kernel 2.4.27-2-386 (recovery mode)
root            (hd0,0)
kernel          /boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro single
initrd          /boot/initrd.img-2.4.27-2-386
savedefault
boot

Thanks for responding. So, let's see if it works..

cillm527 12-28-2005 08:50 AM

Well, I did that, and it's still shows up on k3b, and under "Writes CDs", it says "no".

So, I don't know...I swear I remember writing CDs on this one, I'm positive of it. But it is pretty old...Perhaps I should save for a new one?

Notwerk 12-31-2005 10:22 AM

Post what you get from:
Code:

#ls -l /dev | grep cd
#ls -l /dev | grep hd



All times are GMT -5. The time now is 10:56 AM.