LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 01-04-2012, 07:14 AM   #1
Captain Obvious
LQ Newbie
 
Registered: Sep 2009
Distribution: Ubuntu Oneiric Ocelot
Posts: 8

Rep: Reputation: 0
Has anyone been able to get suspend/hibernate to work with Nvidia Optimus?


Because I haven't... I'm darn sure that optimus is the reason for the lockups, although I'm willing to be proven wrong. Main reason I suspect Optimus is because Windows 7 suspends & hibernates perfectly fine, yet I've never been able to get it to work in Linux with this laptop. And it's a known fact that Nvidia kinda screwed us over with their optimus junk.

[rant]
I mean, I respect their desire to keep the optimus technology secret, ergo keeping it closed-source, but that doesn't mean they withhold the driver completely (from open-source systems). Just give us a binary, and we'll be happy. If you're that afraid of people reverse-engineering your technology, best not sell it at all. That's the only REAL way to keep it secret.
[/rant]

I don't intend this to be a Nvidia-flaming thread... I'm more concerned about the original question... just needed to get that out. =P So, uh, suspend/hibernate anyone?

Last edited by Captain Obvious; 01-04-2012 at 07:17 AM.
 
Old 01-05-2012, 11:04 AM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
On my alienware M14x, in the past, suspend would work about half the time under Fedora 15. I honestly think I am having problems due to using the xfce power settings, but I could be wrong. What laptop do you have?
 
Old 01-06-2012, 12:29 AM   #3
Captain Obvious
LQ Newbie
 
Registered: Sep 2009
Distribution: Ubuntu Oneiric Ocelot
Posts: 8

Original Poster
Rep: Reputation: 0
Dell XPS 17 L702X. Intel Core i7-2760QM CPU, 8GiB RAM, w/ 2 GPUs: 1 Nvidia GeForce GT 555M, the other is an Intel integrated chip. Not sure what model exactly, but it uses the i915 driver. I run X on the Intel chip, as that is the only one that Compiz will work on for some reason. Why Nvidia refuses to add GL_EXT_TEXTURE_FROM_PIXMAP after how many years, I don't know, but either way, it's not necessary on my system, cause X runs perfectly fine, and MOST applications cooperate with bumblebee/optirun when I want the extra power...

Alas, sleep/hibernate is a bit of an issue most likely because the system probably forgets to turn off the Nvidia chip, though I have no proof of this. I'm 99% sure the circuitry is designed so that the display goes through the Intel chip only, and there is no direct way to bypass the Intel chip physically.
 
Old 01-06-2012, 12:46 AM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
Do you have any BIOS options to disable the dedicated chipset? And by the way, I have the same two chipsets; The 555M in my Alienware has 3 GB of dedicated VRAM. If you want to, look at my own thread about how I am able to get bumblebee up and running to utilize both video cards.
 
Old 01-06-2012, 12:47 AM   #5
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
Oh by the way, what distro are you running? And here is a link to my thread - http://www.linuxquestions.org/questi...-setup-907457/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Nvidia Optimus revisited malloc Slackware 9 12-28-2011 02:26 PM
NVIDIA GeForce GT 540M graphics & NVIDIA Optimus Technology rabizadeh_ehsan Linux - Hardware 5 10-21-2011 07:39 AM
Hibernate/Suspend doesn't work ibrahim52 Linux - Newbie 14 08-10-2011 08:39 PM
Xfce 4.6 Suspend and Hibernate Function does not work properly with my notebook. phys Slackware 2 03-09-2009 05:46 PM
Boot from USB key, does suspend or hibernate work? paulsiu Linux - Hardware 1 05-02-2008 02:34 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 12:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration