-   Linux - Hardware (
-   -   Has anybody shared a PRINTER to Mac OS X (

webvandals 03-30-2004 12:16 AM

Has anybody shared a PRINTER to Mac OS X
I finally got my weirdo Canon printer working with my Debian box and I figured it would be trivial to then share it with Samba to the Macs (OS 10.3) on my network. But I just can't quite get it going.

I've scoured the net and found fragments of info, but no step-by-step for sharing from Linux to OS X with Samba. Has ANYONE had any success with this? What are the basic steps to take? Thanks!

webvandals 04-12-2004 07:58 PM

Anybody at all? FYI: I'm using KDE 3.2 and cups printing. I have SWAT installed too. All I want is to be able to see (and send jobs to) the printer that's plugged into my Debian box from the Macs on my network.

Any advice at all? Perty pleez?

maroonbaboon 04-13-2004 08:50 AM

As you say there is plenty of advice around on the net e.g.

However, my own attempt to do this ended in complete failure - I just got garbled bitmaps. But the printer I used had fairly flaky Mac OSX support, which may have been the problem. In fact I don't think Samba should be needed at all, as the Mac could see the CUPS printers across the network OK. My advice would be to get the printer working directly on the Mac and then try suggestions in the various HOWTOs with the printer on linux.

webvandals 04-13-2004 08:46 PM

Hey thanks very much for the links, maroonbaboon! (why couldn't I find those?)

Anyway, I'm happy to hear that OS X can deal with CUPS directly and bypass Samba. But I still can't quite crack it. I see that others are able to just plug a Mac into their network and other printers on the network just appear like magic. So maybe it's CUPS on my Linux box that isn't broadcasting.

If I go to http://localhost:631 -- shouldn't I see some sort of CUPS admin thingy? I just get "resource not found on this server". Could that be why my Mac can't see it?

Just stabbing in the dark now... any ideas anyone?

maroonbaboon 04-13-2004 08:56 PM

Hi - Try http://localhost:631/admin.html instead (there is no default page). I seem to recall that if I ran that on the Mac (Mac has CUPS too) I could see the linux printers also. Just couldn't get the driver to work properly.

webvandals 04-13-2004 09:09 PM

Okay, cool that URI works (but strangely all of the images are missing).

Question 1:
Any idea how I could tell CUPS to allow printer sharing/broadcasting/whatever?

Question 2:
My Linux Box is, should I be able to access the CUPS admin from my Mac? When I goto http://localhost:631/admin.html -- I get a "Forbidden" error. Is *this* why my Mac can't see the printer?

maroonbaboon 04-13-2004 09:31 PM

Try also

http://localhost:631/printers/ or http://localhost:631/admin/

on the Mac. Maybe permissions are set differently on Mac and Linux.

I thought CUPS shared by default, but I never got past absolute newbie grade on the subject. I did edit the configuration files in /etc/cups to get the window boxes to print, but was just following some online guides. Also if you are running KDE, the kprint system hides many of the underlying details.

webvandals 05-03-2004 09:35 PM

Still no luck! :-(

Anybody else got some advice, or know of a step by step tutorial? If you have succeeded at this, could you please tell me which you used Samba or CUPS?

All times are GMT -5. The time now is 08:22 PM.