-   Linux - Hardware (
-   -   Hardware issue? GUI Freeze on Linux Distros (

reeprflame 06-23-2004 10:07 AM

Hardware issue? GUI Freeze on Linux Distros
I am really starting to be confused about whether or not my computer is freezing/locking up duie to a hardware issue. What happenes is that when I am running GNOME in Fedora Core 2 [originally x86_64 but now i386...same error] the screen will freeze at the current one, keyboard be non-responsive, yet the mouse will still move around. If it is not that it goes into a Black Screen that usually I can only recover from by restarting; if not it is by pressing CTRL-ALT-F7. It is completely random whether I am working or it is idle and it seems to occur on all distros i put on [FC2 the two versions mentioned above and Mandrake 10]

Heres my Harware specs:

-AMD Athlon 64 3200
-Gigabyte K8n-Pro Motherboard
-512MB 133MHz SDRAM
-MAXTOR 200GB HD [Windows partitions - NTFS]
-Toshiba 10GB HD [with linux installation]
-ATI All In Wonder Radeon PCI Video Card
-etc...I dont think the others are very pertinent to this

I am wondering if it has anything to do with it not liking my sys components and more specifically my Video Card as it is older. I am buying a new one though soon but am wondering if any of that hardware could cause a conflict like this to occur...

rahmed 06-23-2004 10:42 AM

when u freeze in the gui, type ctrl-alt-backspace and it exits u out. check the terminal to see what the error message is.

reeprflame 06-23-2004 11:21 AM

Yes I am aware of that. That works just only when the keyboard is responsive which is usually never. IT happeneds only when i can also CTLR-ALT-F7, etc. It happens everytime I load linux

iZvi 06-23-2004 12:27 PM

Doesn't X display some error messages in the background ?

kjehed 06-25-2004 01:20 AM

Same problem but with Mandrake 10, HP compaq nx7010 laptop

I have the same problem but with Mandrake 10, HP compaq nx7010 laptop. First I thought it might be Hardware related but it seems that the load of X server spins off when the freezing happens.

Right now the IT department at my company is looking at the darn thing so I haven't been able to test a few things that I've read about.

One tip I got was to use mandrakes kernel drivers instead of the ATI ones, i.e. the DRI drivers.

- I havent tried this though.

- Kjell

uncleop 10-12-2004 10:37 AM

Unfreezes if you can ssh in
I am seeing the same problem on a newly built system. AMD 2400 Athlon XP, ASUS A7V8X, Apollo GF4 with 4MB, LiteOn CDRW drive, and system memory at 256MB of DDR RAM. Running Debian unstable and 2.6.latest-I-think kernel.

If you can ssh or telnet in to the box and kill the CPU-hogging XFree86 process (the X server) then X restarts and you "unfreeze". I can run a VNC session from another system into the box "forever"; it's just a local console freeze. Like the initial poster, the mouse seems to "work", but no mouse clicks nor any keyboard input works. The system also doesn't respond to the soft power button. But "kill -9" from your VNC session or an ssh connection works just fine...

Unfortunately I have found no way to keep the freeze from happening, and I cannot always ssh back in. The box is for my someone else who is not on my network; I found the ssh trick (and the hot process via top) when the box was on my LAN.

This is an old thread; anyone else come up with the solution?

All times are GMT -5. The time now is 12:35 PM.