-   Linux - Hardware (
-   -   hardrive and dvd drive with the same ide cable (

golgo 07-01-2009 07:02 PM

hardrive and dvd drive with the same ide cable
hello everybody i have a small question i have my harddrive and the dvd drive with the same ide cable, but the problem is that sometimes it slows down and it gets frozen, and when i open movie player it really slows down.i have the ubuntu 9.04 64 bit version and i have a phenom x4 with 2GB of ram is that normal or is because i have my hardrive with the dvd drive with the same cable??

GrapefruiTgirl 07-01-2009 07:17 PM

Having the DVD and HDD on the same cable should be fine. However, Let's say that you are watching a movie, maybe running a couple other things in the background, and you have either A) a 40-wire IDE cable, or B) no DMA enabled, then yes, you can experience slowdowns of the video itself, simply because the computer cannot get the data fast enough to display. This however should not 'slow down the entire machine' in general.

Definitely DMA should be enabled in the BIOS for your IDE devices, and also in the kernel (which it should be unless the hardware is really weird). And, you SHOULD have 80-wire cables definitely.

Can you be a little bit more specific about exactly WHAT slows down and/or gets frozen? And is it when the media player is OPENED or do you have to be playing something to cause the slowdown?


Hern_28 07-01-2009 07:21 PM

Another possibility.
Check the jumpers and ensure they are set correctly and specifically. Don't use cable select because that can get a bit weird.. even with winblows.

Would also definitely check and ensure dma is enabled as grapfruitgirl suggested.

Another possible cause would be having the correct video driver installed and set up and working properly.

Would check out these first. If it still acts up then we can dig a little deeper

jay73 07-01-2009 07:41 PM

With that kind of set-up, always make sure that hard drive is master and optical drive slave.

golgo 07-01-2009 08:11 PM

thank u for your advices and it slows down the comuter when the music starts playing when it loading the if the problem is for the cable it should be fine if i buy a sata to ide adapter????or i should check the drivers if they are the correct ones???or the bios???

ps:thank u for your support

GrapefruiTgirl 07-01-2009 08:34 PM

You're welcome!

Well, start with the cheap/free stuff first. As suggested above,

1) Check if your IDE cables are 80-wire or 40-wire (you can count them pretty easy with a fingernail)
2) Make sure the HDD is at the end of the wire and is jumped as MASTER
3) The DVD is in the middle of the wire, and is jumped as SLAVE
4) Check the BIOS - make sure DMA is enabled anywhere you see it mentioned.
5) If the drive is working, chances are very good that you have the correct driver.

6) I doubt a SATA-IDE adapter will gain you anything, but that's just my opinion; I haven't tried one, but I'd bet that the DVD drive cannot produce data fast enough to overload the IDE controller in your motherboard :twocents:

Try that stuff first; then, if performance still sucks, we can try to think of other things to consider, or if you feel it will help, you can go buy an adapter. But, if you do buy an adapter, you'll have to come back and tell us if it made any difference! :)


salasi 07-02-2009 07:22 AM


Originally Posted by golgo (Post 3593554)
...i have my harddrive and the dvd drive with the same ide cable, but the problem is that sometimes it slows that normal or is because i have my hardrive with the dvd drive with the same cable??

Well, having the hard disk and optical drive on the same cable will slow things down, but it shouldn't be by a massive amount.
  • IDE is a blocking protocol, so the use of any two drives on the same cable will cause slow downs if the two drives are used simultaneously
  • The IDE channel can only be configured to the fastest mode of the slowest device on the cable, and optical drives are often slower than hard disks. So if, for example, you had an optical drive that would only support UDMA33 but the hard disk could (theoretically) support UDMA 133, the interface would be limited to UDMA 33. I don't know, though, when the error makes itself known (is it on config, and do you get a message, or is it when the slower device is operated??)

Now, as a general rule of thumb, dropping down one UDMA mode causes a slowdown, but one which you are only likely to notice in benchmarking (rather than casual observation) so I can't exclude the possibility that something else is going on here.


buy a sata to ide adapter???
Well, it will get them off the same interface and so it will simplify the problem somewhat. I wouldn't like to guarantee that it will do much, though. I certainly wouldn't try it unless its cheap, though.

Have you tried looking at 'dmesg' for errors? What about any other perf tuning type measures? Does vmstat show up anything, like lots of swap activity? top?

onebuck 07-02-2009 08:49 AM


What's on the other ide channel?

golgo 07-02-2009 12:49 PM

i have the 80 wire, and on the bios it shows that the dvd drive is the master and the HDD is the slave and i check it with both ways and it didn't change the dvd drive was the master.i also check the DMA and they are on auto :-(...and how do i check what type of UDMA im using????...and well the sata to ide adapter its only $4 i think im going to give it a try

onebuck 07-02-2009 01:35 PM


What's on the other channel? If nothing then move the HD to ide1 as master/single.

golgo 07-02-2009 01:49 PM

mmmm what you mean by on the oder channel??? my mother board only has 1 for 1 ide cale and i try it both ways and it appears on the bios that the dvd drive is the master

onebuck 07-02-2009 02:07 PM


Some MB do have ide0 and ide1. I looked through the thread again and it does seem you have only one ide with 2 sata. What about setting the drives to alternate master/slave? It seems to me that you attempted but what about the jumpers on the drives? Were they changed to reflect the setting? What about the cable position at the time of the jumper change? When you set the master then the cable position should be at the end of the cable. The slave would then be positioned inward on the second connector. Do you have a spare ide cable to swap with?

golgo 07-02-2009 02:17 PM

hi thank your for helping me out and how do i alternate the master/slave cable???

GrapefruiTgirl 07-02-2009 02:27 PM

If I understand you correctly, you tried changing the position on the cable, of the two drives, right? ANd the BIOS still reported that the DVD was master?
If this is right, then what you need to do to switch them around, is check that the little jumpers on the back of the unit are correctly set.

There will be a little tiny block with a few sets of little metal pins in it, and usually on the housing of the unit, there is a little diagram of which pins to jump to set the unit as master or slave.

While there's no guarantee that this will help, I think it's wise to set the HDD as master, and the DVD as slave, and put the HDD at the end of the wire and the DVD in the middle. At least it will eliminate the physical setup as a factor in the problem.

Something else worth noting, is that you can use the HDPARM (utility) command to check and/or set the USING_DMA flag, and the 32BIT_IO flag, as well as maybe one or two others, that can determine/set how the drive uses DMA.
Hdparm is included with many Linux distros, but if you don't have it, you can get it easily enough and install it.


onebuck 07-02-2009 04:53 PM


Originally Posted by golgo (Post 3594629)
hi thank your for helping me out and how do i alternate the master/slave cable???

By placing the connector to mate with the proper jumper drive. If you set the cd/dvd to master then place the cable connector that is at the end of the cable on this drive. Then you would jumper your hdd as slave and place it on the inward or first connector from the MB. Alternately try drives set as master with the other as slave. But you must move the cable to mate with the proper drive configuration. Master will always be at the end of a IDE cable on the channel.

All times are GMT -5. The time now is 06:43 AM.