LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-27-2006, 04:37 PM   #1
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Rep: Reputation: 32
Harddisk not recognized after reinstallation of motherboard


Hi, I bought a new CPU and motherboard and tried to insert the motherboard into the computer. Problems occured (probably, the power supply's output ain't high enough), so I switched back to the old hardware for now. This combination of hardware had run before I had re-inserted it.

Currently, I'm using a Knoppix (thanks! ) to have a running system.

This is an Asus A7V motherboard and an IBM-DTLA-305030 harddisk.

I had a hardware specialist with me (thanks! ) when setting up the hardware, so there shouldn't be newbie mistakes in that regard.

- When booting (and in BIOS), the harddisk is detected:
Quote:
Detecting Primary Master ... IBM-DTLA-305030
Detecting Primary Slave ... None
Detecting Secondary Master ... CD-540E
Detecting Secondary Slave ... None
Occasionally (maybe because I pressed Pause to often - in order to take note of the screen messages), next, the message occured,
Quote:
Primary master drive fails
Next in the boot sequence, there are those two tables where hardware information and the PCI devices are listed. In the first of them, my harddrive is listed OK (when the aforementioned message doesn't appear).
Next, there is a message,
Quote:
Detecting
which stays there for a noticably long time.
Next, there's the message,
Quote:
Ultra100 BIOS is not installed because there are no drives attached
which seems rather queer to me - as any drives had been recognized before.
Next (when I don't boot from CD), the Ubuntu boot sequence shows up, stating,
Quote:
Mounting root file system
and hanging on
Quote:
Waiting for root file system
- Having the Knoppix system running now, I can see the contents of the harddisk that did not boot, i.e., I can see my recent changes in /etc/apt/sources.list.
Hence, that file system does exist and had been mounted.

I thought of rescuing the contents of my home folder to a second partition (and reinstalling Ubuntu thereafter). Unfortunately, Knoppix has replaced several folder with symbolic links to folders being in Knoppix' RAMDISK.

So, another question was how to access the actual folders on hda1 - but on the other hand, I'm not sure if reinstalling the operation system would really help and I also think this harddisk should be intact ...
The main question is, what's wrong with this hardware recognition? How can I make the existing Ubuntu installation recognize it?

Thanks for any ideas...
 
Old 05-27-2006, 05:28 PM   #2
dannystaple
Member
 
Registered: Apr 2006
Location: London, Uk
Distribution: Ubuntu on Desktop
Posts: 121

Rep: Reputation: 15
Hi there,

When you are mounting your drive from knoppix, what are you mounting it as? You should probably mount the drive under examination under something like /mnt/hddtofix. This would then mean that the knoppix symbolic links would not interfere at all with it. My fear now is that it may have already done so if you tried to mount your problem filesystem as a root filesystem from knoppix.

As for what is wrong with the hardware recognition, it may be a few things. If the bios itself is moaning, you really didnt want to let it try to boot into an OS. First, check that the connections between the motherboard and HDD are sound. Make sure they are well seated, remove them, make sure no pins have been pushed through (I saw this once on a Time computer) and push them back in firmly. Also, check there are no kinks, dents or breaks in the cable.
The next thing (if it is still complaining) is to check if your HDD requires a "Master Only" setting when there is no slave device, and that this jumper is set if required. This can cause issues.
Have you added other hardware beyond reinstalling the motherboard, or made upgrades to Processors, fans, graphics cards etc? You might be experiencing problems with the power supply.

You could to pop the HDD into an external case, and try mounting it read only on a completely different machine, then running fsck to see how it copes. This will at least make very sure that there are no faults on the HDD.

I have also experienced the odd duff IDE cable, and had to replace them occasionally. Of particular note are the rounded IDE cables which seem to have a higher failure rate than the normal ribbons (due to the fact that some of them are just ribbons tortured to fit into the round sleeve, and tend to be more susceptable to kinking and breaking).

I hope this helps you out, I know how frustrating it can be to not be able to get to your data any more.

Danny
 
Old 05-27-2006, 07:22 PM   #3
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Original Poster
Rep: Reputation: 32
dannystaple,
Thanks for your input!
Quote:
When you are mounting your drive from knoppix, what are you mounting it as?
I'm not sure as Knoppix does this mounting itself. I.e., I'm inputting,
Code:
knoppix@ttyp0[knoppix]$ cd /
knoppix@ttyp0[/]$ ls -l
insgesamt 46
lrwxrwxrwx    1 root     root           12 2004-01-22 22:40 bin -> /KNOPPIX/bin
lrwxrwxrwx    1 root     root           13 2004-01-22 22:40 boot -> /KNOPPIX/boot
dr-xr-xr-x    4 root     root         2048 2004-01-17 11:23 cdrom
drwxr-xr-x    3 root     root        29696 2006-05-27 19:43 dev
drwxr-xr-x  142 root     root         6144 2006-05-27 22:22 etc
lrwxrwxrwx    1 root     root           13 2006-05-27 21:42 home -> /ramdisk/home
drwxr-xr-x   21 root     root         4096 2004-01-22 22:40 KNOPPIX
lrwxrwxrwx    1 root     root           12 2004-01-22 22:40 lib -> /KNOPPIX/lib
drwxr-xr-x    9 root     root         1024 2006-05-27 19:43 mnt
drwxr-xr-x    2 root     root         1024 2006-05-27 19:43 none
lrwxrwxrwx    1 root     root           12 2004-01-22 22:40 opt -> /KNOPPIX/opt
dr-xr-xr-x   60 root     root            0 2006-05-27 21:42 proc
drwxrwxrwt    4 root     root           80 2006-05-27 21:42 ramdisk
drwxr-xr-x    2 root     root         1024 2006-05-27 21:42 root
lrwxrwxrwx    1 root     root           13 2004-01-22 22:40 sbin -> /KNOPPIX/sbin
drwxr-xr-x    2 root     root         1024 2004-01-12 23:59 sys
lrwxrwxrwx    1 root     root            8 2004-01-22 22:40 tmp -> /var/tmp
lrwxrwxrwx    1 root     root           12 2004-01-22 22:40 usr -> /KNOPPIX/usr
lrwxrwxrwx    1 root     root           12 2006-05-27 21:42 var -> /ramdisk/var
knoppix@ttyp0[/]$
(Sorry, that quote's probably a bit overwhelming.) - Actually, I did nothing but boot that Live CD, yet, and didn't mount anything manually.
Quote:
This would then mean that the knoppix symbolic links would not interfere at all with it. My fear now is...
I think my original harddisk is still intact - but just not accessible now - for any reason. - Actually, Knoppix opens the disks read-only.
Quote:
If the bios itself is moaning
In the BIOS setup - as well in the initial boot sequence messages -, the harddisk is recognized... (most of the times ...)
Quote:
First, check that the connections between the motherboard and HDD are sound
They are!
Quote:
The next thing (if it is still complaining) is to check if your HDD requires a "Master Only" setting
Where would I check that?
Quote:
Have you added other hardware beyond reinstalling the motherboard ...
No, this is exactly the hardware that's been installed when everything worked before. One thing that changed is, I'd probably changed the assignment of PCI cards to PCI slots. I'm not sure which card had been in which slot, and there had been some error messages about that. Meanwhile, I had re-arranged the cards and those messages stopped.
Quote:
You could to pop the HDD into an external case, and try mounting it ...
I'm not sure about that. Obviously, Knoppix then wouldn't replace those actual folders by symbolic links anymore. On the other hand, there must be a way to overcome the symbolic links, and to see the real file system. - Anyways, the primary issue appears to be to be able to boot into it.
Also, I'd be glad not having to buy external supplies that I wouldn't need lateron.
Quote:
I have also experienced the odd duff IDE cable
Yes, but it worked until yesterday. This could be a solution(!), though, as anything else seems to be so unlikely...
Quote:
I hope this helps you out ...
Thank you very much. This is a situation where I (as a hardware newbie) can't achieve too much without external input and help/support. I've learned much these days!
Your help is greatly appreciated.
 
Old 05-28-2006, 05:34 AM   #4
dannystaple
Member
 
Registered: Apr 2006
Location: London, Uk
Distribution: Ubuntu on Desktop
Posts: 121

Rep: Reputation: 15
Hi,

Are you sure knoppix is even mounting the drive at all? I am not even sure it would be. Those bits would be read only because they are probably decompressed from PackFS from the live CD. The symlinks are, after all, to a ramdisk.

You can try to create a directory in /mnt, and mount the drive manually. What is the output of "df -h"? And what is in the knoppix "/etc/fstab" file?

Danny
 
Old 05-28-2006, 06:39 AM   #5
KarlosDaJackel
Member
 
Registered: May 2006
Distribution: Gentoo
Posts: 54

Rep: Reputation: 15
Hi Robbert,
your hard disk is not being seen at all.

When your in knoppix type mount. It will show you all the current disks that are mounted. If you see no mention of /dev/hda then its not mounted.

Also if you type fdisk -l it will show you all detected disks and partitions.

I reckon the cable is duff, can you swap the cables for the hard disk and the cdrom? Obviously if this works the harddisk will boot but your cd drive wont work. If swapping the cables does not work change the connectors on the motherboard.

So put the hard disk cable into channel 2 and the cdrom into channel 1. This will tell you if you have a problem with the harddisk,cable or connector.

As the cdrom works on channel 2, plugging the hard disk into channel 2 with the working cable from the cdrom should allow it to work. If the hard disk does'nt work there they may be a problem with it.

karlos
 
Old 05-28-2006, 08:10 AM   #6
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Original Poster
Rep: Reputation: 32
Danny,
that's right: The harddisk hasn't been mounted at all:
Code:
knoppix@ttyp0[knoppix]$ df -h
Dateisystem          Größe Benut  Verf Ben% Eingehängt auf
/dev/root             3,0M  2,1M  905K  70% /
/dev/cdrom            686M  686M     0 100% /cdrom
/dev/cloop            1,9G  1,9G     0 100% /KNOPPIX
/ramdisk              698M  5,6M  692M   1% /ramdisk
/etc/fstab:
Code:
/proc      /proc       proc   defaults            0 0
/sys       /sys        sysfs  noauto              0 0
/dev/pts   /dev/pts    devpts mode=0622           0 0
/dev/fd0   /mnt/auto/floppy auto   user,noauto,exec,umask=000    0 0
/dev/cdrom /mnt/auto/cdrom  auto   user,noauto,exec,ro 0 0
# Added by KNOPPIX
/dev/hda1 /mnt/hda1 ext3 noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda2 /mnt/hda2 ext3 noauto,users,exec 0 0
# Added by KNOPPIX
/dev/hda3 none swap defaults 0 0
# Added by KNOPPIX
/dev/hda5 none swap defaults 0 0
KarlosDaJackel,
Code:
knoppix@ttyp0[/]$ mount
/dev/root on / type ext2 (rw)
/dev/cdrom on /cdrom type iso9660 (ro)
/dev/cloop on /KNOPPIX type iso9660 (ro)
/ramdisk on /ramdisk type tmpfs (rw,size=714204k)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0666)
automount(pid818) on /mnt/auto type autofs (rw,fd=4,pgrp=818,minproto=2,maxproto=4)
Code:
knoppix@ttyp0[dev]$ sudo fdisk -l
                                                                                                                             
Platte /dev/hde: 30.7 GByte, 30738677760 Byte
255 Köpfe, 63 Sektoren/Spuren, 3737 Zylinder
Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes
                                                                                                                             
    Gerät Boot      Start         End      Blocks   Id  System
/dev/hde1               1        2075    16667406   83  Linux
/dev/hde2            2076        3497    11422215   83  Linux
/dev/hde3            3498        3619      979965   82  Linux Swap
/dev/hde4            3620        3737      947835    5  Erweiterte
/dev/hde5            3620        3737      947803+  82  Linux Swap
I'd used the CD-ROM's cable with the harddisk but there was no difference. Also, I switched the channels: Both devices were recognized then (CD-ROM as Primary Master, HDD as Secondary Master). Nevertheless, the hardware recognition in the second stage of my BIOS still failed:
Quote:
Ultra100 BIOS is not installed because there are no drives attached
- There's something special with my motherboard and BIOS: The motherboard has two controllers (by "controller" I mean those sets of slots).
Controller 1 is labeled: "Primary IDE" and "Secondary IDE" - that's where the devices are currently plugged in.
Controller 2 is labeled: "Primary ATA100" and "Secondary ATA100" - I slightly remember there were cables in before I removed the motherboard, nevertheless, devices being plugged in there now don't get recognized at all.

There are two BIOS, too: The first one, "ASUS A7V ACPI BIOS Revision 1004C", apparently does recognize the harddisk (and anything else). Its last messages is "PCI Device Listing". Next, "Ultra100 (tm) BIOS Version 2.01" tries to get its work done: "Detecting...", and then:
Quote:
Ultra100 BIOS is not installed because there are no drives attached
BTW, the first BIOS recognizes the harddisk as UDMA4 - which appears to be related to ATA. The harddisk cable - in opposite to the CDROM cable - has more ribbons (or lines) - probably 80...

I'll try again to insert the harddisk cable there (which led to having the harddisk not being recognized at all before), and have a look at the BIOS settings then.

Thank you

Update: The harddisk does not get recognized at all when its cable is plugged into the ATA Controller. Then, it also doesn't show up in the BIOS setup dialogs.

Last edited by robbbert; 05-28-2006 at 09:55 AM.
 
Old 05-28-2006, 12:14 PM   #7
KarlosDaJackel
Member
 
Registered: May 2006
Distribution: Gentoo
Posts: 54

Rep: Reputation: 15
knoppix@ttyp0[dev]$ sudo fdisk -l

Platte /dev/hde: 30.7 GByte, 30738677760 Byte
255 Köpfe, 63 Sektoren/Spuren, 3737 Zylinder
Einheiten = Zylinder von 16065 * 512 = 8225280 Bytes

Gerät Boot Start End Blocks Id System
/dev/hde1 1 2075 16667406 83 Linux
/dev/hde2 2076 3497 11422215 83 Linux
/dev/hde3 3498 3619 979965 82 Linux Swap
/dev/hde4 3620 3737 947835 5 Erweiterte
/dev/hde5 3620 3737 947803+ 82 Linux Swap


Dude, that "hde" up there is your hard disk. Its 30Gig and has 2 linux and 2 swap partitions. Its obviously just the wrong controoler or chanell as its showing as hde instead of hda. There must be a way of setting it up in the bios. Maybe you can set that controller to load before the other one? Your so close to solving this.
 
Old 05-28-2006, 12:44 PM   #8
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
Quote:
Originally Posted by robbbert
I'd used the CD-ROM's cable with the harddisk but there was no difference. Also, I switched the channels: Both devices were recognized then (CD-ROM as Primary Master, HDD as Secondary Master). Nevertheless, the hardware recognition in the second stage of my BIOS still failed:
Never put HDD with CDrom in one line.
CHECK if you forget master/slave/cable select pin.

Update(flashed) your motherboard BIOS from the vendor website.

Is there any 'ENHANCED MODE' ATA setting in the motherboard bios?
If so set to compatible mode.
 
Old 05-28-2006, 03:29 PM   #9
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Original Poster
Rep: Reputation: 32
Quote:
showing as hde instead of hda
Good point Karlos! Now I finally know which controller *must* be right!

Anyways, the first BIOS still doesn't recognize the HDD when it's connected with "that ATA" controller, while the second BIOS does. If the HDD is connected to the other controller, it's the opposite. The Linux kernel's still "waiting for root file system" (although *I've* not waited more than a few minutes on the - possible - results; this might be a great chance! LOL ). Tried almost any combination of plugs/connectors and BIOS settings now.

BobyMC,
Quote:
Never put HDD with CDrom in one line.
I hadn't.
Quote:
CHECK if you forget master/slave/cable select pin.
The jumper at the harddisk still is - correctly - set to Master.
Quote:
Update(flashed) your motherboard BIOS from the vendor website.
That BIOS I have is a little crappy and featureless, indeed. I'll look out for some DOS boot disk in order to check an upgrade. Although I think this also should work without as it worked before...
Quote:
Is there any 'ENHANCED MODE' ATA setting in the motherboard bios?
Not exactly. There are three settings, 1. "ATA boot device" (whatever that means), 2. "Load ATA devices before SCSI devices", and 3. "Enable ATA". I've played with all that settings; the only thing having an effect (on the second BIOS) was en-/disabling ATA.

Thanks!
 
Old 05-29-2006, 12:46 AM   #10
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Original Poster
Rep: Reputation: 32
"Waiting for root filesystem" payed - et voilà - there it is...

Thanks all
 
Old 05-30-2006, 01:21 PM   #11
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
LINUX recognized that 'ATA stuff(enable/dis-enahanced/compatible)' at interrupt 169.
LINUX don't care about it.
That could be the main issue.

Correct me ? if I'm wrong.

Cheers.
 
Old 05-30-2006, 02:20 PM   #12
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Original Poster
Rep: Reputation: 32
The main issue was that I'd expected that both BIOS (1st BIOS = normal, 2nd BIOS = ATA) would need to recognize the harddisk. Actually, that ATA harddisk needs to be recognized by the second BIOS.
Quote:
LINUX recognized that 'ATA stuff(enable/dis-enahanced/compatible)' at interrupt 169.
Where would I look that up?

- BTW, I just looked at kern.log, and there are lots of messages, "hda IRQ probe failed" and "hdb IRQ probe failed". That might explain why mounting the file system still is relatively slow compared with before that hardware re-installation.
Currently, in the (first) BIOS setup, the Primary Master's set to Auto; I'll try if it helps when I set it to None.

Thanks
 
Old 05-31-2006, 03:14 PM   #13
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
Just put in NORMAL mode OR compatible(disable ATA?) mode HDD bios setting for LINUX OS.

"noboby care Interrupt 169" message came up from one of my linux OS at boot(forget what it was).

Greetz
 
Old 05-31-2006, 04:10 PM   #14
robbbert
Member
 
Registered: Oct 2005
Location: Hannover, Germany
Distribution: Let there be Ubuntu... :o)
Posts: 573

Original Poster
Rep: Reputation: 32
Thanks. To be true, I'm just happy I'm able to boot now. In my case, I've disregarded the "normal" BIOS, completely, and just made sure that ATA recognition worked (as this would make the harddisk "hde instead of hda" as Karlos noticed). I wouldn't set that as a rule, though.
 
Old 06-02-2006, 12:46 PM   #15
Bobymc
Member
 
Registered: Apr 2006
Location: INDONESIA
Distribution: SLAX,Damn S.L,Suse,Mandrake,Rd HAT62,72,73,90, Mandriva2k6, FEdora, SUNmicrosys.
Posts: 269

Rep: Reputation: 30
You're welcome.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
yet another grub reinstallation guedellas Linux - Newbie 3 02-19-2006 09:55 AM
SATA HardDisk NOT recognized in Fedora Core 3 devansh Linux - Hardware 2 06-09-2005 04:52 PM
Reinstallation! Jmcatch742 Linux - Newbie 3 10-02-2004 07:44 PM
Low Harddisk space. Can I just transfer the entire Linux to a bigger harddisk? davidas Linux - Newbie 12 04-13-2004 03:03 AM
reinstallation Nay Linux - Newbie 10 12-21-2003 09:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration