LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   Hard drive / partition alignment error... (http://www.linuxquestions.org/questions/showthread.php?t=4175436051)

buccaneere 11-07-2012 05:56 AM

Hard drive / partition alignment error...
 
I installed a new drive, and after partitioning GParted, and re-scanning, I got, "the partition is misaligned by 3072 bytes".

ext3, and NTFS formatting produced same error.

I wiped it, another GPT, and 3 more partitions. Re-scan, and same error. GParted, and 'DiskUtility' whined about the same error.

I booted W7, wiped, re-partitioned, with GPT, and same size partitions, NTFS. Windows said "I'm happy". SURPRISE!!!

THEN, I re-booted Ubuntu. Same alignment error. ???

Google says older Linux (10.04 old???) partitioning utilities are prone to alignment errors. I WOULDN'T count on that, EXCEPT that the error came up on Windows-created partitions too.

Any ideas?

cascade9 11-07-2012 06:10 AM

HDD brand/model?

If its one of the new 'advanced format' HDDs, windows XP and earlier (not that anybody should be running earlier MS OSes) will also not get the partitions aligned correctly.

buccaneere 11-07-2012 05:36 PM

2 Attachment(s)
Thanks there Mr C...

I partitioned and formatted again, in W7 (primary OS for that media-only pc), and shutdown. Today, that hard drive reports no mis-alignment. I don't know how it happened, so nothing is learned so far.

cascade9 11-08-2012 05:50 AM

You could have at least told me the brand/model......

Win7 should get partition alignment right. Old versions of Gparted wont.

masterclassic 11-08-2012 02:16 PM

Ι see it is a 4TB Hitatchi hard drive, so it uses 4KiB sectors for sure.
Gparted Live defaults to the MiB alignment since some years. win visa and win 7 align partitions to MiB, too.
Do you use Ubuntu 10.04? It is highly possible that it doesn't support properly such hard drives. I think these "advanced format" drives are in the market since 2010, so this distro version isn't up to date. Furthermore, 4TB drives are even newer, 1 year or less.

So, you could perhaps try some recent version.

buccaneere 11-08-2012 03:27 PM

Sorry there C-9; I didn't know what other info was necessary, without cluttering up the post...

Allocation unit size is 32K (NTFS). Does THAT make a difference?
---------------------------------

I presumed that when physical divisions of disk space are in MULTIPLES of the default / smaller units, then NO application could have a problem when looking at the disk, regardless of Windows or Linux environment...
------------------------------------

So irregardless:


Is there any chance that with 10.04 booted, a mis-mount / mis-read could occur, that causes boundary failure, or data loss? Everything IS backed up out of the machine (yep - I do have 34 TB of drives, FULL TOO!!! )

10.04 is used to manipulate W7, which is 'modified', and occasionally needs encouragement :wink: .

cascade9 11-10-2012 03:46 AM

Wow, diging up info on hitachi has got harder since they got bought by WD.

Eventually though I found some data- it appears to be another '4K reporting as 512b sector' drive. Annoying.

32K cluster size wont make any difference. Some basic backgorund on advanced format drives here, and in patricular this bit (and its worth checkign the link if only to see the graphics that go with this statement)-

Quote:

With the emulation of 512B sectors, there’s the risk that a partition could be misaligned compared to the 4K physical sectors - where it would be unwittingly started in the middle of such a sector. As a result, the clusters of a file system on that partition would end up straddling 4K sectors, which would cause performance problems.
http://www.anandtech.com/show/2888


All times are GMT -5. The time now is 06:37 PM.