-   Linux - Hardware (
-   -   Hard disk failure? (

GazzaJ 08-15-2006 04:04 AM

Hard disk failure?
I beleive my hard disk is corrupted in someway and was wondering if I could do something to correct this or at least access the disk to get some files of it.

Initial problems arose when the server (running Fedora 3) was rebooted and the startup stopped with at a grub command prompt. The server has just one disk with 2 partitions.

From grub I get the following information:

Partition num 0, Filesystem type is ext2fs, partition type 0x83
Partition num 1, Error 18: Selected cylinder exceeds maximum supported by BIOS

root (hd0,0)
kernel /vmlinuz
Gives Error 25: Disk read error

root (hd0,1)
Gives Filesystem type unknown, partition type 0x82

I tried linux rescue from the Fedora Cd but it was unable to find any Linix partitions. From the command prompt I get:
fsdisk -l returns nothing
fsdisk /dev/hda returns Unable to read /dev/hda

Looking at syslog there are a lot of lines such as:
<4>hda: dma_intr: status=0x51 {DriveReady SeekComplete Error}
<4>hda: dma_intr: errorr=0x40 {Uncorrectable Error}, LBAsect=71, sector=0
<4>ide: failed opcode was: unknown
<4>end_request: I/O error, dev hda, sector 0

This is repeated for other sectors.

I tried to mount the drive in Knoppix but the error was "I was unable to determine the filesystem type".

Any ideas?

cardy 08-15-2006 07:20 AM

Its a long shot but you could try and tell the kernel to not use Direct Memory Access (DMA) as you appear to be getting DMA errors to talk to the drive and see if this helps. The option for the kernel is:


You can use the above, whilst in grub select e to edit the kernel you wish to boot then append that entry to the line starting with kernel and then press enter. Now press b to boot the selected kernel.

aus9 08-15-2006 07:28 AM

and another thing is this
root (hd0,0)
kernel /vmlinuz
Gives Error 25: Disk read error

that does not look correct.

if hd0,0 is a /boot partition then its
kernel /vmlinuz (if symbolic linked) with root=/dev/hda2

othewise your /boot is a sub folder to / so its

kernel /boot/vmlinuz (or whatever) root=/dev/hda1

All times are GMT -5. The time now is 02:55 PM.