LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Grub Loading, Please Wait......Error 18 (https://www.linuxquestions.org/questions/linux-hardware-18/grub-loading-please-wait-error-18-a-343280/)

Braytac 07-14-2005 09:24 PM

Grub Loading, Please Wait......Error 18
 
Hi All
I have just finished building a new server. Intel mainboard P4 3.2GHZ running Debian 3.1. Two Ultra Wide SCSI HDD's. 36GB each.

I encounter a problem in doing the first boot after the installation.
see below:

Grub Stage 1.5

Grub Loading, Please Wait
Error 18

I've researched this GRUB error and I was able to find that the error basically means that the HDD's connected are to large for the BIOS that the machine is running. Now this mainboard is no more than a month old, however...and I think this may be the cause, I am using an Adaptec AHA-2940W SCSI Card to connect the hard drives. this model, from what i've found this card was released around the 1997 mark.

What I would like to know is is this card to old to work with Debian 3.1?
If there is a way around this problem, would running a BIOS upgrade on the card cause any further problems?
and lastly if it is possible to get working without a BIOS upgrade (As I would rather not in case I ruine the card by mistake) how can i do it?

I tried to install LILO but it failed every time for some reason. I am running a simple software mirror between the two disks.

Any help would be greatly appreciated.

thanks

sourin 07-15-2005 12:10 AM

Hi,

This happens when your controller is unable to manage the disk size attached. Check if you have any BIOS update for the controller from the vendor site. You can always backup your current BIOS before writing a new one. So do not worry about ruining your card. If something goes wrong you can always reload the old, from your backup.

A 1997 mark controller should not be a problem. Check if the control has any compatibility issues with the make of SCSI HDDs which you are using.

- Sourin

kevin_hill54 08-04-2005 08:27 AM

I had this same error on a brand new Gigabyte 7VT600 mobo with a 40 Gb HD. I had a 20 Gb working fine but tried to install a clean copy of Ubuntu onto a 40Gb hd. Had the message and figured it was a bad install so installed Slackware 10.1 had the same error. Makes no sense that I can install onto 40 Gb but can't run?

Any ideas

Kevin

Folbo 10-21-2006 10:27 AM

I am in the process of installing Ubuntu 6.06 server (Linux ... for the first time)

I am also seeing this error 18 from Grub

What I do not understand is that the computer seemed to be happy running both my 60Gb disks and a 120Gb disk when running under W2K.

I have wiped this out since I cannot seem to get dual boot to work.
I formatted a 60Gb drive at a low level (using the Maxtor Powermax utility)
and then I let the Ubuntu installer do its thing.

All seemed to go well, I was not even prompted about Grub (unlike when W2k was still on the system).

First boot ... error 18 :mad:

Is Grub nescesary when you only have a single OS? :confused:
Why is the BIOS involved under Grub but not under W2k?

Most importantly ... where next? Linux is the way I would like to go but after 20 years building and programming computers under several different OSes, I am little confused and discouraged.

Many Thanks

Martin.

kevin_hill54 10-22-2006 07:54 AM

Don't give up on Ubuntu.

I can't remember the error fix but it was a hardware issue from memory. It was a while ago and I have since upgraded to Ubuntu 6.10. Use it you'll love it.

Good luck

bigrigdriver 10-22-2006 08:12 AM

Grub error 18:
Quote:

18 : Selected cylinder exceeds maximum supported by BIOS
This error is returned when a read is attempted at a linear block
address beyond the end of the BIOS translated area. This generally
happens if your disk is larger than the BIOS can handle (512MB for
(E)IDE disks on older machines or larger than 8GB in general).
Probably means you need to edit the BIOS. Make sure the disk size settings include *LBA* instead of *NORMAL* or something else, to get past the 1024 cylinder limit. Then you shouldn't have this problem again.

dasy2k1 10-23-2006 11:03 AM

When i first instlled linux (ubuntu, and slackware) i got this problem, (allthough i have never workes with drives that big)

this fixed it for me...


when you instlall make sure you put GRUB in the MBR of the disk, not the superblock as some distors recomend...


tahtway it will overwrite anything that was there before and boot corectly...
if it is in the super block and there is still the remeins of somthing elce in the MBR (from an old distro or windows)
that will try to boot giving the error, (somtimes also error 15 can be caused by this)

my advice would be reinstall GRUB (if you can boot from a boot disk/CD)

elce
reinstll your distro

(to instll slackware you need to use LILO and tell it to install on the MBR)

Folbo 10-25-2006 05:05 AM

Thanks for the encouragement ....but I just cannot seem to get things moving :mad:

With a complete re-install of Ubunutu 6.06, overwriting the MBR, I am still faced with the rather cryptic Grub loading stage 1.5 ... Error 18

This occurs without fail no matter which physical drive I put Ubuntu on to, seemingly no matter how the drives are partitioned, and with a low level format between each attempt so as to remove any legacy issues from a prior install.

What is the smallest partition that I can usefully install unbuntu on? My last attempt will be to create this smallest partition at the start of the drive, and use this.



I still cannot get my head around why NT can see the drives, and boot from the drives successfully, yet Grub cannot. It is the same BIOS, set to LBA .... Windows works but Linux does not :confused:

Is there another boot method other than Grub / Lilo that works in a different way (other than NTloader!)?

I have seen a post elsewhere which basically suggest installing Grub onto a small partition, and copying whatever is installed there into Windows, and using the Nt boot loader instead. This seems a worth while approach but I cannot seem to find a way of installing Ubuntu/Grub and then booting to a Linux image. The problem seems to relate to not having permissions to copy the data to a floppy. I presume that I would have to be logged on as an administrator (as root), but I do not know how to do this. I have a copy of Knoppix that allows a CD based Linux to be run but that is as far as I can get.
Any help would be thankfully received.

Martin.

Xel'naga666 10-26-2006 05:30 AM

This sorted me out with a fresh kubuntu install
 
Quote - Colin Watson's post from this site
https://launchpad.net/distros/ubuntu...ller/+bug/9006

I ran the Warty Warthog installer on an older computer, a Super 7 motherboard
with a K6-III processor. I believe the BIOS was the problem. The hard disk is
a 20 GB disk, and the BIOS pre-dates disks that large.

The installation ran to completion, and then the system would not boot. GRUB
returned the terse message "Error 18".

I Googled for "GRUB Error 18" and what I found suggested that it was a problem
with the BIOS accessing deeply into the hard disk. I re-ran the installer, and
this time manually partitioned the hard disk, with the very first partition a
small "/boot" partition for GRUB and the kernel.

The installation ran to completion and the system booted up just fine. (By the
way, a K6-III/450 with 384MB of RAM makes a pretty nice Ubuntu system.)

Possible solutions:

* make the standard disk configuration have a /boot partition

* detect an old BIOS, and if detected create a /boot

* don't change the installer, but put documentation in the README (not ideal,
but the least amount of work)


===========================================
I took this on board and created the following partitions on my compaq armada lappy e500 from the Kubuntu 6.06.1 install.

#hda1 /boot 100MB b
#hda2 / 8GB
#hda3 300MB swap
#hda5 /data 21GB

Grub boots the kernal from the boot partition and fires up the "hda2" files without problems. I even wnet to the chore of installing a new bios to fix the issue but it didnt help.

Hopefully this solves some of everyones problems. It saved me twice!!

Sadly this'll mean you'll have to run the install again but it *should* work. And im doing the same thing on another lappy right now.....

Xel'naga666 10-26-2006 05:34 AM

Quote:

Originally Posted by Folbo
Is there another boot method other than Grub / Lilo that works in a different way (other than NTloader!)?

Please jesus don't use the ntloader, there are a few other fairly good boot loaders out there but they all fail in comparison to GRUB and Lilo.

The best alternative I can think of out of the top of my head is "gag" which is a graphical boot loader. I found it once on the systemrescuecd live distro.

---Sorry to double post mods :rolleyes:

Folbo 10-28-2006 07:09 AM

Thanks for the suggestions ... will try again

I must admit that if were not for you guys Linux would be back in the bin again until it can do the things the ntloader could do many years ago.

Xel'naga666: On your list of partitions, what happened to hda4?

Xel'naga666 10-28-2006 02:57 PM

Folbo: Yep ure right....I am missing a partition in there. And to be honest I have no idea how it happened. Thats how cfdisk wrote to my disk at the time. But it all works. So hopefully nothing is wrong with it. I noticed this on a installation on my friends SuSe lappy too. Not sure what causes it. Is it really a big issue?? If so, do you know of a way to change hda5 into hda4 without wiping the data??

Also, hda5 is a fat32 partition because at the time I was writing back and forth from winXP and Linux (not now, lol) and I havent been able to change it into a ext3 filesystem yet?? Did having a fat32 part. cause this problem??

dasy2k1 10-30-2006 03:46 AM

Quote:

Originally Posted by Folbo
Thanks for the suggestions ... will try again

I must admit that if were not for you guys Linux would be back in the bin again until it can do the things the ntloader could do many years ago.

Xel'naga666: On your list of partitions, what happened to hda4?

From my experiance Hda4 woudl be teh start of teh logical partitioning after primary partitioning,
Hda4 will be a physical primary partition containing the logical partitions Hda5 as it isnt really a partition in its own right it dousent show as existing,
if you view the disk with cfdisk it shoudl show you it as tehre with the tag Logical

wicke 08-13-2007 11:45 PM

GRUB 1.5 problem
 
I installed Ubuntu 6.10 on my computer, and got the Error 18 message.
The PC I installed it onto:
Intel NX440LX Mobo
Pentium II 266MHz
256MB PC13 SDRAM
20GB IDE master with XP Pro
60GB IDE slave with multiple partitions (music, Ubuntu, etc.)

I set a 10GB partition on the 60GB for Ubuntu. It installed fine, but after rebooting, I got that darned error message. Any help would be appreciated, especially quick responses! I've got a lot of important work on the XP drive.

digideus 09-09-2007 11:59 AM

I'm also having the GRUB error 18 problem, but ive noticed that some distributions dont have the issue whereas some do. I managed to get around it by re-selecting LBA in the bios when using Ubuntu 7, but I cant for the life of me get it working with Mepis Linux, so I guess I'm going to stick with Ubuntu.

Is this possibly because of the partitioning tool bundled with the distro? Mepis 2004 has Qparted, whereas Ubuntu's one is a part of the installation process.

On a side note, this is my first SERIOUS attempt at Linux, but I do have 20+ years of experience in computers and supporting them in huge network environments, so this should be a doddle, right? hehe


All times are GMT -5. The time now is 01:52 PM.