-   Linux - Hardware (
-   -   Graphics Fedora Core 5 845G HP COMPAQ D530 and D510 (

lustyd 08-07-2006 10:54 AM

Graphics Fedora Core 5 845G HP COMPAQ D530 and D510
Hi all, I recently was given an HP D530 Ultraslim and a Compaq D510 SFF and am trying to install Fedora Core 5 on them both, one for a general purpose computer and one as a server. The graphical installer doesn't work on either so I did a text install (I'm not entirely a newbie but I prefer not to compile things if I can avoit it)

The problem I'm having is the graphics. using the i810 driver LSPCI says:
00:02.0 VGA compatible controller: Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset integrated graphics Device (rev 01)

(If you need other lines let me know...I have to type them manually unfortunately!!)

Error on 800x600@16 is screens found, no usable configuration

I have looked on many sites about this problem but all the solutions require updating the BIOS and setting the video memory higher. I have tried the factory BIOS and latest BIOS with the same result and there is no option to set the graphics RAM.

Changing the video card os not an option on either machine (and neither should it have to be!)

Any help would be most appreciated, these are about as standard as a desktop gets as pretty much every business I've been to in the UK uses these or the Dell equivelant so I find it hard to believe that they are unsupported on Linux.


J.W. 08-07-2006 09:52 PM

Welcome to LQ. The problem is probably with your xorg.conf settings. Without boring you with details, have you tried booting this PC with a Live CD (such as Knoppix)? If it works under Knoppix, it should work under FC5. and the basic issue you're facing boils down to a configuration issue

lustyd 08-08-2006 04:18 AM

Yes I did try that, but knoppix seems to use xfree rather than xorg, and employs several tricks to ensure that a graphical display comes up, making the config file very complex.

Should I submit this as a bug to the fedora project? As I said these are very common desktop computers!


All times are GMT -5. The time now is 08:07 AM.