-   Linux - Hardware (
-   -   Graphics Card problems with opengl (

pafinator11 08-13-2005 02:18 PM

Graphics Card problems with opengl
I installed fedora core 4 x86_64 yesterday. At the time of install I was using a Geforrce 440MX graphics card. Immediately after the install I downloaded the Nvidia drivers from nvidia and installed them. When I went to screensavers none of the opengl screensavers would work. Not even in the preview box. At the time I was just using that ard because it was one I had laying around and I was waiting for an order. So today I got the order which was a geforce 6600 and I went to the screensavers and they still didnt work (obviously) and so then I figured they just weren't installed and the I installed Point2Play and at the setup wizard during the test opengl direct rendering failed and it did not move on to the other tests. I checked out the details and they said

Your OpenGL drivers do not appear to be setup correctly. Please check the documentation for your Linux distribution and your graphics card drivers to ensure proper installation.
So I really dont know what I should do at this point. In Fedora 3 32 bit with the 440 opengl worked fine but i never installed the nvidia drivers so 3D failed. I think this is an issue with xserver not being setup correctly. Anyone have any ideas? I will post any more information if it helps.

jpcaza 08-13-2005 02:35 PM

Did you do this?

Chapter 3. Configuring X for the NVIDIA Driver

The X configuration file provides a means to configure the X server. This
section describes the settings necessary to enable the NVIDIA driver. A
comprehensive list of parameters is provided in Appendix D.

In April 2004 the Foundation released an X server based on the XFree86
server. While many Linux distributions will use the X server in the
future, rather than XFree86, the differences between the two should have no
impact on NVIDIA Linux users with two exceptions:

The configuration file is '/etc/X11/xorg.conf' while the XFree86
configuration file is '/etc/X11/XF86Config'. The files use the same
syntax. This document refers to both files as "the X config file".

The log file is '/var/log/Xorg.#.log' while the XFree86 log file
is '/var/log/XFree86.#.log' (where '#' is the server number -- usually
0). The format of the log files is nearly identical. This document
refers to both files as "the X log file".

In order for any changes to be read into the X server, you must edit the file
used by the server. While it is not unreasonable to simply edit both files, it
is easy to determine the correct file by searching for the line

(==) Using config file:

in the X log file. This line indicates the name of the X config file in use.

If you do not have a working X config file, there are a few different ways to
obtain one. A sample config file is included both with the XFree86
distribution and with the NVIDIA driver package (at
'/usr/share/doc/NVIDIA_GLX-1.0/'). Tools for generating a config file (such as
'xf86config') are included in many distributions. Additional information on
the X config syntax can be found in the XF86Config manual page (`man
XF86Config` or `man xorg.conf`).

If you have a working X config file for a different driver (such as the "nv"
or "vesa" driver), then simply edit the file as follows.

Remove the line:

Driver "nv"
(or Driver "vesa")
(or Driver "fbdev")

and replace it with the line:

Driver "nvidia"

Remove the following lines:

Load "dri"
Load "GLCore"

In the "Module" section of the file, add the line (if it does not already

Load "glx"

There are numerous options that may be added to the X config file to tune the
NVIDIA X driver. Please see Appendix D for a complete list of these options.

Once you have completed these edits to the X config file, you may restart X
and begin using the accelerated OpenGL libraries. After restarting X, any
OpenGL application should automatically use the new NVIDIA libraries. If you
encounter any problems, please see Chapter 5 for common problem diagnoses.

pafinator11 08-13-2005 03:09 PM

Thank you very much. I did that and rebooted. It worked instantly. Thanks again!

All times are GMT -5. The time now is 02:41 PM.