LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 06-15-2014, 07:19 AM   #1
PasBern
Member
 
Registered: Dec 2009
Location: Rotterdam, Netherlands
Distribution: Fedora 28
Posts: 82

Rep: Reputation: 1
GNOME cannot find any sound device anymore


For some reason GNOME doesn't detect any audio device anymore, meaning that all applications fail to give me sound (VLC, Totem, Rhythmbox). This happened without any upgrade.


There seems to be a kernel driver in use:

Code:
# lspci -nnk
00:1b.0 Audio device [0403]: Intel Corporation Lynx Point-LP HD Audio Controller [8086:9c20] (rev 04)
        Subsystem: Acer Incorporated [ALI] Device [1025:079b]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel
Testing sound via KDE system settings is successful (HDA Intel PCH ALC282 Analog), but some audio devices (HDA ULI M5461 ALC882) are grayed out.

Any idea how I can get this fixed?
 
Old 06-15-2014, 07:38 AM   #2
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Hi PasBern, So I'm understanding that sound did work in Gnome at some point? Have you installed any additional packages since then? To be thorough, have you checked your mixer settings to be sure volumes are raised and sound is not muted? What kernel and alsa version are using?

Good luck. ;-)
 
Old 06-15-2014, 08:29 AM   #3
PasBern
Member
 
Registered: Dec 2009
Location: Rotterdam, Netherlands
Distribution: Fedora 28
Posts: 82

Original Poster
Rep: Reputation: 1
That is the weird thing, sound stopped working for GNOME all of a sudden. Testing sound in the GNOME desktop environment using KDE system settings works too. The mixer settings cannot detect any sound device.

Here is what aplay tells me:

Code:
# aplay -l
**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: HDMI [HDA Intel HDMI], Gerät 3: HDMI 0 [HDMI 0]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 7: HDMI 1 [HDMI 1]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 0: HDMI [HDA Intel HDMI], Gerät 8: HDMI 2 [HDMI 2]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: PCH [HDA Intel PCH], Gerät 0: ALC282 Analog [ALC282 Analog]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
It seems to me that this has something to do with GNOME, I did not in the meantime install any new packages or perform an upgrade.
 
Old 06-15-2014, 09:49 AM   #4
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,556
Blog Entries: 1

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
Perhaps you have multiple sound devices and the one you want to use did not get assigned card 0 this boot. That happens on my system. Because I'm too lazy to do the /etc/modprobe.d/alsa_custom.conf thing to index my drivers. But I can cope with a minimal .asoundrc file.

$ cat /proc/asound/cards

$ nano .asoundrc
Code:
defaults.ctl.card 1
defaults.pcm.card 1
defaults.pcm.device 0
Where 1 would be 0 if your desired card got asigned 0 this boot. If you use pulseaudio you can use pavucontrol to select which card to use. Although you'll probably need a .asoundrc that points at pulse. The global one probably does if you didn't do a custom one.

Last edited by Shadow_7; 06-15-2014 at 09:52 AM.
 
Old 06-15-2014, 03:18 PM   #5
PasBern
Member
 
Registered: Dec 2009
Location: Rotterdam, Netherlands
Distribution: Fedora 28
Posts: 82

Original Poster
Rep: Reputation: 1
Something not quite understable must have happened (Sound is still not working). Other users have sound (I created a test user for that purpose) and it is not restricted to the GNOME desktop environement. As my user I do not have sound, in KDE I am informed that the default audio device cannot be accessed, I believe it assumes the HMDI jack to be the default device. Which doesn't make sense as I use earphones and no cable is plugged in. Again, this a user-specific problem. There is NO .asoundrc-file in nobody's HOME-directory. I grepped all files for the keywords "audio" and "default" in my directory, no sensible findings came up.

These observations lead me to conclude that neither tinkering around with a manually created .asoundrc-file nor trying to fix the issue system-wide some way via ALSA settings gets to the core of the problem. Something has turned bad in my HOME-directory for whatever reason. So I guess doing the hard slog, moving all files and directory under /HOME away the copying them back one by will have to do. Linux can be so straightforward (excuse my cynicism, but too many bad things have happened under Linux)!
 
Old 06-15-2014, 03:36 PM   #6
Peacedog
LQ Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,296

Rep: Reputation: 168Reputation: 168
Is the user a member of the audio group?

Good luck. ;-)
 
Old 06-15-2014, 04:25 PM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 3,556
Blog Entries: 1

Rep: Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776Reputation: 776
The user should be in the audio group or it doesn't have permissions to use the audio device. And for pulseaudio it should also be in the pulse group. Although many of the more popular distros are very good at hiding such administrative needs from most users. As long as you stick with all the defaults.

$ groups <user>

or just groups if you are that user. Just think of all this as the AUTOEXEC.BAT and CONFIG.SYS version of stuff for linux. The main advantage is that linux generally does not relocate admin tools and rename them with every release and/or update. Although varying distros use different toolsets.

If you're using more than one user and using pulseaudio, you may need to stop pulseaudio and start it again between users to pass the permissions ball between users. Which implies "autospawn = no" in the client.conf so it doesn't auto-restart. So many "ways" to configure audio in linux depending on your use case.
 
Old 06-15-2014, 04:40 PM   #8
PasBern
Member
 
Registered: Dec 2009
Location: Rotterdam, Netherlands
Distribution: Fedora 28
Posts: 82

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by Peacedog View Post
Is the user a member of the audio group?

Good luck. ;-)

Yes, I am member of the audio group, as I said, sound stopped working all of a sudden, actually while playing a video file.

So now I moved all configuration-folders out of the way and copied them back, one by one. Each logging in again, to see wheter sound still worked. Clearing my HOME-directory of configuration files fixed the issue. Well, eventually I copied back all file, and sound still kept working. So much for logic!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
find sound device knobby67 Programming 2 02-01-2010 06:03 AM
Umount /dev/sdb for ejecting IPOD. Debian couldnt find the device anymore auroches Linux - Newbie 1 07-24-2009 12:00 AM
cant find any sound device (ac'97) poodle Linux - Hardware 8 08-05-2006 05:12 AM
can't find sound device WanglessOlasov Linux - Hardware 21 12-11-2005 10:56 AM
gnome primary sound device astrowill Linux - Hardware 0 12-27-2004 06:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration