-   Linux - Hardware (
-   -   GMA X3100 Glx/Direct Rendering under intel driver (

conartist6 08-30-2010 10:04 PM

GMA X3100 Glx/Direct Rendering under intel driver
Afaik this card should be capable of direct rendering, correct? The card's spec indicates that it supports OpenGL1.5 (wimpy next to its DX10 and Shader Model 4.0 specs...). Currently glxinfo says that direct rendering is not on, and that the Mesa driver is being used. xorg.conf

Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "glx"
        Load  "dri"
        Load  "dri2"
End Section


Section "Device"
        Identifier  "Card0"
        Driver      "intel"
        VendorName  "Intel"
        BoardName  "965G"
        BusID      "PCI:0:2:0"
End Section

Everything works perfectly except that apps that try to make direct rendering calls (blender is the only one I care about, and it works fine in softwaregl mode, but I need hardware support for it and I care about setting this right) Is anything wrong here? Why can't I get direct rendering enabled?


conartist6 08-30-2010 10:11 PM

Sigh. Seems xorg is linking to the wrong libGL.

conartist6 08-30-2010 10:22 PM

"If it isn't [showing LIBGL_DEBUG=verbose info], you have replaced your X.Org-provided libGL with some other libGL, or it's finding an old libGL from somewhere. Run ldd /usr/X11R6/bin/glxinfo and see which libGL it's finding. Make sure it's the one in /usr/X11R6/lib/libGL, or a link in /usr/lib to the one in /usr/X11R6/lib. You shouldn't have any libMesaGL* on your system.

I tried setting the LIBGL_DRIVERS_PATH environment variable to /usr/X11R6/lib/modules/dri before loading X, but I still get no debug info. I double checked to make sure the var was actually set, and it was, but ldd still reports that glxinfo is finding /usr/lib64/, which is a symlink to, which would be an nVidia library, which explains why dri is borked. Now the only question is: how do I fix it?

conartist6 08-30-2010 10:54 PM

Ok, fixed that with a symlink. Not the most elegant, but it works. Still no joy tho. That driver is now correctly /usr/X11R6/lib64/, however it is looking for the proper dri module in the incorrect location! /usr/X11R6/lib/dri/ instead of the lib64 variant of that path. I guess another symlink is in order but gosh darn it can anybody tell me how to set all these things correctly so that I'm not hacking things together? Hacking things together doesn't seem to be as bad an idea in Slack as it is in more managed os's, but I still don't like it. Kthx.

All times are GMT -5. The time now is 10:37 PM.