LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-21-2004, 04:23 PM   #16
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled

Before you overwrite xorg, make a copy of it.

What chipset is your motherboard? If your chipset is a VIA and you set AGP to 4X, you are going to have some problems unless you set something. In your module conf file make sure you have:

alias /dev/nvidia* nvidia
options nvidia NVreg_EnableAGPSBA=0 NVreg_EnableAGPFW=0

Turning off NVreg_EnableAGPSBA and NVreg_EnableAGPFW increases stability and reliablity. You can add other options too. If you have a VIA chipset, add NVreg_EnableVia4x=1 on the same line. You may want to add Option "NvAgp" "0" in the Device section of your xorg file. You can change from 0 to 3. Trial and error until it works.
 
Old 07-21-2004, 07:06 PM   #17
virii
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
i'll try that, but my mobo has a 8x/4x slot, not just 4x. it's a Soyo KT6000 Dragon Plus
 
Old 07-21-2004, 07:23 PM   #18
virii
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
tried it, same thing happens. the weird thing is that after changing to nvidia in the xorg config, all of linux freezes, not just X. maybe this will help with figuring out the problem.
 
Old 07-22-2004, 04:41 PM   #19
virii
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
anything?
 
Old 07-23-2004, 07:01 PM   #20
virii
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
any more suggestions? i'm stuck here
 
Old 07-26-2004, 02:15 PM   #21
virii
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
would it help if i updated my kernel?
 
Old 07-26-2004, 08:13 PM   #22
virii
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
after looking back at some of the comments, i fixed it, thank you guys
 
Old 07-26-2004, 08:49 PM   #23
ovf
Member
 
Registered: Jul 2003
Location: Massachusetts
Distribution: LFS 4.0, Windows XP, Ubuntu 10.01, Gentoo 2.6.32-r7, OpenSolaris
Posts: 100

Rep: Reputation: 15
How did you fix it?
 
Old 07-26-2004, 09:35 PM   #24
virii
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware 10
Posts: 26

Original Poster
Rep: Reputation: 15
exactly how electro said. followed his directions exactly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GLX problem batev Slackware 54 12-13-2005 11:50 AM
Problem with glx juniox Linux - General 3 09-24-2005 05:25 PM
GLX Problem nykey Linux - Newbie 10 12-05-2003 01:45 PM
(II) [GLX]: Initializing GLX extension - X wont go hydro Linux - Software 3 02-20-2003 06:12 PM
Problem with NV-GLX BraveFencer Linux - Software 2 08-05-2002 08:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 07:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration