Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 01-24-2020, 07:52 AM   #1
LQ Newbie
Registered: Jan 2020
Posts: 10

Rep: Reputation: Disabled
Getting the audio jack to work on a Intel NUC 10i7FNH

A bit of reading on the net helped me to do some troubleshooting, and I can confirm that the hardware works: the command "cat /dev/urandom | aplay -D hw:0,0 -f S16_LE -c 2" creates a sound on the audio jack.

Question is: How do I translate this knowledge info a configuration file so that I can play music through the audio jack?
Seems to me I need to make the OS (or some part of it) aware that this hardware exists and what its capability is.

Any help or pointers to documentation is greatly appreciated!

Old 01-24-2020, 08:05 AM   #2
Senior Member
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 & 7
Posts: 3,411

Rep: Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916
What' happens if you just start a music player app like VLC or RhythmBox? Is it not working?
Old 01-24-2020, 12:06 PM   #3
LQ Newbie
Registered: Jan 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
No sound comes through the audio jack.
The alsamixer does not show an option for an analog output.
All output devices listed in VLC do not send any sound to the audio jack.
It is not muted - i checked.

It feels to me that the hardware was not detected properly during the installation of the OS, but the aplay command seems to suggest that the hardware is functional.
Old 01-24-2020, 03:27 PM   #4
Senior Member
Registered: Feb 2011
Location: Massachusetts, USA
Distribution: CentOS 6 & 7
Posts: 3,411

Rep: Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916Reputation: 916
If aplay -l lists your sound card, then it has probably been muted by one of the many overlapping sound controls in Linux (I blame Poettering). In that case try this page:
Old 01-24-2020, 03:29 PM   #5
Senior Member
Registered: Sep 2017
Distribution: Slackware
Posts: 1,990

Rep: Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880Reputation: 880
Are there multiple devices listed in alsamixer? Normally there is a way to change the audio device but I can't recall what it is at the moment.
Old 01-25-2020, 06:14 AM   #6
LQ Newbie
Registered: Jan 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks smallpond for the pointer to the troubleshooting description.
I think it got me one step closer but noy yet accross the finish line.

The command "speaker-test -c2 -t wav" plays "left speaker" and "right speaker" alternately on the headphones connected to the audio jack. However nothing else pays sound through the jack - VLC, Clementine, etc.

A look at settings under "pavucontrol" indicates that "analog stereo ouput (unavailable)".

Amixer shows:
amixer -c0 cget numid=10
numid=10,iface=CARD,name='Headphone Jack'
; type=BOOLEAN,access=r-------,values=1
: values=off
amixer -c0 cget numid=11
numid=11,iface=PCM,name='Playback Channel Map'
; type=INTEGER,access=r----R--,values=2,min=0,max=36,step=0
: values=0,0
| container
| chmap-fixed=FL,FR

When I try to change the values of these controls (both as user and as root) I get "amixer: Control hw:0 element write error: Operation not permitted"

My interpretation of the above:
1) aplay and speaker-test access the hardware directly, and it works.
2) Pulse Audio and/or Alsa get information from somewhere that set the analog stereo jack to OFF, and that's why programs like VLC etc can play through the audio jack.

How do I convince Pulse Audio and/or Alsa to set the controls to ON?
Is it a driver issue?

lshw shows:
description: Audio device
product: Intel Corporation
vendor: Intel Corporation
physical id: 1f.3
bus info: pci@0000:00:1f.3
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=snd_hda_intel latency=32
resources: iomemory:600-5ff iomemory:600-5ff irq:163 memory:6023110000-6023113fff
lspci shows:
00:1f.3 Audio device: Intel Corporation Device 02c8

Hope someone can point at the next step!
Thanks in advance
Old 02-19-2020, 10:27 PM   #7
LQ Newbie
Registered: Feb 2020
Location: Atlanta, GA
Distribution: Red Hat and Debian flavors
Posts: 2

Rep: Reputation: Disabled
Lightbulb Troubleshooting and next steps

Aha, just happened to pick one up the other day for unrelated use and happened to see the question. At first I believed it was because your system was using HDMI audio, which happens to be the case here except mine allows software volume control (the setting is not locked out). Then I ran the `speaker-test` and was surprised that, while yours played over the headphone port, mine played over the HDMI out.

I was checking a few more things and ran the speaker-test as root and no sound. Voila! It was playing through the front panel audio jack as my environment variables no longer contained my Gnome session information.

First assumption is the sound device permissions might not have been set to root:audio with mode 660. It appears the permissions are set appropriately so that's not the issue. So I started poking around to see what ALSA was detecting:

root@nuc10i:~# cat /proc/asound/card0/codec* | grep Codec
Codec: Realtek ALC256
Codec: Intel Kabylake HDMI
Given that I'm not much of an audio guy, I couldn't make too much heads or tails of the information but have this suspicion. The device is there, it's working, but ALSA has no clue how to find the device or detect headphones being connected or disconnected via one of the detect pins provided by the device. I saw some similarities to what you described here:

Using `alsamixer` I was able to set the front audio panel volume by raising/lowering the PCM channel (no headphone channel present). `hdajacksensetest` returned the same results posted to that the bug. This may be a "bug" similar to others using the same driver when hardware manufacturers use different pin signaling than the reference spec:

You have two options, depending on your budget and need for a fix:
  1. Follow the instructions at to submit a bug.
  2. If your budget permits, pick up a USB sound card. The Logitech Pro X headset comes with one that works with Linux and ALSA, you may even be able to get one from a friend who isn't using one (probably has a drawer full of them from old headsets) for FREE.

At least you can rest assured your hardware is working and it's not a dead audio port. While it's not the ideal situation, the developers are donating their time to the ALSA project, often after their busy jobs and often without pay or other monetary compensation. I hope this information helps and please, don't let that comment dissuade you from sending them a bug report, the developers often want to be as helpful as they can and are more than happy to help if you are patient and willing to help them with the information they need for a fix.
1 members found this post helpful.
Old 02-28-2020, 01:22 AM   #8
LQ Newbie
Registered: Jan 2020
Posts: 10

Original Poster
Rep: Reputation: Disabled
Thanks bbeaudoin!
This was solved by setting environmental variables, which I did not know existed!



audio, nuc

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Intel Nuc - No HDMI Audio available Tadaen Linux - Newbie 3 02-11-2017 09:49 AM
[SOLVED] Slackware 14.2 + Intel NUC + HDMI = slow video/audio TL_CLD Slackware 13 12-15-2016 02:55 AM
HDMI audio on Intel NUC DN2820FYK louigi600 Slackware 22 03-16-2015 06:17 PM
LXer: The Remarkable Intel NUC LXer Syndicated Linux News 0 01-16-2014 03:30 PM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 09:54 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration