-   Linux - Hardware (
-   -   Getting HP 6840 to print with Fedora 8? (

tomva 06-08-2008 03:31 PM

Getting HP 6840 to print with Fedora 8?
Hello all-

I recently installed Fedora 8. Very nice distro!

However, I have been unable to get my printer working (HP Deskjet 6840). It was working before with F7, but I forgot to remember the settings.

Based on a number of searches, it appeared that I should use the HP JetDirect drivers, and specify the printer location using socket://hostname:port. However, the printer isn't responding to any print requests. So I suspect a different configuration is required, but I'm not sure what that is.

Here is what I attempted:
- Connected to local cups at http://localhost:631
- Clicked "Add Printer"
- Selected AppSocket/HP JetDirect driver
- Specified "socket://hp6840:9100" as the URI

(hp6840 is the local hostname for the printer and ping hp6840 works fine).

If I try printing to the printer (test page, or a page from another app), the print job just hangs in processing.

Is there another configuration I should be using for this printer?



farslayer 06-08-2008 09:02 PM

So do you have a host or DNS entry for hp6840 so that cups will be able to resolve that name to an IP address ?

did you try socket://ip.addy.of.printer:9100 as the URI ?

tomva 06-09-2008 09:43 AM

Thanks for the reply! The openprinting link is handy, although it also does not describe the details of configuring the printer under CUPS, which I think is where things are breaking down.

I do have a DNS entry for hp6840:


tomva@localhost$ ping hp6840
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=255 time=2.764 ms
64 bytes from icmp_seq=1 ttl=255 time=2.592 ms

I tried using the raw IP address as well, but that resulted in the same behavior (printer not printing anything).

What device should I use when setting up the printer in CUPS? I go to http://localhost:631/, and click "Add Printer". It asks for a Device, and I choose "AppSocket/HP JetDirect". Is that the right device?

I had been using these settings


Device: AppSocket/HP JetDirect
Device URI: socket://hp6840:9100  (also tried socket://

Just now, I tried setting up the printer by using


Device: HP Printer (HPLIP)
Device URI: socket://hp6840:9100

However, that also failed. I suspect I am doing something wrong when configuring the printer under CUPS.

farslayer 06-09-2008 03:50 PM

well Jetdirect Print servers should actually be able to accept jobs via: JetDirect, LPR, or IPP printing if I'm not mistaken.. so you could try configuring it with one of the other methods.. I typically just configure my Printers for LPR or IPP printing.

I was looking for a nice "CUPS Jetdirect how-to" and wasn't finding any, They all just said to use App/Socket with the URI in the format you were already doing..

tomva 06-16-2008 11:42 PM

Sigh... I found my problem! Of course, I remembered that the hp6840 (like most printers that can print over the network) has its own http server. So I visited my local http://hp6840/, and saw that the printer claimed the cover was open!

The printer has apparently gotten flaky lately (weather?) and believes the cover is open when it isn't. So long as I press down on the cover, it will happily print.

At least I know I didn't misconfigure it. Fedora 8 was happy, but my printer wasn't.

farslayer 06-17-2008 07:21 AM

Thanks for reporting back :)

All times are GMT -5. The time now is 09:05 PM.