LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Geforce4 MX 440 not detected under Mandrake 9.2 (https://www.linuxquestions.org/questions/linux-hardware-18/geforce4-mx-440-not-detected-under-mandrake-9-2-a-141822/)

brisemec 02-03-2004 11:55 AM

Geforce4 MX 440 not detected under Mandrake 9.2
 
Hi. I've recently installed Mandrake 9.2. Everything went fine except that in the X configuration tool (XFdrake), my AGP graphics card is not detected. I have 2 aditional PCI cards that are correctly detected.

I successfully installed the latest NVIDIA drivers and it works fine with the PCI cards but I can't make X use my AGP card too.

I'm using Xfree86 4.something (the one that comes with Mandrake 9.2).
I tried removing the PCI cards but it doesn't help.
I tried manually adding a Device section to my XF86Config-4, setting the BusId property to "PCI:1:0:0" (the value reported by lspci) but it just hanged my PC.

Here are the relevant specs from my PC:

Processor: AMD Athlon XP 2000+
Motherboard: ECS K7VTA3 v.5 (KT333)
Graphics cards:

1. NVIDIA Geforce4 MX 440 AGP 4X 64Mb
2. NVIDIA Riva TNT 2 PCI 32 Mb
3. NVIDIA Riva TNT 2 Vanta PCI 32 Mb

tigerflag 02-03-2004 08:17 PM

Hi.

I use that card, and Mandrake has always detected it. I want to get clear on this- do you have all three cards installed at the same time? You should only have one.

Have you removed the extra PCI cards and rebooted to see if your hardware detection sees the AGP card? There's probably a good way to do this w/out rebooting, but I'm in kind of a rush right now.

Post more so we can help you.

Aussie 02-04-2004 05:21 AM

Go into your BIOS and set the "Initial display device" to AGP.

brisemec 02-04-2004 06:17 AM

I've already tried both things: removed the extra PCI cards and my BIOS settings are correct (init AGP first). But it still doesn't work :(

Btw, it's not a Mandrake-specific problem. I get the same problem with Red Hat and Slackware.

Aussie 02-04-2004 02:44 PM

Does the card work in other operating systems?

brisemec 02-05-2004 06:29 AM

Yes, under Windows XP it's working fine.

Aussie 02-05-2004 06:42 AM

Ok, take out the pci cards and boot into linux, log in as root and do "lspci -vv", post the output here.

snocked 02-05-2004 07:56 AM

mine was detected by 9.2 too

brisemec 02-06-2004 06:25 AM

I'm not allowed to post files here so here is the relevant (i think) output from "lspci -vv":
Code:

01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0171 (rev a3) (prog-if 00 [VGA])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
        Latency: 32 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at e8000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Region 2: Memory at e0000000 (32-bit, prefetchable) [size=512K]
        Expansion ROM at <unassigned> [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [44] AGP version 2.0
                Status: RQ=31 SBA- 64bit- FW+ Rate=x1,x2
                Command: RQ=0 SBA- AGP- 64bit- FW- Rate=<none>

Here is the full output: http://7mares.terravista.pt/brisemec/lspci.txt

Aussie 02-06-2004 06:43 AM

Ok, now we need your XF86Config.

brisemec 02-09-2004 05:11 AM

Woohoo! It's working!!!!!

Yesterday I was editing my XF86Config file and now all 3 cards are working. I had already tried to edit it but it didn't work, must have done something wrong.

Thanks to all for your help! :)


All times are GMT -5. The time now is 12:42 PM.